Kodi Community Forum
[RELEASE] XeeBo - Eden (PVR support) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Skin Help and Support (/forumdisplay.php?fid=67)
+---- Forum: XeeBo (/forumdisplay.php?fid=140)
+---- Thread: [RELEASE] XeeBo - Eden (PVR support) (/showthread.php?tid=105258)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19


[RELEASE] XeeBo - Eden (PVR support) - Hitcher - 2011-07-10 22:26

Available from the official repo and my own for the most up-to-date version.

Mouse/touch screen volume control -

Video


- bandelguy - 2011-07-25 05:44

I have been eagerly waiting for the pre-eden version. Thanks for release. Btw, when it would show in the pre-eden repo?


- Hitcher - 2011-07-25 10:36

Normally a couple of days.


- lunerceli - 2011-07-26 05:34

How would one be able to get the new version if they wanted to get it now Hitcher??


- Hitcher - 2011-07-26 07:41

From my Google Code source.


- bandelguy - 2011-07-26 07:49

I have downloaded Xeebo through Tortoise SVN.

Can I update the skin in future through SVN, just like I do for other skins (Transparency or Backrow) ?

Remarks after using the skin
WOW! The skin is amazingly smooth.


Any plans for including:

1. Studio Flags (may be, when there is an official studio logos pack / are used like a script).
2. Including 2 or more upcoming tracks in the music "Now playing".
3. TV shows Logo support.


- Hitcher - 2011-07-26 15:01

bandelguy Wrote:I have downloaded Xeebo through Tortoise SVN.

Can I update the skin in future through SVN, just like I do for other skins (Transparency or Backrow) ?

Sure, that's where XBMC will compile the official releases from anyway.

bandelguy Wrote:Remarks after using the skin
WOW! The skin is amazingly smooth.

Thanks, I'm always changing things to try and improve the efficiency.

bandelguy Wrote:Any plans for including:

1. Studio Flags (may be, when there is an official studio logos pack / are used like a script).
2. Including 2 or more upcoming tracks in the music "Now playing".
3. TV shows Logo support.

1. Possibly.
2. There's only room for one line and it would look odd if it said 'Next' when it was actually the one after the next track and then the one after that.
3. I don't really see them fitting in with the layout style used in XeeBo.


- bandelguy - 2011-07-26 16:30

Hitcher Wrote:1. Possibly.
2. There's only room for one line and it would look odd if it said 'Next' when it was actually the one after the next track and then the one after that.
3. I don't really see them fitting in with the layout style used in XeeBo.

No. 2 and 3 are not so important for me. Yes, going by the OSD design for XEEBO, I agree with you.

I used Boxee for sometime, on a trial basis, and after using Xeebo, I find Xeebo less complicated in navigation than Boxee.


- gobbledigook - 2011-07-27 17:07

bandelguy Wrote:2. Including 2 or more upcoming tracks in the music "Now playing".

pity this can't be done.... i've been having dreams about an interactive type playlist where you can switch between library mode and now playing and edit the tracks you have queued up easily... my idea involves a split screen type display but i'm no coder Sad


- lunerceli - 2011-07-29 07:39

What is the svn address for Xeebo??

nevermind, i am just waking up and being retarded this morning...LOL


- bandelguy - 2011-07-29 10:16

lunerceli Wrote:What is the svn address for Xeebo??

nevermind, i am just waking up and being retarded this morning...LOL



use Svn software to checkout:

http://xbmc-skin-xeebo-eden.googlecode.com/svn/trunk/


- Kalliban - 2011-07-29 21:17

I have a strange error. The subtitle script didn't work, so I tried uninstalling it and reinstalling it, then removing it from skin settings and rechoosing it there. It still didn't work, so I checked the VideoOSD.xml file and changed the "$INFO[Skin.String(SubtitlesPath)]" to "script.xbmc.subtitles" on line 192 and then it worked. If I checked the xbmc.log before it seems like the skin's setting for the path isn't saved somehow (it tries to run "runscript()"). Is this a bug or maybe some cache or something I can fix myself? Big Grin

PS. The error was there on 2.1.7, and I tried updating to 2.1.8 without any change.


- Hitcher - 2011-07-29 22:37

If you looked at the control group above you'd see that it uses <onclick>RunScript(script.xbmc.subtitles)</onclick> if you haven't set your own Subtitles addons in the Skin settings.


- Kalliban - 2011-07-29 23:24

Hitcher Wrote:If you looked at the control group above you'd see that it uses <onclick>RunScript(script.xbmc.subtitles)</onclick> if you haven't set your own Subtitles addons in the Skin settings.

I know, that's why I changed the other control group to that. Like I said, I have set the path in the skin settings, but according to the log it just tries to run RunScript(), hence the path to the script is null.

In order to make it work, I set it to script.xbmc.subtitles even if the setting is saved.

Since it goes to the second control group, the setting is saved, but the call to the path ("RunScript($INFO[Skin.String(SubtitlesPath)])") only runs RunScript(), in other words the $INFO[Skin.String(SubtitlesPath)] returns null. Is this a bug or may it just be my setup that has an error somewhere? I recently upgraded to a nightly build of xbmc.


- Hitcher - 2011-07-29 23:42

Fixed, it was a damn typo.

Cheers.