Kodi Community Forum
[Web Interface Addon] AWXi - Ajax Based Web Interface - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Web Interfaces (/forumdisplay.php?fid=156)
+---- Thread: [Web Interface Addon] AWXi - Ajax Based Web Interface (/showthread.php?tid=112956)



RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - neoflex - 2012-05-04 00:07

I use HDMI myself to connect my HTPC to the AV Receiver but the HTPC is always on because I use it also as a nas.
So, in my case, XBMC being always launched but not the receiver I needed a way to turned it on when a media is launched via AWX Wink


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - john.cord - 2012-05-04 16:03

Yes, Frodo support... !!!!

But not working :-(


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-04 22:46

(2012-05-04 16:03)john.cord Wrote:  Yes, Frodo support... !!!!

But not working :-(

The new version has been pulled into the official repo and should work with frodo afaik.


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - bac522 - 2012-05-05 13:49

Really enjoy using this web interface. One request I have is can we add long seek buttons to the player interface on the main screen and the system control screen? I watch auto racing, but sometimes the pre-race shows are boring and want to just long seek through it. Although on the main screen maybe not such a big deal since I can just click somewhere on then "Currently Playing" bar to zoom ahead.

[Image: control.jpg]


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-05 14:35

I am planning on changing the full screen controls a bit but why not use the progress bar out of interest?


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - bac522 - 2012-05-05 14:39

(2012-05-05 14:35)Mizaki Wrote:  I am planning on changing the full screen controls a bit but why not use the progress bar out of interest?

Smile Just updated my prior post stating just that...brain cramp in forgetting that I could do it that way to get through some of the pre-race stuff I'm not interested in. Although that doesn't work so well when trying to get through 2-5 minutes of commercials, always over or under shoot, that's where a long seek would be nice.


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-05 16:22

If possible I'll make a double click action to do a larger jump and I plan to add in fast forward and rewind buttons Smile


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - john.cord - 2012-05-06 18:00

(2012-05-04 22:46)Mizaki Wrote:  
(2012-05-04 16:03)john.cord Wrote:  Yes, Frodo support... !!!!

But not working :-(

The new version has been pulled into the official repo and should work with frodo afaik.

ok, is working now.... what about the covers? do not load in my case... anything to do to get them loading?

And what do i have to delete to geht it working in Firefox? Deleted the Browsercach but still do not work.

On my Galaxy Tab 10.1 it looks like this with long Album Names... maybe implement a fixed end point were the text is going to scroll instead of overlap with the codec and channel logos...

http://666kb.com/i/c3kccygw5q9t12vzp.jpg


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-06 18:19

Clear your cache is always a good first port of call. You can try turning lazyLoad off if it's on. Otherwise I'll need more info. Check the wiki page for debugging.


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - john.cord - 2012-05-07 00:34

(2012-05-06 18:19)Mizaki Wrote:  Clear your cache is always a good first port of call. You can try turning lazyLoad off if it's on. Otherwise I'll need more info. Check the wiki page for debugging.

Cleared cach in Firefox but still does not work. In Chrome or IE it is working...

Will look into the wiki...

EDIT: Debug Info from Web Console:

Code:
[00:40:13.259] POST http://192.168.1.23:8080/jsonrpc?awx [HTTP/1.1 415 Unsupported Media Type 4ms]
[00:40:13.264] POST http://192.168.1.23:8080/jsonrpc?awx [HTTP/1.1 415 Unsupported Media Type 4ms]
[00:40:13.269] Kein Element gefunden @ http://192.168.1.23:8080/jsonrpc?awx:1
[00:40:18.262] POST http://192.168.1.23:8080/jsonrpc?awx [HTTP/1.1 415 Unsupported Media Type 4ms]
[00:40:18.267] POST http://192.168.1.23:8080/jsonrpc?awx [HTTP/1.1 415 Unsupported Media Type 2ms]
[00:40:18.272] Kein Element gefunden @ http://192.168.1.23:8080/jsonrpc?awx:1
[00:40:23.269] POST http://192.168.1.23:8080/jsonrpc?awx [HTTP/1.1 415 Unsupported Media Type 29ms]

Imho a browser problem but what else could i do than clean the cach? Thums are not working in any browser...

EDIT:

Cleared Everything (Cach, Cookies etc...) but still shows that error.


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-07 01:05

Right, I'm pretty sure if you are using Frodo you are not up-to-date enough. Firefox work-around


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - john.cord - 2012-05-07 09:45

(2012-05-07 01:05)Mizaki Wrote:  Right, I'm pretty sure if you are using Frodo you are not up-to-date enough. Firefox work-around

ah, ok. thx


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-07 18:06

Instead of any proper, well as far I ever do "proper", coding I added a movie logo view! Woo!
[Image: 5uigwx.jpg]
Umm... yeah, get busy making film logos people! Rofl

fanart.tv in case anyone doesn't know where they come from.


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - john.cord - 2012-05-09 09:07

For me logos or covers or any other thumbnails do not work...

And still errors when trying to add files stored on a USB Drive to the playlist:

Foder structure is: HARDDRIVE/MUSIC/ALBUMNAME/files. Drive is mounted under ubuntu in the /media directory... only for files not in database...


RE: [Web Interface Addon] AWX-Eden - Ajax Based Web - Mizaki - 2012-05-09 17:23

This is still Frodo I assume? What about Eden? You really shouldn't be using Frodo daily. Eden is only just out the door. I would expect Frodo to be broken quite often until near the beta phase. Of course I will be looking at Frodo (web sockets!) but don't expect it or AWXi to work without issue.

That said, assuming Frodo and some general knowledge:
Do they work in the skin (logos especially)?
Are the files local or SMB/NFS shares etc?
Is this all browsers?
If you copy the VFS path of the image and open it in a new tab, does it show?
Does any other external interface show the images?

I might think of some more. But basically: is it just AWXi or a general problem?