Kodi Community Forum
Artwork Downloader - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (/forumdisplay.php?fid=151)
+---- Thread: Artwork Downloader (/showthread.php?tid=114633)



RE: [Release] Artwork Downloader - Bladerunner1962 - 2012-06-08 17:39

GENERAL QUESTION how to load pictures

Hi, I have already the artwork downloader in my system.

Perhaps I would actualise or load a picture to the movie, how I have to do that?
Is Artwork Download loading all founded pictures of my whole DB into a file folder?

For e.g. a defined movie: where in XBMC I can update the thumbs/pictures
for this movie? Is there a submenu to be open on the movie file?


RE: [Release] Artwork Downloader - Martijn - 2012-06-08 17:41

(2012-06-08 17:32)Goulet Wrote:  Hi Martijn, thanks for the quick reply. Is the log I pasted not the full debug log?
One thing I've noticed when looking at the log myself is there seems to be a user and password in for the SMB that i don't recall putting myself. I have just deleted and readded the source without specifying any password and I'm still getting:

95458985792 DEBUG: OpenDir - Using authentication url smb://xbox:xbox@OURPC/L/Backup%20Movies/Men%20in%20Black%20%281997%29/extrathumbs
13:43:47 T:140695458985792 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://xbox:xbox@OURPC/L/Backup%20Movies/Men%20in%20Black%20%281997%29/extrathumbs'
unix_err:'2' error : 'No such file or directory'

When I go into sources.xml I can see there's defintely no smb usernames/passwords specified
Thanks again

This was meant for you:
I see a lot of weird things. Ever tried reinstalling OpenElec?
Also check your network connection and make sure you have internet acces

There is something wrong in the way you added your sources cause it adds something.
Remove the sources.xml and commoncache.db file and start over. also clean your library.


RE: [Release] Artwork Downloader - acandido - 2012-06-08 18:16

(2012-06-08 17:32)Goulet Wrote:  
(2012-06-08 17:16)Martijn Wrote:  
(2012-06-08 16:21)Goulet Wrote:  Hi everyone,

This add-on looks amazing but I've so far been unsuccessful in getting it to work. When I try to get artwork for Movies or TV I just get "0 downloaded".

Log: http://paste.ubuntu.com/1030379/

I'm using OpenELEC 2.0 Beta 4(1.95.4) and it's happening for all SMB sources. I get the same problem with cdart add-on so obviously something wrong with my setup but I can't figure out what Smile

I've checked that my sources have write access in case that might have been an issue.

Can't wait to get this working, thanks so much for looking.

I see a lot of weird things. Ever tried reinstalling OpenElec?
Also check your network connection and make sure you have internet acces

(2012-06-08 16:22)schumi2004 Wrote:  More and more i'm getting this nasty error which locks my XBMC instance.

http://pastebin.com/QR0hx5gF

Any ideas?

No idea. Nothing I can do about at least. Perhaps the full debug log would tell something

Hi Martijn, thanks for the quick reply. Is the log I pasted not the full debug log?
One thing I've noticed when looking at the log myself is there seems to be a user and password in for the SMB that i don't recall putting myself. I have just deleted and readded the source without specifying any password and I'm still getting:

95458985792 DEBUG: OpenDir - Using authentication url smb://xbox:xbox@OURPC/L/Backup%20Movies/Men%20in%20Black%20%281997%29/extrathumbs
13:43:47 T:140695458985792 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://xbox:xbox@OURPC/L/Backup%20Movies/Men%20in%20Black%20%281997%29/extrathumbs'
unix_err:'2' error : 'No such file or directory'

When I go into sources.xml I can see there's defintely no smb usernames/passwords specified
Thanks again

Credentials could also be coming from passwords.xml.


RE: [Release] Artwork Downloader - Goulet - 2012-06-08 21:22

(2012-06-08 17:41)Martijn Wrote:  
(2012-06-08 17:32)Goulet Wrote:  Hi Martijn, thanks for the quick reply. Is the log I pasted not the full debug log?
One thing I've noticed when looking at the log myself is there seems to be a user and password in for the SMB that i don't recall putting myself. I have just deleted and readded the source without specifying any password and I'm still getting:

95458985792 DEBUG: OpenDir - Using authentication url smb://xbox:xbox@OURPC/L/Backup%20Movies/Men%20in%20Black%20%281997%29/extrathumbs
13:43:47 T:140695458985792 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://xbox:xbox@OURPC/L/Backup%20Movies/Men%20in%20Black%20%281997%29/extrathumbs'
unix_err:'2' error : 'No such file or directory'

When I go into sources.xml I can see there's defintely no smb usernames/passwords specified
Thanks again

This was meant for you:
I see a lot of weird things. Ever tried reinstalling OpenElec?
Also check your network connection and make sure you have internet acces

There is something wrong in the way you added your sources cause it adds something.
Remove the sources.xml and commoncache.db file and start over. also clean your library.

Cool, thanks. I'm going to do a clean reinstall of OpenElec over the weekend, thanks for taking the time to respond.

cheers


RE: [Release] Artwork Downloader - Martijn - 2012-06-08 21:36

perhaps first check what acandido suggested.
check passwords.xml


RE: [Release] Artwork Downloader - schumi2004 - 2012-06-09 16:10

(2012-06-08 17:16)Martijn Wrote:  
(2012-06-08 16:22)schumi2004 Wrote:  More and more i'm getting this nasty error which locks my XBMC instance.

http://pastebin.com/QR0hx5gF

Any ideas?

No idea. Nothing I can do about at least. Perhaps the full debug log would tell something

Nothing useful in debug log i think

http://pastebin.com/BGWK47P4


RE: [Release] Artwork Downloader - Deano316 - 2012-06-09 16:17

Is there a delay beween logos being added to fanart.tv and logos being scraped into XBMC? I've noticed that whilst the Artwork Downloader works great (kudos by the way Wink) the scraper seems to be a few days behind.


RE: [Release] Artwork Downloader - Martijn - 2012-06-09 16:19

(2012-06-09 16:17)Deano316 Wrote:  Is there a delay beween logos being added to fanart.tv and logos being scraped into XBMC? I've noticed that whilst the Artwork Downloader works great (kudos by the way Wink) the scraper seems to be a few days behind.

could be a max of 7days to take the load of the server


RE: [Release] Artwork Downloader - Deano316 - 2012-06-09 16:25

That explains it Wink


RE: [Release] Artwork Downloader - Martijn - 2012-06-09 16:47

(2012-06-09 16:10)schumi2004 Wrote:  
(2012-06-08 17:16)Martijn Wrote:  
(2012-06-08 16:22)schumi2004 Wrote:  More and more i'm getting this nasty error which locks my XBMC instance.

http://pastebin.com/QR0hx5gF

Any ideas?

No idea. Nothing I can do about at least. Perhaps the full debug log would tell something

Nothing useful in debug log i think

http://pastebin.com/BGWK47P4
that is not a FULL Debug Log
Problem is in a module that I use so can't do anything about that


RE: [Release] Artwork Downloader - htpc guy - 2012-06-09 17:45

*Feature Request*

So I just spent a few days creating movie logos, which I have not yet uploaded. I estimate that I've made about 50-60 new logos that i plan on uploading soon. I'm happy to report that I now have all of my movies stocked with logos. Big Grin

Anyway, it would be nice if AD had an option to tie into the fanart.tv website and upload any logos on my local server that were not on the website. That would make the upload process so much easier.


RE: [Release] Artwork Downloader - Bladerunner1962 - 2012-06-09 17:50

I had read, that I only could use the Artwork Download if I have for
each movie file a special folder on my drive?
Do you all have done so? Hundrets of folders?

Or is it possible to use it on a other way?


RE: [Release] Artwork Downloader - Martijn - 2012-06-09 17:53

(2012-06-09 17:45)htpc guy Wrote:  *Feature Request*

So I just spent a few days creating movie logos, which I have not yet uploaded. I estimate that I've made about 50-60 new logos that i plan on uploading soon. I'm happy to report that I now have all of my movies stocked with logos. Big Grin

Anyway, it would be nice if AD had an option to tie into the fanart.tv website and upload any logos on my local server that were not on the website. That would make the upload process so much easier.
Thanks. Will forward to those Smile

Adding such a feature would require massive rewriting an our job so much harder Wink
Imagine all the details that need to be added on the upload process. Like language/season/comments and so on.
IMO it isn't really worth the effort for such a small usergroup (sorry about that Smile )

Besides that option isn't available on fanart.tv and that would need to be properly developed first. Perhaps when Frodo hits the shelves...


RE: [Release] Artwork Downloader - Martijn - 2012-06-09 17:56

(2012-06-09 17:50)Bladerunner1962 Wrote:  I had read, that I only could use the Artwork Download if I have for
each movie file a special folder on my drive?
Do you all have done so? Hundrets of folders?

Or is it possible to use it on a other way?

Yep all of them have separate folders.
No other way.

There are programs that can split all the movies into folders for you automatic


RE: [Release] Artwork Downloader - htpc guy - 2012-06-09 18:28

(2012-06-09 17:53)Martijn Wrote:  
(2012-06-09 17:45)htpc guy Wrote:  *Feature Request*

So I just spent a few days creating movie logos, which I have not yet uploaded. I estimate that I've made about 50-60 new logos that i plan on uploading soon. I'm happy to report that I now have all of my movies stocked with logos. Big Grin

Anyway, it would be nice if AD had an option to tie into the fanart.tv website and upload any logos on my local server that were not on the website. That would make the upload process so much easier.
Thanks. Will forward to those Smile

Adding such a feature would require massive rewriting an our job so much harder Wink
Imagine all the details that need to be added on the upload process. Like language/season/comments and so on.
IMO it isn't really worth the effort for such a small usergroup (sorry about that Smile )

Besides that option isn't available on fanart.tv and that would need to be properly developed first. Perhaps when Frodo hits the shelves...


Oh well, a guy can dream. Thanks anyway. I guess it would only be useful for a very small user base so I agree, if its that much work then its not worth it.