Kodi Community Forum
New Home for Ember Media Manager (Official Thread) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (/forumdisplay.php?fid=116)
+---- Forum: Ember Media Manager (/forumdisplay.php?fid=195)
+---- Thread: New Home for Ember Media Manager (Official Thread) (/showthread.php?tid=116941)



- Meez - 2012-01-09 19:22

i also have an issue with scraping tv shows/episodes. emm can detect new episodes, but it does not automatically scrape the data/images from tvbd or wherever it gets the data from. the episodes just show up as (ie. S01E11). i have to rescrape manually. the scrape button is also greyed out.


- bodrick - 2012-01-09 19:56

shadow_cruiser Wrote:+1. This is one of the best functions for me. Hopefully this feature can be fixedSmile

So I'm a little confused, and maybe its a setup issue, but i dug around today trying to resolve the trailer issue. Once I figured out how to enable the downloading of trailers it worked fine for me. I'm guessing that its possible that configuration wise it might not be enabled.

When editing a movie, is the little plus by the trailer url enabled or disabled, I'm guessing if its disabled, you need to enable trailer support under settings.

To do this go to settings, then the movies section. Under the Scrapers - Images and Trailers section make sure that Enable Trailer support is checked. Then under the section for the Ember Native Movie Scraper, make sure Trailer support is checked there and select from the respective trailer sites, warning AllHTPC is defunct and does not work ,I'm working on removing that option from the next release.

Once these have been done you should be able to download trailers using the green + on the edit movie section. I'm also assuming (I don't worry about trailers) that this will scrape them too if you have checked the required boxes.


- bodrick - 2012-01-09 20:00

Trigun Wrote:OK, thanks in advance.

So I loaded up my sets without any issues, how did you define the sets and you say some show and some don't, can you maybe send me an example nfo of one that shows and one that doesn;t? or create a bug on the project site and upload some examples there?

Thanks


- bodrick - 2012-01-09 20:01

upD8R Wrote:This is working? Need to test ...

Its possible the settings might not be right, I had the same problem, I just put up a post that details the right settings to enable trailer downloading.


- bodrick - 2012-01-09 20:13

evlcookie Wrote:I seem to have encountered an out of memory bug and it's only with 1 specific movie - Thor. It's working fine on every other movie and I certainly have enough HDD space.

This is the error that just happened.



This is also i would think the same one but different at the same time Big Grin

So it looks Thor is a special case, luckily I have the movie, it seems its having issue with a couple of the posters, namely because I think they are huge, the height is 2959 and the width is 1930 for one of the posters. Now saying that why its throwing an exception I'm not sure but I can recreate the issue which sometimes is the biggest battle. I'll see what I can do, plus the way the downloading of images works currently is grossly inefficient and I want to try and speed it up.


- seth.feinberg - 2012-01-09 20:38

Hey, anybody have any ideas on why my EMM installations is ignoring files that are clearly in their appropriate folders? I think I screwed up the installation somehow cause, for instance, looking at 12 Angry Men in EMM shows no fanart or poster but the 12 Angry Men folder clearly has a fanart.jpg and folder.jpg...

Also I still can't get SortTitle to actually work 100% of the time...


- bodrick - 2012-01-09 20:38

themugger Wrote:Hi, thx for the suggestions but unfortunetly the same result... Ember just sits in task manager and i have to manually kill the process. Anyone else got any other ideas?

Thanks

Do your log files give any indication of whats going on? I've not got much experience with the command line parameters or how it works yet, but maybe the log file might include something.


- bodrick - 2012-01-09 20:44

seth.feinberg Wrote:Hey, anybody have any ideas on why my EMM installations is ignoring files that are clearly in their appropriate folders? I think I screwed up the installation somehow cause, for instance, looking at 12 Angry Men in EMM shows no fanart or poster but the 12 Angry Men folder clearly has a fanart.jpg and folder.jpg...

Also I still can't get SortTitle to actually work 100% of the time...

Under the settings for Ember, go to the TV Shows Section and select the File and Sources entry. Then verify that for file naming section you have the correct files selected. I believe by default Ember doesn't have these setup correctly to reflect closely with XBMC or at least from my experience it wasn't quite the way I wanted it. Anyway verify there that the correct files are selected, if they are then something else is going on and I'll have to dig further.


- upD8R - 2012-01-09 21:09

bodrick Wrote:Its possible the settings might not be right, I had the same problem, I just put up a post that details the right settings to enable trailer downloading.
Thanks, I've seen your message and I've tried it successfully by myself.

Nevertheless, I have a question: What are the search parameters of Ember to fetch the list from Youtube? It seems it only finds English trailers (at least during my brief testing).

If it just queries for "movie title" and "trailer" I'd like to see an option to influence the search, e.g. by adding terms like "german" and "HQ" ...


- snowjim - 2012-01-09 21:20

I am also having problems with new episodes of Tv shows. I add a couple of episodes for diffrent TV shows and then hit Update Library button in Ember. The new episodes will be shown but I have to run the scraping manually?

There should really be a simple button under the TVShows tab where I can just click it and then it will update all episodes that is missing metadata from all TV Shows.

Now I will have to remeber over time witch Episodes I have added and if I do not let Ember fill this information before running XBMC, XBMC will use its own scraper to get it(witch is a no go).


- eljeh - 2012-01-09 21:35

snowjim Wrote:I am also having problems with new episodes of Tv shows. I add a couple of episodes for diffrent TV shows and then hit Update Library button in Ember. The new episodes will be shown but I have to run the scraping manually?

There should really be a simple button under the TVShows tab where I can just click it and then it will update all episodes that is missing metadata from all TV Shows.

Now I will have to remeber over time witch Episodes I have added and if I do not let Ember fill this information before running XBMC, XBMC will use its own scraper to get it(witch is a no go).

Sounds like the issue I'm having, The "Scrape Media" Button under TVShows was working fine, but now all of a sudden it grayed out.


Older sets not showing up in EMM - Silkdog569 - 2012-01-09 22:01

bodrick Wrote:So I loaded up my sets without any issues, how did you define the sets and you say some show and some don't, can you maybe send me an example nfo of one that shows and one that doesn;t? or create a bug on the project site and upload some examples there?

Thanks

Bodrick,

I to have the same issue with previous sets not showing. I believe it is the way this new version is adding in the Sets information to the NFO file. With previous versions the lines added to the NFO file was like this
<sets>
<set order="3">Jurassic Park Collection</set>
</sets>

Now with the current version 1.3.0.2 the line added is only this
<set>Jurassic Park Collection</set>

This just adds in the Set name but you can not set the order you want the movies to list as. Even though you add them into the box at the time of the setup of the set it does not save the order information. Each NFO file in the set says the same <set>Jurassic Park Collection</set>.

When going back to check the Set information in EMM the movies come up in alphabetical order.

You can go ahead and recreate all the sets and they will show up under EMM 1.3.0.2 but if if you want the movies to show up in the order you want that will not happen.
If you go back to a older version of EMM before you had picked it up the sets will not show either since the tags <Sets> are not in the NFO file.

I can still use older versions for creating Set information in the NFO so it is not a show stopper and I only create sets once in a while. I hope this can help track down what ever had changed in the new programing.

Just like to say Thank You for picking up EMM and continuing to improve and fix Issues. You are huge in doing so for so many.


- snowjim - 2012-01-09 23:01

eljeh Wrote:Sounds like the issue I'm having, The "Scrape Media" Button under TVShows was working fine, but now all of a sudden it grayed out.

Scrape Media is also grayd in my version (v1.3 rev2) in the TV Show tab but in Movies it is enabled.

I have however never used that button, I have always used right click and then (re)scrape, even with multiselections.

Im however not clear on how to update episodes? It is not obvious that there is new episodes if I not manually drill down to find them and to screap I will have to use the right menu on the seasion.

It would be nice if Ember could state that there is new episodes that needs scraping and that the global scrape button was enabled for this. Another better solution might be to auto scrape episodes for TV shows that is allready known(and locked).


- castortray - 2012-01-09 23:05

is this version of EMM support "XBMC scrapers" ?


- TeKo - 2012-01-09 23:09

castortray Wrote:is this version of EMM support "XBMC scrapers" ?

Dont know what you mean.

If you question is: if XBMC reads the data you scraped with Ember then Yes.