Kodi Community Forum
How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: How to Install XBMC PVR Xvba for AMD/Nvidia/Intel GPUs (/showthread.php?tid=116996)



RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - fritsch - 2012-03-25 21:00

If you can, please join #xbmc-xvba - there are some specialist concerning non-working audio


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - thefree - 2012-03-25 22:25

Hi

I have updated xbmc from https://launchpad.net/~wsnipex/+archive/xbmc-xvba 25.3.2012 (todays build) and I'm getting static from mp3 playback, and no music at all only hisss sound. Previuse build worked prefectly. I'm using ubuntu 11.10. Can somebody help?


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - fritsch - 2012-03-26 09:48

@thefree:
I tested it this morning shortly after your message. There is in deed a problem concerning music playback. Other music formats are non-working, too. I did not have time to look into this by detail.
To make this bug official, could you please open an issue at: https://github.com/FernetMenta/xbmc/issues?sort=created&direction=desc&state=open
Include a xbmc.log with debugging turned on.


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - wsnipex - 2012-03-26 19:08

(2012-03-25 22:25)thefree Wrote:  Hi

I have updated xbmc from https://launchpad.net/~wsnipex/+archive/xbmc-xvba 25.3.2012 (todays build) and I'm getting static from mp3 playback, and no music at all only hisss sound. Previuse build worked prefectly. I'm using ubuntu 11.10. Can somebody help?

This is fixed in the new package, plz upgrade


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - djvdthemaster - 2012-03-26 20:25

Hi all,

I just updated to the latest xmbc-xvba package so i got the latest release.
I am running ubuntu 64bit on my amd fusion e-350 and 2 days ago the 1080p playback
was pretty fine, only got a few hickups. So I was hoping this update would make things better.

I must admit that though I followed the installation guide, I could not find where
to fully disable compiz/unity 3d so please bear that in mind (and hopefully somebody could help me with that).

Anyways, I now got a problem and it might be compiz/unity 3d related:
the same 1080p movie plays now with colors all over it, and hickups every second:
http://imageshack.us/photo/my-images/194/screenshot007by.png/
^ this one

http://imageshack.us/photo/my-images/269/screenshot012u.png/
^ as you might notice from the second screenshot, there is text from my desktop on it.

I didnt do anything else regarding my config/graphics as far as I know the last few days.

Thanks for your time and help all!

PS: the hardware is like 5 days old so I dont think it is defective (at least i hope not)


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - fritsch - 2012-03-26 20:41

Quote:I must admit that though I followed the installation guide, I could not find where
to fully disable compiz/unity 3d so please bear that in mind (and hopefully somebody could help me with that).

The howto does use a minimal installation. no compiz / unity is installed by default.
If you made a full installation of ubuntu. Log out and use the unity-2D session.


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - djvdthemaster - 2012-03-26 20:46

(2012-03-26 20:41)fritsch Wrote:  
Quote:I must admit that though I followed the installation guide, I could not find where
to fully disable compiz/unity 3d so please bear that in mind (and hopefully somebody could help me with that).

The howto does use a minimal installation. no compiz / unity is installed by default.
If you made a full installation of ubuntu. Log out and use the unity-2D session.

That might be the only point in the manual I did not follow, as I already started configuring my full ubuntu 11.10 64bit installation, sorry.
Did re-login with unity-2d and got the same fractal-like things again Sad


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - fritsch - 2012-03-26 21:04

(2012-03-26 20:46)djvdthemaster Wrote:  
(2012-03-26 20:41)fritsch Wrote:  
Quote:I must admit that though I followed the installation guide, I could not find where
to fully disable compiz/unity 3d so please bear that in mind (and hopefully somebody could help me with that).

The howto does use a minimal installation. no compiz / unity is installed by default.
If you made a full installation of ubuntu. Log out and use the unity-2D session.

That might be the only point in the manual I did not follow, as I already started configuring my full ubuntu 11.10 64bit installation, sorry.
Did re-login with unity-2d and got the same fractal-like things again Sad

Any chance to try from a fresh installed minimal version?


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - djvdthemaster - 2012-03-26 21:32

(2012-03-26 21:04)fritsch Wrote:  
(2012-03-26 20:46)djvdthemaster Wrote:  
(2012-03-26 20:41)fritsch Wrote:  The howto does use a minimal installation. no compiz / unity is installed by default.
If you made a full installation of ubuntu. Log out and use the unity-2D session.

That might be the only point in the manual I did not follow, as I already started configuring my full ubuntu 11.10 64bit installation, sorry.
Did re-login with unity-2d and got the same fractal-like things again Sad

Any chance to try from a fresh installed minimal version?

Should be do-able, yes. Thanks for that suggestion.
But before that, I might try rebooting it a few times after the xbmc and xbmc-bin update off today (should that be necessary?)


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - djvdthemaster - 2012-03-26 22:54

Okay, update from me. After my reboot I found out:

1) starting ubuntu with unity 3d gives those strange fractals
2) starting in unity 2d works fine
3) starting in XBMC seems to be even a bit more smooth then unity 2d (because no desktop manager is running probably) ?

Anyways, it seems this problem was solved this way. Will boot into unity 2d standard, and if I might fail that config I will still do a minimal install.
Thanks for your time and help, appreciated. Keep up the great effort!


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - gfisher - 2012-03-27 07:05

Hi Wsnipex, Fritsch

Thanks for the mp3 fix. All good now.

? If you are building the code, what IDE do you prefer/use. I would like to see the project in its dev form, dialogs and all.


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - fritsch - 2012-03-27 07:41

Developing can be done with eclipse cdt. Just import the makefile project, after you did bootstrap and configure. I am building with make -j3 in parallel and afterwards let it runn through a remote session directly by eclipse.

More details we can discuss on irc.


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - thefree - 2012-03-27 16:20

Since upgrade mine is working fine, no problems at all.


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - SerGol - 2012-03-28 20:46

Please check.
A lot of drop frames Confused

Code:
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.0
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 3 frames
Format settings, GOP                     : M=2, N=24
Codec ID                                 : 27
Duration                                 : 19s 220ms
Bit rate                                 : 10.5 Mbps
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 50.000 fps
Standard                                 : Component
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.229
Stream size                              : 24.1 MiB (83%)
Color primaries                          : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
Transfer characteristics                 : BT.709-5, BT.1361
Matrix coefficients                      : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Example file
SF_zwei_HD-2012-03-28.ts (~29 Mb)


RE: Howto Install XBMC PVR Xvba for AMD/ATI Radeon and Fusion GPUs - fritsch - 2012-03-28 22:53

@SerGol:
Thanks for the sample file. I tried to reproduce this on my Zotac AD-10 System (Fusion E-350) and did not have a single drop. Can you attach a xbmc.log with debugging turned on when you play this file?

As the catalyst driver is sometimes really buggy, please consider to restart the machine before.