Kodi Community Forum
[WINDOWS][PATCH]Bitstream output of HD audio formats - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Development (/forumdisplay.php?fid=93)
+--- Thread: [WINDOWS][PATCH]Bitstream output of HD audio formats (/showthread.php?tid=121877)



RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - tjcinnamon - 2012-05-13 17:51

(2012-05-12 17:55)bluray Wrote:  
(2012-05-12 17:20)tjcinnamon Wrote:  I have an Onkyo RC-360 and a 5.1 Paradigm piece by piece set of speakers. They sound cherry so it'll be worth sorting this out.
It will work fine......it works flawless on my 7.2 RC270 so far....if you haven't update your Onkyo RC360 firmware, you can update it from here- Firmware Updates!

I can confirm with the non-AE version, it works with external programs such as netflix and emulators. Whereas, AE will not allow audio outside of XBMC while XBMC is running.

Are the best settings (for Onkyo RC360, HD6850), DTS-HD Master Audio and reduced core?


Re: [WINDOWS][PATCH]Bitstream output of HD audio formats - Martijn - 2012-05-13 17:55

Turn off exclusive mode IIRC.
However this may cause some other problems


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - {{INX}} - 2012-05-13 18:10

Can someone please help with a small issue I have?

I have installed the latest version (XBMCSetup 11.0 Eden+HD-audio) and all audio types up to Standard DTS work fine but when I try and play a True HD, DTS MA file, the Onkyo amp no longer picks up the audio (It always used to with previous versions).

Now I discovered that if I play a TrueHD. DTS MA film and press 'M' then go into the audio & subtitle menu and switch the films audio track back to standard DTS the amp clicks sound comes out fine, then if I switch back to True HD, DTS MA the amp then picks it up and all works fine.

Thanks in advance


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - tjcinnamon - 2012-05-13 18:42

(2012-05-13 17:55)Martijn Wrote:  Turn off exclusive mode IIRC.
However this may cause some other problems

I did and XBMC wouldn't open if it wasn't open, and if it was already open it wouldn't play video.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - tjcinnamon - 2012-05-14 01:37

(2012-05-12 17:20)tjcinnamon Wrote:  Are the best settings (for Onkyo RC360, HD6850), DTS-HD Master Audio and reduced core?



RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - Streamerke - 2012-05-14 23:17

Still one problem though: it seems that the HD audio patched version no longer supports AAC encoded movies, at least not with my receiver as I think my receiver is not capable of receiving this. The normal v11.0 Eden works fine, The patched version doesn't.

Is there a solution for this?


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - DanielaE - 2012-05-15 08:33

It does. I have AAC encoded movies in my set of test files. IIRC there were posts in this thread (or a related one) which basically pointed to a wrong setting in your profile (possibly debris from test runs with non-Eden stuff). Load it into an editor of your choice, search for AAC and passthrough, and erase that line. That should rectify your problem.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - Streamerke - 2012-05-15 11:40

(2012-05-15 08:33)DanielaE Wrote:  It does. I have AAC encoded movies in my set of test files. IIRC there were posts in this thread (or a related one) which basically pointed to a wrong setting in your profile (possibly debris from test runs with non-Eden stuff). Load it into an editor of your choice, search for AAC and passthrough, and erase that line. That should rectify your problem.

Errr.. hoe about Youtube video then? The same issue occurs with Youtube video that also has AAC sound: video appears in slomo with no sound at all.

Also I am a relatively new XBMC user. I did not understand your post. What should I load in where? What kind of editor? Are you talking about a settings file? Also, I never used anything earlier than Eden.

Sorry for my lack of knowledge Wink


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - sejanus - 2012-05-17 01:32

hi guys.

Got a problem with this Sad I have ripped my blurays to massive .mkv files with "makemkv". It works fine for most movies, but 4 won't play. They are the original star wars trilogy, and top gun. I think the common link between them is they all have 6.1 dts-hd soundtracks?

when I go to play them, the receiver doesn't pick up any sound and the video barely moves, it stutters along at barely a frame at a time.

but if I play a .mkv that has a 5.1 dts-hd track, it plays perfectly and the receiver gets the dts-hd master stream.

Any ideas?

I'm running this on a mac mini with windows 7, connected by hdmi to a denon 4311 receiver.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - uncola - 2012-05-17 09:19

Hi Sejanus. We explored this dts es 6.1 issue earlier in the thread. I have the exact same issue with the same movies, star wars original, I'm also using a mac mini 2011 running windows 7, but I'm using an onkyo receiver. We weren't able to figure it out, it might be a mac mini issue..


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - sejanus - 2012-05-17 09:29

thanks for the info uncola. thats a shame. I'll recode the soundtracks in the meantime to get around it.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - a5ian300zx - 2012-05-17 12:47

thanks, my issues are now resolved after installing the Eden AE stable version.

thanks once again.


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - bluray - 2012-05-17 16:11

(2012-05-17 09:19)uncola Wrote:  Hi Sejanus. We explored this dts es 6.1 issue earlier in the thread. I have the exact same issue with the same movies, star wars original, I'm also using a mac mini 2011 running windows 7, but I'm using an onkyo receiver. We weren't able to figure it out, it might be a mac mini issue..
Have you try it with "High Definition Audio Codecs"?


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - olizan - 2012-05-17 21:08

Hello,

i have some problem when htpc came out from sleep mode. My resolution has changed.
Do you have an idea ?

regards

olivier

Config :
AMD Athlon II X2 250 - Processeur Dual Core Socket AM3 0.045 micron Cache L2 2 Mo - Stepping C3
Antec NSK1380-EC - Boitier mini desktop avec alimentation 350W
ASRock 880GMH/U3S3 - Carte mère Micro ATX Socket AM3 AMD 880G
ASRock Smart Remote - Télécommande pour PC
Kingston ValueRAM 4 Go (2 x 2 Go) DDR3 1066 MHz CL7 - Kit Dual Channel DDR3 PC3-8500 CL7 - KVR1066D3S8N7K2/4G (garantie à vie par Kingston)
windows 7 64 bits

Ampli Onkyo TX-NR709
Plasma Panasonic TH42PV700F


RE: [WINDOWS][PATCH]Bitstream output of HD audio formats - mrhyde1969 - 2012-05-19 09:39

(2012-05-17 21:08)olizan Wrote:  Hello,

i have some problem when htpc came out from sleep mode. My resolution has changed.
Do you have an idea ?

regards

olivier

Config :
AMD Athlon II X2 250 - Processeur Dual Core Socket AM3 0.045 micron Cache L2 2 Mo - Stepping C3
Antec NSK1380-EC - Boitier mini desktop avec alimentation 350W
ASRock 880GMH/U3S3 - Carte mère Micro ATX Socket AM3 AMD 880G
ASRock Smart Remote - Télécommande pour PC
Kingston ValueRAM 4 Go (2 x 2 Go) DDR3 1066 MHz CL7 - Kit Dual Channel DDR3 PC3-8500 CL7 - KVR1066D3S8N7K2/4G (garantie à vie par Kingston)
windows 7 64 bits

Ampli Onkyo TX-NR709
Plasma Panasonic TH42PV700F

This is the Bitstream patch forum!!