Kodi Community Forum
[RELEASE] XBMC Subtitles - Addon Script - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Subtitle Add-ons (/forumdisplay.php?fid=143)
+---- Thread: [RELEASE] XBMC Subtitles - Addon Script (/showthread.php?tid=126495)



RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-22 16:10

(2012-04-22 15:50)mr_blobby Wrote:  
(2012-04-17 14:11)amet Wrote:  
(2012-04-17 14:09)Thakoer Wrote:  Amet thanks for that. holland we will really appreciate this. haha
Their website is indeed changed. I had read in their forum.
when is the last update of your then?

thanks.
I never said ill do it Smile

I didnt do ondertitel service, need to check who did
I did the ondertitel service and I've fixed it for the site redesign.
I also added a simple sync detection for this service.
The changes have been commited to the development repository on github and will be included in a new version of the subtitle addon.

thx a lot!!

I really need to make a list of service contributors Smile


RE: [RELEASE] XBMC Subtitles - Addon Script - Thakoer - 2012-04-22 22:02

Amet

When can wexpwxt the new update ?
[quote='Thakoer' pid='1083824' dateline='1335124925']
Amet

When can we expect the new update?


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-22 22:18

(2012-04-22 22:02)Thakoer Wrote:  Amet

When can wexpwxt the new update ?
[quote='Thakoer' pid='1083824' dateline='1335124925']
Amet

When can we expect the new update?

soon


RE: [RELEASE] XBMC Subtitles - Addon Script - keoma - 2012-04-23 01:13

Hello I'm having a problem searching for subtitles. I get the following error message: Error 'ascii' codec can't decode byte 0xc3 in position "X" ordinal not in range(128). "X" is variable. Looking at the log gives me no clues really, but googling around tells me this is a pretty common python error related to UTF8. Perhaps its related to the asian titles showing up?

http://pastebin.com/z8fisPMC

Running xbmcbuntu out of the box on Asrock 330HT


RE: [RELEASE] XBMC Subtitles - Addon Script - Thakoer - 2012-04-23 16:03

Amet thanks

The people in holland can't wait haahh...success and I see it soon !!


RE: [RELEASE] XBMC Subtitles - Addon Script - misa - 2012-04-23 16:56

(2012-04-23 01:13)keoma Wrote:  Hello I'm having a problem searching for subtitles. I get the following error message: Error 'ascii' codec can't decode byte 0xc3 in position "X" ordinal not in range(128). "X" is variable. Looking at the log gives me no clues really, but googling around tells me this is a pretty common python error related to UTF8. Perhaps its related to the asian titles showing up?

http://pastebin.com/z8fisPMC

Running xbmcbuntu out of the box on Asrock 330HT

Same here..........after I updated to the new service.py


RE: [RELEASE] XBMC Subtitles - Addon Script - rocko_2006 - 2012-04-24 02:10

It seems to be a problem with subtitles compressed with rar (from http://www.subdivx.com at least), the addon get stuck in "downloading subtitles..." until I press ESC, but it only happens with rar files, if I select a subtitle compressed with zip, it gets downloaded and everything is OK.

Here is a log of an attempt to download a rar file:

http://xbmclogs.com/show.php?id=1858

Note: I checked (downloading the file manually) that there aren't more than 1 srt inside the rar file, and the name of the srt don't contain any spanish characters (like "ñ" or "¿")


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-24 08:53

(2012-04-24 02:10)rocko_2006 Wrote:  It seems to be a problem with subtitles compressed with rar (from http://www.subdivx.com at least), the addon get stuck in "downloading subtitles..." until I press ESC, but it only happens with rar files, if I select a subtitle compressed with zip, it gets downloaded and everything is OK.

Here is a log of an attempt to download a rar file:

http://xbmclogs.com/show.php?id=1858

Note: I checked (downloading the file manually) that there aren't more than 1 srt inside the rar file, and the name of the srt don't contain any spanish characters (like "ñ" or "¿")

I believe that would happen with Linux builds that have no RAR support.

see here, http://xbmc.org/theuni/2012/04/10/xbmc-accepted-into-debian/ RAR support is disabled

EDIT: granted, we could handle that failure more gracefully Smile


RE: [RELEASE] XBMC Subtitles - Addon Script - Oemar - 2012-04-24 12:12

(2012-04-22 22:18)amet Wrote:  
(2012-04-22 22:02)Thakoer Wrote:  Amet

When can wexpwxt the new update ?
[quote='Thakoer' pid='1083824' dateline='1335124925']
Amet

When can we expect the new update?

soon


The boy (mr blobby) who fixed it deserves a compliment. We have a month can not make use of ondertiteling.com and now it's made a long delay before an update is ...


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-24 13:15

we all have a day job, I don't appreciate you bitching about it... if you don't like it, don't use it... simple

we owe you nothing, everything that has been done is done out of good will, it will be pushed to official repo when we think its ready, not a second earlier....

its on git, pull it from there if you need it now...


RE: [RELEASE] XBMC Subtitles - Addon Script - keoma - 2012-04-24 13:24

Hey Amet, sorry to be nagging on you. Regarding my problem posted earlier, is there anything else i can provide you with to help you locate the problem? A full debug log or anything?


RE: [RELEASE] XBMC Subtitles - Addon Script - misa - 2012-04-24 13:27

(2012-04-23 16:56)misa Wrote:  
(2012-04-23 01:13)keoma Wrote:  Hello I'm having a problem searching for subtitles. I get the following error message: Error 'ascii' codec can't decode byte 0xc3 in position "X" ordinal not in range(128). "X" is variable. Looking at the log gives me no clues really, but googling around tells me this is a pretty common python error related to UTF8. Perhaps its related to the asian titles showing up?

http://pastebin.com/z8fisPMC

Running xbmcbuntu out of the box on Asrock 330HT

Same here..........after I updated to the new service.py

Did anyone noticed this?..............problem still stands on the new service.py


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-24 13:29

(2012-04-24 13:24)keoma Wrote:  Hey Amet, sorry to be nagging on you. Regarding my problem posted earlier, is there anything else i can provide you with to help you locate the problem? A full debug log or anything?

full debug log is always needed, but I know there are utf-8 issues... I am working on it but its difficult when I cant reproduce on my side Sad


RE: [RELEASE] XBMC Subtitles - Addon Script - amet - 2012-04-24 13:30

(2012-04-24 13:27)misa Wrote:  
(2012-04-23 16:56)misa Wrote:  
(2012-04-23 01:13)keoma Wrote:  Hello I'm having a problem searching for subtitles. I get the following error message: Error 'ascii' codec can't decode byte 0xc3 in position "X" ordinal not in range(128). "X" is variable. Looking at the log gives me no clues really, but googling around tells me this is a pretty common python error related to UTF8. Perhaps its related to the asian titles showing up?

http://pastebin.com/z8fisPMC

Running xbmcbuntu out of the box on Asrock 330HT

Same here..........after I updated to the new service.py

Did anyone noticed this?..............problem still stands on the new service.py

what new service.py? did you read the first post of this thread?


RE: [RELEASE] XBMC Subtitles - Addon Script - muzzol - 2012-04-24 19:35

amet, what locales are you using?

any UTF-8 should help reproducing this problem.