Kodi Community Forum
Button infolabels - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Skin Development (/forumdisplay.php?fid=12)
+--- Thread: Button infolabels (/showthread.php?tid=128659)



Button infolabels - pecinko - 2012-04-12 15:59

<label fallback="1">$INFO[Skin.String(MyName)]</label>

does not work for button control. Is this expected or is it a bug?


RE: Button infolabels - pecinko - 2012-04-12 16:28

Curious enough $VAR works. Trac it?


RE: Button infolabels - Hitcher - 2012-04-12 16:59

Variables are great; can't wait until we can use them for positions and sizes.


RE: Button infolabels - pieh - 2012-04-12 17:01

by "does not work" You mean it will display fallback value or just nothing?


RE: Button infolabels - pecinko - 2012-04-12 17:12

(2012-04-12 17:01)pieh Wrote:  by "does not work" You mean it will display fallback value or just nothing?

By does not work I mean there is no label at all.

EDIT:

This works:

PHP Code:
<variable name="MyVar">
    <
value condition="!IsEmpty(Skin.String(MyName))">$INFO[Skin.String(MyName)]</value>
    <
value>$LOCALIZE[1]</value>
  </
variable



RE: Button infolabels - pieh - 2012-04-12 17:37

I put this in confluence home window as a test and it seems to be working.
Code:
<control type="button" id="9292">
      <description>Title label</description>
      <posx>170</posx>
      <posy>285</posy>
      <height>30</height>
      <width>1000</width>
      <label fallback="1">$INFO[Skin.String(SubtitleScript_Path)]</label>
    </control>
It seems something more is involved here.

Does this button is in container? Need more details to reproduce it.


RE: Button infolabels - pecinko - 2012-04-12 19:15

OK.

I have buttons in grouplist control.

Here is what is happening if I use the button from your example and place it separately (NO grouplist):

PHP Code:
<control type="button" id="9292">
      <
description>Title label</description>
      <
posx>170</posx>
      <
posy>485</posy>
      <
height>30</height>
      <
width>1000</width>
      <
font>size22</font>
      <
label fallback="1">$INFO[Skin.String(SubtitleScript_Path)]</label>
    </
control

I have NO label when Skin.String is empty and have subtitle script path when add-on is set.

If I make a variable:

PHP Code:
<variable name="TEST">
    <
value condition="!IsEmpty(Skin.String(SubtitleScript_Path))">$INFO[Skin.String(SubtitleScript_Path)]</value>
    <
value>$LOCALIZE[1]</value>
  </
variable

and use it as:
PHP Code:
<control type="button" id="9292">
      <
description>Title label</description>
      <
posx>170</posx>
      <
posy>485</posy>
      <
height>30</height>
      <
width>1000</width>
      <
font>size22</font>
      <
label>$VAR[TEST]</label>
      <!--<
label fallback="1">$INFO[Skin.String(SubtitleScript_Path)]</label>-->
    </
control

everything works as expected. I have this problem only with buttons - labels in or out of container are working fine.

Eden build on OS X 10.7.3.


RE: Button infolabels - pieh - 2012-04-12 19:48

Right, I found that we simply don't use fallback attribute for buttons. We'll get that fixed.