Kodi Community Forum
[Linux] HDMI video cutting out randomly - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Linux and Live support (/forumdisplay.php?fid=52)
+---- Thread: [Linux] HDMI video cutting out randomly (/showthread.php?tid=128706)



HDMI video cutting out randomly - cquilliam - 2012-04-12 22:55

I have a Zotac Mag HD-ND01 using the ION chipset. I recently wiped it out and did a fresh install of the latest XBMCuntu. Since the re-install, I've been having this annoying issue of my HDMI video cutting out on me randomly. And the only way to fix it is to unplug the HDMI cable from the back of the machine and plugging it back in. This happens once every few hours, sometimes I can be watching videos, other times it can be just sitting in the menu. I use optical audio, and that continues when the screen cuts out. I have tried 3 different HDMI cables to ensure that wasn't the issue. Prior to this re-install, I was running an earlier version of XBMClive, and the HDMI was perfect with no issues whatsoever.

Quote:htpc@xbmc:~$ dpkg --list | grep nvidia
ii nvidia-current 280.13-0ubuntu6.1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 280.13-0ubuntu2 Tool of configuring the NVIDIA graphics driver

I'm not sure what logs I would need, so if any additional information that is needed, just let me know. I don't really want to have to restore back my old install, so I'm hoping to get this fixed. Thanks.


RE: HDMI video cutting out randomly - teeedubb - 2012-04-13 00:30

Tried updating your nvidia drivers?


RE: HDMI video cutting out randomly - Plaguester - 2012-04-13 02:24

There are some newer ones in the repository. Try those first. I presume that you've already tried a different cable and port (if available)? To try an older version of the driver:

Code:
# List available versions
$ apt-cache madison nvidia-current

# find the version you want, then
$ sudo apt-get install nvidia-current=<version>

If that works, then you can keep the package from updating to the newest one with:
Code:
$ echo nvidia-current hold | dpkg --set-selections

If that doesn't work, post your /etc/X11/xorg.conf file.