Kodi Community Forum
[BUG] Colordiffuse for slider control - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Skin Development (/forumdisplay.php?fid=12)
+--- Thread: [BUG] Colordiffuse for slider control (/showthread.php?tid=132068)



[BUG] Colordiffuse for slider control - phil65 - 2012-05-22 03:16

Colordiffuse only applies to slider itself, not to the focustexture for example.
for radiobuttons everything (except labels of course) gets colored.


RE: [BUG] Colordiffuse for slider control - phil65 - 2012-05-28 14:46

bump. should i add this as a trac ticket? any comment from one of the devs here? Smile


RE: [BUG] Colordiffuse for slider control - pieh - 2012-05-28 18:22

Any code snippet? it seems to diffuse here just fine.


RE: [BUG] Colordiffuse for slider control - phil65 - 2012-05-28 18:46

visible when using nox 3.0, choosing a color different from white for video area, and opening audo settings from within video osd. the focus texture for volume and volume amplification do not get colored. (those are built-in controls, perhaps that matters?)


RE: [BUG] Colordiffuse for slider control - phil65 - 2012-05-28 18:57

sorry, it´s a "sliderex" control, not "slider"

this is the code:

Code:
<control type="sliderex" id="10">
            <description>Default Slider</description>
            <width>1172</width>
            <height>60</height>
            <colordiffuse>$VAR[ColorDiffuseVar]</colordiffuse>
            <texturefocus>views/tripanel/listselect_fo.png</texturefocus>
            <texturenofocus>osd/osd_settings_buttonnf.png</texturenofocus>
            <texturesliderbar>osd/osd_slider_bg_settings.png</texturesliderbar>
            <textureslidernib>osd/osd_slider_nib_nf.png</textureslidernib>
            <textureslidernibfocus>osd/osd_slider_nib.png</textureslidernibfocus>
            <font>Font_Reg20</font>
            <textcolor>grey2</textcolor>
            <textoffsetx>45</textoffsetx>
            <focusedcolor>white</focusedcolor>
        </control>



RE: [BUG] Colordiffuse for slider control - pieh - 2012-05-29 00:03

fixed in https://github.com/xbmc/xbmc/commit/38bacea60735eb672c21d17130abba14af5be560
thanks for report (and bump) Wink


RE: [BUG] Colordiffuse for slider control - BlackRose - 2012-05-29 01:45

(2012-05-29 00:03)pieh Wrote:  fixed in https://github.com/xbmc/xbmc/commit/38bacea60735eb672c21d17130abba14af5be560,
thanks for report (and bump) Wink

Oh wow, great find. How do I update my XBMC to the latest build including this change. Never used github for much thus far. I've looked at it, felt foolish, looked some more, felt retarded, looked some more, and then their was an electricity shortage across half of civilization. Help. I'm blonde!

I'm using windows by the way!


RE: [BUG] Colordiffuse for slider control - phil65 - 2012-05-29 02:38

(2012-05-29 01:45)BlackRose Wrote:  
(2012-05-29 00:03)pieh Wrote:  fixed in https://github.com/xbmc/xbmc/commit/38bacea60735eb672c21d17130abba14af5be560,
thanks for report (and bump) Wink

Oh wow, great find. How do I update my XBMC to the latest build including this change. Never used github for much thus far. I've looked at it, felt foolish, looked some more, felt retarded, looked some more, and then their was an electricity shortage across half of civilization. Help. I'm blonde!

I'm using windows by the way!

should be fixed in next daily build if you do not want to compile it yourself


RE: [BUG] Colordiffuse for slider control - phil65 - 2012-05-29 03:14

(2012-05-29 00:03)pieh Wrote:  fixed in https://github.com/xbmc/xbmc/commit/38bacea60735eb672c21d17130abba14af5be560,
thanks for report (and bump) Wink

...and forgot to say thx for this Smile


RE: [BUG] Colordiffuse for slider control - BlackRose - 2012-05-29 04:10

Thanks on behalf of everyone who's run into this issue... do I simply need to install the next daily build over my other xbmc installation. I have 11.0 Eden. Thanks for the knowledge


Re: RE: [BUG] Colordiffuse for slider control - Martijn - 2012-05-29 07:24

(2012-05-29 04:10)BlackRose Wrote:  Thanks on behalf of everyone who's run into this issue... do I simply need to install the next daily build over my other xbmc installation. I have 11.0 Eden. Thanks for the knowledge

Yes. Do make a backup of your settings!