Kodi Community Forum
[Mac OS X] Problem with SMB protocol after updating to Mac OS Maverick - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Mac OS X support (/forumdisplay.php?fid=56)
+---- Thread: [Mac OS X] Problem with SMB protocol after updating to Mac OS Maverick (/showthread.php?tid=176400)

Pages: 1 2 3 4 5 6 7 8


Problem with SMB protocol after updating to Mac OS Maverick - knaapjen - 2013-10-23 23:35

Hi, I have updated my Macbook Pro to Mac OS Mavericks, and since then my apple tv 2 isn't properly working.

The SMB protocol doesn't seem to work anymore? I can't add new directory's with (zeroconfig, SMB) and it can't find the old directory's.

Is there a fixx for this or is there anyone who knows what te problem is.


RE: Problem with SMB protocol after updating to Mac OS Maverick - Ned Scott - 2013-10-24 02:07

Can you get us a debug log? I will be updating later tonight to test myself, but getting data from multiple people might help.


RE: Problem with SMB protocol after updating to Mac OS Maverick - Ap0c4lypt0 - 2013-10-24 07:06

I found this solution that this user posted:


http://www.xbmchub.com/forums/members/dbmay75.html

"Issue resolved later that same night by installing the latest nightly build and proceeding with installing the new wizard. I haven't had much time lately to dive into what's new and what's stable, but I'm a lot better off than I was at the time of my initial post."

I installed Mavericks last night and noticed the same thing, will look into it today.

http://mirrors.xbmc.org/snapshots/osx/

grab the lastest alpha, worked for me.


RE: Problem with SMB protocol after updating to Mac OS Maverick - Ned Scott - 2013-10-24 08:54

(2013-10-24 07:06)Ap0c4lypt0 Wrote:  I found this solution that this user posted:


*garbage link removed*

"Issue resolved later that same night by installing the latest nightly build and proceeding with installing the new wizard. I haven't had much time lately to dive into what's new and what's stable, but I'm a lot better off than I was at the time of my initial post."

I installed Mavericks last night and noticed the same thing, will look into it today.

http://mirrors.xbmc.org/snapshots/osx/

grab the lastest alpha, worked for me.

That has nothing to do with what we're talking about. This is about Mac OS X 10.9 being used as an SMB server, not XBMC running on OS X 10.9.


RE: Problem with SMB protocol after updating to Mac OS Maverick - knaapjen - 2013-10-24 12:59

Ned Scott you are right, this is about Mac OS X 10.9 (Mavericks) being used as an SMB Server.

The SMB protocol isn't working. The AFP protocol works but after a few minutes (watching a movie) I get kicked out of XBMC. XBMC quits.

What debug log do you need? From the apple TV2 or the Macbook Pro?


RE: Problem with SMB protocol after updating to Mac OS Maverick - Ned Scott - 2013-10-24 13:43

Apple TV 2 when it accesses the Macbook Pro.


RE: Problem with SMB protocol after updating to Mac OS Maverick - knaapjen - 2013-10-24 14:40

14:34:37 T:136257536 DEBUG: CWinEventsIOS: Button press keyID = 5
14:34:37 T:804696064 DEBUG: CZeroconfBrowser: dump txt-records
14:34:37 T:804696064 DEBUG: OpenDir - Using authentication url smb://192.168.0.36
14:34:37 T:804696064 ERROR: SMBDirectory->GetDirectory: Unable to open directory : 'smb://192.168.0.36'
unix_err:'1' error : 'Operation not permitted'
14:34:37 T:804696064 ERROR: GetDirectory - Error getting smb://192.168.0.36:445/
14:34:37 T:136257536 ERROR: GetDirectory - Error getting zeroconf://_smb._tcp.%40local.%40MacBook%20Pro%20van%20Jan-Jaap
14:34:37 T:136257536 ERROR: CGUIDialogFileBrowser::GetDirectory(zeroconf://_smb._tcp.%40local.%40MacBook%20Pro%20van%20Jan-Jaap) failed
14:34:38 T:136257536 INFO: CheckIdle - Closing session to http://api.themoviedb.org (easy=0x7585000, multi=0x204000d0)


RE: Problem with SMB protocol after updating to Mac OS Maverick - ktmkarl - 2013-10-24 18:07

could someone help me I am not to computer smart Big Grin. I installed Mavericks yesterday and now XBMC will not open what do I do?

I have a three year old iMac that had Mountain lion and updated to Mavericks


RE: Problem with SMB protocol after updating to Mac OS Maverick - wgstarks - 2013-10-24 19:00

(2013-10-24 18:07)ktmkarl Wrote:  could someone help me I am not to computer smart Big Grin. I installed Mavericks yesterday and now XBMC will not open what do I do?

I have a three year old iMac that had Mountain lion and updated to Mavericks

This is completely off topic. You should start your own thread.


RE: Problem with SMB protocol after updating to Mac OS Maverick - winestock - 2013-10-25 02:38

(2013-10-24 12:59)knaapjen Wrote:  Ned Scott you are right, this is about Mac OS X 10.9 (Mavericks) being used as an SMB Server.

The SMB protocol isn't working. The AFP protocol works but after a few minutes (watching a movie) I get kicked out of XBMC. XBMC quits.

What debug log do you need? From the apple TV2 or the Macbook Pro?

There is a known issue in XBMC using the AFP protocol. I wonder if the problem you are having is related to Apple now using SMB2 in Mavericks.


RE: Problem with SMB protocol after updating to Mac OS Maverick - tomski182 - 2013-10-25 04:48

(2013-10-25 02:38)winestock Wrote:  
(2013-10-24 12:59)knaapjen Wrote:  Ned Scott you are right, this is about Mac OS X 10.9 (Mavericks) being used as an SMB Server.

The SMB protocol isn't working. The AFP protocol works but after a few minutes (watching a movie) I get kicked out of XBMC. XBMC quits.

What debug log do you need? From the apple TV2 or the Macbook Pro?

There is a known issue in XBMC using the AFP protocol. I wonder if the problem you are having is related to Apple now using SMB2 in Mavericks.

So is the lack of SMB2 support an ATV issue or XBMC related?


RE: Problem with SMB protocol after updating to Mac OS Maverick - Ned Scott - 2013-10-25 05:51

At this point we don't know if it is an SMB 2 issue. Apple's updated SMB server is supposed to be backwards compatible.


RE: Problem with SMB protocol after updating to Mac OS Maverick - tomski182 - 2013-10-25 05:52

(2013-10-25 05:51)Ned Scott Wrote:  At this point we don't know if it is an SMB 2 issue. Apple's updated SMB server is supposed to be backwards compatible.

Yeah that's what I thought. Thanks for the reply.


RE: Problem with SMB protocol after updating to Mac OS Maverick - nmirza - 2013-10-25 09:32

I know this thread is about the smb a server, but i believe my thread (http://forum.xbmc.org/showthread.php?tid=176381) might be related.

Basically with 10.9, vlc works fine to stream from my smb server. But xbmc stutters because it seems unlike xbmc on 10.8 or vlc on 10.9, xbmc on 10.9 caches a lot more data.

So in your aswell i think its xbmc on your apple tv thats causing the problem rather than the server.


RE: Problem with SMB protocol after updating to Mac OS Maverick - cecemf - 2013-10-25 13:41

(2013-10-23 23:35)knaapjen Wrote:  Hi, I have updated my Macbook Pro to Mac OS Mavericks, and since then my apple tv 2 isn't properly working.

The SMB protocol doesn't seem to work anymore? I can't add new directory's with (zeroconfig, SMB) and it can't find the old directory's.

Is there a fixx for this or is there anyone who knows what te problem is.

Did you update your Apple Tv to the latest OS that came out last night ?