Kodi Community Forum
XBMC_PC Win32 GUI Development Environment for skinners (skin developers) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Skin Development (/forumdisplay.php?fid=12)
+--- Thread: XBMC_PC Win32 GUI Development Environment for skinners (skin developers) (/showthread.php?tid=23235)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24


- Jezz_X - 2006-11-18 10:49

mbay Wrote:when it is said to open font.xml and make sure the font id tag says:
Code:
<fontset id="TeamBlackbolt" unicode="true">
is there anything else aside from restarting that needs to be done?

Thanks for any help

make sure you do it for the resolution that you actually use each dir pal pal16x9 nsc ntsc16x9 720p and 1080 all have there own font.xml files in them


- Jezz_X - 2006-11-18 10:59

Ok anyone trying to use mc360 in it just use these font xmls also if you use the teamblackbolt font on the xbox these are newer and greatly improved size and should look heaps better
http://www.myfilehut.com/userfiles/12943/MC360_fontxmls_xbmc_pc.rar


- mbay - 2006-11-18 11:12

Jezz_X,

thanks buddy - i updated the ntsc-specific font.xml file and it worked like a charm. Smile


- SleepyP - 2006-11-18 11:59

yo. My issues were due to incorrect mapping of my drive letters (what a surprise). It now runs correctly and I can get a full debug log output, as well as sound output. However, the video remains black. JMarshall, would a debug log prove interesting for this, or is it safe to assume my video card is too ghetto?


- jmarshall - 2006-11-18 12:27

Pretty sure that it's the same issue that elupus had. Debug Log wouldn't hurt ofcourse.

Cheers,
Jonathan


- CademiaX - 2006-11-18 13:47

jmarshall and/or Jezz_X: Im having some issues with the release build. here is the build log.. Ive tried a few times and get the same thing.

Code:
------ Build started: Project: guilib, Configuration: Release Win32 ------
guilib - up-to-date.
------ Build started: Project: XBMC_PC, Configuration: Release Win32 ------
Linking...
LINK : fatal error LNK1104: cannot open file 'libci.lib'

Build log was saved at "file://c:\Xbox\Xbmc\tools\Win32\Release\BuildLog.htm"
XBMC_PC - 1 error(s), 0 warning(s)
---------------------- Done ----------------------

    Build: 1 succeeded, 1 failed, 0 skipped



- CademiaX - 2006-11-18 14:21

here is the entire build log..

http://pastebin.com/827282


- edwinmcdunlap - 2006-11-18 16:13

Jezz_X Wrote:Ok anyone trying to use mc360 in it just use these font xmls also if you use the teamblackbolt font on the xbox these are newer and greatly improved size and should look heaps better
http://www.myfilehut.com/userfiles/12943/MC360_fontxmls_xbmc_pc.rar
Thanks, man. Works perfectly now.Big Grin


- Coolgamer30 - 2006-11-18 18:02

CademiaX Wrote:jmarshall and/or Jezz_X: Im having some issues with the release build. here is the build log.. Ive tried a few times and get the same thing.

Code:
------ Build started: Project: guilib, Configuration: Release Win32 ------
guilib - up-to-date.
------ Build started: Project: XBMC_PC, Configuration: Release Win32 ------
Linking...
LINK : fatal error LNK1104: cannot open file 'libci.lib'

Build log was saved at "file://c:\Xbox\Xbmc\tools\Win32\Release\BuildLog.htm"
XBMC_PC - 1 error(s), 0 warning(s)
---------------------- Done ----------------------

    Build: 1 succeeded, 1 failed, 0 skipped
I had that exact same error too. What I did to make it compile was to go to Project>Properties then the Linker tab then under Input. Add libci to Ignore Specific Library then it should compile.


- Jezz_X - 2006-11-18 19:43

Coolgamer30 Wrote:I had that exact same error too. What I did to make it compile was to go to Project>Properties then the Linker tab then under Input. Add libci to Ignore Specific Library then it should compile.

yeah what he said Nod


- SleepyP - 2006-11-19 02:15

yo, here's the debug log from my "works but no video" experience:
http://pastebin.com/827747


- CademiaX - 2006-11-19 03:39

Coolgamer30 Wrote:I had that exact same error too. What I did to make it compile was to go to Project>Properties then the Linker tab then under Input. Add libci to Ignore Specific Library then it should compile.

ah.. thx, works perfect Smile well aside from a 145 warnings.. hehe.. thx


- edwinmcdunlap - 2006-11-19 04:03

Since XBMCPC has network support, would anyone know how to get FoxyTunes to work with it? I tried putting in 127.0.0.1 as the IP, and it didn't work.. Any other ideas?


- Loaded Gun - 2006-11-19 08:23

I am getting NO text at all what so ever.


- Jezz_X - 2006-11-19 09:13

Loaded Gun Wrote:I am getting NO text at all what so ever.
did you read this post
http://forum.xbmc.org/showpost.php?p=116041&postcount=42