Kodi Community Forum
[OFFICIAL] MPlayer.dll development branch feedback. - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Development (/forumdisplay.php?fid=32)
+--- Forum: Development (/forumdisplay.php?fid=93)
+--- Thread: [OFFICIAL] MPlayer.dll development branch feedback. (/showthread.php?tid=23969)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19


- vanadium - 2007-01-08 18:22

Been testing these new builds out against various streams from my STRM pack lately. 01/07/2007 and 01/08/2007 revisions seem to have borked streaming video (mms://) a bit; connects fine and stops, going back to the menu.

Reverted back to the first experimental revision for now -- it helped fix a ton of demuxing issues indeed. I'm grateful. Big Grin


- elupus - 2007-01-08 18:51

right, could you give me a sample stream?

<edit> never mind, fixed now. new dll available </edit>


- vanadium - 2007-01-09 01:12

elupus, thanks a ton and I'll check it out tonight. Have there been any voice sync issues in streams other than RealMedia that anyone else has noticed? (I'll look into this more tonight on some WindowsMedia streams -- I've noticed a slight delay now and then on some of them (like RTR Planeta (240k) in Russia).

Really looking forward to your continued work on mplayer. Meanwhile, my STRM pack if you need any to test can be found at http://www.op9.net/files/XBMC/XBMC-TV.zip -- hope this helps, and I don't mean this link to advertise. There's a ton of different kinds in there to test with.


- vanadium - 2007-01-09 01:16

vanadium Wrote:like RTR Planeta (240k) in Russia).

Actually, a better example would be MIR TV Russia: mms://213.232.226.11/MIRTV_300


- Gamester17 - 2007-01-09 16:43

Rabomil Wrote:In some cases I get strange artefacts when I'm using lavdopts=skiploopfilter=all. The actual situation is worse than the picture shows. By changing the the line to lavdopts=skiploopfilter=bidir, the artefacts are gone. Too bad that only the deblocking of b-frames will be skipped then.
still, just having lavdopts=skiploopfilter=bidir as an option (or default for H.264) might be an acceptable compromise(?)


- wHack - 2007-01-10 19:11

Works great on h.264 so long as it's not packaged with AAC audio, and with AC3 it still drops a few frames. Seems like with some heavy optimization of AAC and a liittle tweaking of AC3 all could run smoothly on alot of h.264 files without even having to optimize the h.264 codec any more.


- mironicus - 2007-01-11 02:50

I found another bug:

I have some AVIs with external subtitle-files.

Like

Movie.avi
Movie.idx
Movie.sub

The subs are not displayed with the new mplayer-build.


Skipping in Damaged XVIDs - joe4444 - 2007-01-11 04:39

I have no clue what feature of the newer version of mplayer allows playing through corrupted videos, but I have several videos that work fine in mplayer for win32. In XBMC these videos always skip over about 5 minutes or they simply stop playback completely. Here is a link to the log file from one of the videos that skips 5 minutes:

http://pastebin.ca/312627

Hopefully this will be helpful to a developer because I don't understand it. All I know is that this and other videos have similar problems in XBMC but not in any video player I've tried in Windows.


- elupus - 2007-01-11 05:25

joe4444:
so could you tell how the new mplayer.dll does on those in comparison to old? that is really the only thing i'm interested in at this stage.

mironicus:
yea, noticed. if you are able to select another subtitle then they start showing up. ie a srt or maybe even another stream on the same..... hmm odd now they always show up. might know why..


- joe4444 - 2007-01-11 09:27

I've done some more testing, and it appears the issue is actually related to an error in the FTP, although I'm not sure if it's XBMC or my client. Apparently when transferring some video files to my xbox they were corrupted. I verified this by running a checksum on the video files. The ones with problems do not match the originals I downloaded. Oo

Sorry! Blush


- MajorTom - 2007-01-11 10:58

joe4444 Wrote:I've done some more testing, and it appears the issue is actually related to an error in the FTP, although I'm not sure if it's XBMC or my client. Apparently when transferring some video files to my xbox they were corrupted. I verified this by running a checksum on the video files. The ones with problems do not match the originals I downloaded. Oo

Sorry! Blush

That sounds ominous... hope the FTP transer bug isn't back...


- mironicus - 2007-01-11 14:45

Quote:That sounds ominous... hope the FTP transer bug isn't back...

Could be. I use the latest build of XBMC and since that I have transfer problems with FTP, too! Transfers with Quix freeze etc.


- joe4444 - 2007-01-11 21:44

So this isn't new or unique to me? It was causing problems with at least 1/2 of the videos I transferred this week. I have been using the build from 2006-11-05 since late November, but only very recently (a few days ago) did this corrupt video problem occur.

Luckily I hadn't erased any of the originals from my PC, and after transferring them to my XBOX again the problem seems to be gone. I'm going to run a few more tests with recent builds to see if I can duplicate the problem.

Could someone point me to a thread related to the (old) FTP transfer bug?


Sorry for crashing your mplayer thread, elupus!


- elupus - 2007-01-11 23:26

please keep this stuff about ftp out of this thread. i'm very sad to hear about the ftp stuff thou. since i was in there last.


new mplayer.dll bug! - Hack_kid - 2007-01-12 18:52

Hi i know this is my first post but ive ben here forever just never bothered to register because i had no need to post until now because everything i had to say someone else had said but i have discovered a bug with the new mplayer.dll. If you are playing music (mp3) and are in the video section then back out to the home window and then go to videos and then choose a bookmark once you choose a book mark (mine is labeled movies) and quwincidently it is in the same physical position on the screen as my music share in the music tab (they are both in the exact middle of the list) well anyways once you choose a bookmark (mine being movies) the player skips to the next mp3 in playlist (folder) it basicaly executes the next song command when you press A and i can re create it.

here is my xbmc.log i dont know if it will help though doesnt seem to match up what was happening maybe i dont have the right logging setting on

Code:
08:33:31 M: 54112256  NOTICE: -----------------------------------------------------------------------
08:33:31 M: 54091776  NOTICE: Starting XBoxMediaCenter.  Built on Jan  9 2007
08:33:31 M: 54091776  NOTICE: Q is mapped to: Harddisk0\Partition6\Apps\XBMC010907
08:33:31 M: 54091776  NOTICE: Log File is located: Q:\xbmc.log
08:33:31 M: 54091776  NOTICE: -----------------------------------------------------------------------
08:33:31 M: 54091776  NOTICE: Setup DirectX
08:33:32 M: 54063104  NOTICE: load settings...
08:33:32 M: 54063104  NOTICE: loading T:\guisettings.xml
08:33:32 M: 53923840  NOTICE: Getting hardware information now...
08:33:32 M: 53923840  NOTICE: Checking resolution 10
08:33:32 M: 53923840  NOTICE: Setting autoresolution mode 4
08:33:32 M: 53923840  NOTICE: Per AV pack settings are on
08:33:32 M: 53923840  NOTICE: S-Video found : loading T:\avpacksettings.xml
08:33:32 M: 53907456  NOTICE: Getting hardware information now...
08:33:32 M: 53886976  NOTICE: Checking resolution 10
08:33:32 M: 53886976  NOTICE: Setting autoresolution mode 4
08:33:32 M: 54009856  NOTICE: q:\userdata\sources.xml
08:33:32 M: 49045504   ERROR: Window Translator: Can't find window myvideotitles
08:33:32 M: 49094656  NOTICE: Checking the Date!
08:33:32 M: 49111040  NOTICE: start dvd mediatype detection
08:33:32 M: 48586752  NOTICE: initializing playlistplayer
08:33:32 M: 48586752  NOTICE: DONE initializing playlistplayer
08:33:32 M: 48586752  NOTICE: load default skin:[MC360]
08:33:33 M: 44589056  NOTICE: use static ip
08:33:33 M: 44589056  NOTICE: initialize done
08:33:33 M: 44589056  NOTICE: Running the application...
08:33:34 M: 43884544 WARNING: Skin has invalid include: -
08:33:34 M: 43864064 WARNING: Skin has invalid include: -
08:33:35 M: 35803136  NOTICE: start timeserver client
08:33:35 M: 35278848  NOTICE: XBFileZilla: Starting...
08:33:35 M: 34754560  NOTICE: starting kai
08:33:35 M: 34754560  NOTICE: KAICLIENT: Attach to Kai engine host at 192.168.0.27
08:33:35 M: 32583680  NOTICE: XBFileZilla: Started
08:34:04 M: 25800704   ERROR: XFILE::CFileSMB::Read - smbc_read returned error 9
08:34:05 M: 25509888   ERROR: FileReader::Read - encountered read error
08:34:05 M: 25509888   ERROR: MP3Codec: Error reading file
08:34:05 M: 25444352   ERROR: CAudioDecoder: Error while decoding 1
08:34:05 M: 25821184   ERROR: MP3Codec: Unable to open file musicdb://4/44.mp3
08:34:05 M: 25845760   ERROR: CAudioDecoder: Unable to Init Codec while loading file musicdb://4/44.mp3
08:34:05 M: 26636288   ERROR: Playlist Player: skipping unplayable item: 59, path [musicdb://4/44.mp3]
08:34:05 M: 25821184   ERROR: MP3Codec: Unable to open file musicdb://4/45.mp3
08:34:05 M: 25845760   ERROR: CAudioDecoder: Unable to Init Codec while loading file musicdb://4/45.mp3
08:34:05 M: 26636288   ERROR: Playlist Player: skipping unplayable item: 60, path [musicdb://4/45.mp3]
08:34:05 M: 25821184   ERROR: MP3Codec: Unable to open file musicdb://4/46.mp3
08:34:05 M: 25845760   ERROR: CAudioDecoder: Unable to Init Codec while loading file musicdb://4/46.mp3
08:34:05 M: 26636288   ERROR: Playlist Player: skipping unplayable item: 61, path [musicdb://4/46.mp3]
08:34:05 M: 25821184   ERROR: MP3Codec: Unable to open file musicdb://4/47.mp3
08:34:05 M: 25845760   ERROR: CAudioDecoder: Unable to Init Codec while loading file musicdb://4/47.mp3
08:34:05 M: 26636288   ERROR: Playlist Player: skipping unplayable item: 62, path [musicdb://4/47.mp3]
08:34:17 M: 25464832  NOTICE: Storing total System Uptime
08:34:18 M: 25464832  NOTICE: Saving settings
08:34:18 M: 25464832  NOTICE: Saving S-Video settings in T:\avpacksettings.xml
08:34:18 M: 25464832  NOTICE: stop all
08:34:18 M: 25464832  NOTICE: stop time server client
08:34:18 M: 27037696  NOTICE: stopping kai
08:34:18 M: 27561984  NOTICE: stop dvd detect media
08:34:18 M: 28086272  NOTICE: stop fancontroller
08:34:18 M: 28086272  NOTICE: stop mplayer
08:34:18 M: 30162944  NOTICE: stop daap clients
08:34:18 M: 30162944  NOTICE: stop python
08:34:18 M: 30162944  NOTICE: clean cached files!
08:34:18 M: 30162944  NOTICE: unload skin
08:34:18 M: 44167168  NOTICE: unload sections
08:34:18 M: 45223936  NOTICE: destroy
08:34:18 M: 49438720  NOTICE: stopped


Thanks,

Hack_kid