Kodi Community Forum
[RELEASE] YouTube3 - YouTube Script - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] YouTube3 - YouTube Script (/showthread.php?tid=33585)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21


- asr10 user - 2009-02-15 00:59

Thank you very much. I was going crazy thinking what happened!


- taxigps - 2009-02-16 15:17

Thank you very much! This script is good!
But would you add a language file for the script, that will allow to translate to other language easily.


- AaronG85 - 2009-02-17 12:34

thanks love this script


- frikky - 2009-02-22 20:48

I have encountered a problem.

When launching the Youtube script a window pops up saying "Downloading...", after which the Xbox freezes up. I tried launching the version in the XBMC build mentioned and it seemed to run ok - not taking into account that it's out of date. Have I done anything wrong upon 'installing' the script? All I've done is extracting the Youtube3 folder from the .zip and transferring the folder to the Xbox. In case you're going to suggest trying another XBMC skin; it did not work with the PM3 skin either.

XBMC build: T3CH XBMC 2009-02-18 SVN rev17820
Script version: YouTube3-15-02-09.zip
Skin MC360

[Image: 351859.jpeg]


- borick - 2009-02-23 16:38

frikky Wrote:I have encountered a problem.

When launching the Youtube script a window pops up saying "Downloading...", after which the Xbox freezes up. I tried launching the version in the XBMC build mentioned and it seemed to run ok - not taking into account that it's out of date. Have I done anything wrong upon 'installing' the script? All I've done is extracting the Youtube3 folder from the .zip and transferring the folder to the Xbox. In case you're going to suggest trying another XBMC skin; it did not work with the PM3 skin either.

XBMC build: T3CH XBMC 2009-02-18 SVN rev17820
Script version: YouTube3-15-02-09.zip
Skin MC360

[Image: 351859.jpeg]

So it freezes with the latest build, but not an earlier build? Can you reproduce this behavior every time? One thing to try would be to clear our your data directory in the script which contains settings.txt and other data files. Just delete all those files and restart the script. I'm going to have to give it a shot with the build you mentioned see if I can reproduce this on my XBOX.

Edit: I just noticed its a brand new build you mentioned, with some major changes as they relate to python scripts. I suspect these changes are causing the crashing behavior. If this really is a problem I'll have to fix it up really soon.


- frikky - 2009-02-23 17:59

Thanks for the quick response!

It freezes with build XBMC-8.10-FINAL-T3CH-PROPER (latest stable build according to t3ch's site) as well.

Emptying the data folder had no influence on the freeze issue. It happens every time using YouTube3-15-02-09, previous versions load fine but won't get data from youtube.


- xGROMx - 2009-02-23 22:22

I must be doing somthing wrong, the script loads under "scripts" and i can get the list of videos but not play them. When i go to "video" the script doesn't show up.....

same thing happens with the apple video script, but works under video plugins

-noob


- xGROMx - 2009-02-23 23:54

Figured out my noob problem, but i am now getting the same problem as frikky.

Loads then downloads thumbs, as soon as i move my mouse over any of them it freezes. This is on a windows build


- volenin - 2009-02-25 04:22

Great script! Just a small suggestion: it might be worthwhile to put a note on the very first page that this is a SCRIPT and not a PLUGIN, thus the app must be deployed into the SCRIPTS directory and not the PLUGINS.

Interestingly, I had it in the Plugins for quite some time and the feeling you are getting is that the app is just buggy and doesn't work (the first screen appears and the thumbs are loading, but after that the XBMC is freezing). In other words, you are not getting an error, but rather a freezing app Smile.

Also, I've noticed a minor glitch in the following scenario (using remote control):

- do the search
- navigate the found entries in the 'main' screen (up/down)
- click left to go to the sidebar
--- you'd end up on the very first item ('view')
- click 'down' to navigate the side bar down to the next entry ('Search')

- BUG: the 'Search' item will be skipped - you'll endup on 'History' tab
- pressing down again in a loop will bring to the 'Previous' and then, skipping the 'Next' - back to the 'View'
- keeping on pressing 'down' the sequence occurs again (ie, skipping 'Search' and 'Next' items)
- if you navigate 'up' then you can get to those items

Cheers,

Vlad

PS: using the 'YouTube3-15-02-09' version of plugin under 180xx XBMC SVN build, on Ubuntu Hardy 8.04.2


- xGROMx - 2009-02-25 04:36

problem with that is, i stuck it in the scripts folder first and it loads and looks great. But you cant load any of the videos.

same with the apple movie script that comes with the build, it looks great when ran under scripts but don't function, it only works under the plugins/video

this is a windows build


- borick - 2009-02-25 06:15

xGROMx Wrote:problem with that is, i stuck it in the scripts folder first and it loads and looks great. But you cant load any of the videos.

same with the apple movie script that comes with the build, it looks great when ran under scripts but don't function, it only works under the plugins/video

this is a windows build
get the latest version from the website listed in the first page of this thread - the version which was released with XBMC is older and youtube changed something with their session ids, so it broke the old youtube scripts, the newest one on google code should fix the problem you are talking about, please let me know if it doesn't


- xGROMx - 2009-02-25 06:32

I have the newest, downloaded it this past weekend, I am running the YouTube3-15-02-09 file on the XBMC for windows 8.10.

Go in to add source or just through video scripts it will load and start to download some things then lock up XBMC, gota CTRL-ALT-DEL out of it.


- volenin - 2009-02-26 04:31

Hmm... Works fine for me under Linux.... Must be smth else then.


- Molkio - 2009-02-26 18:33

borick Wrote:Download the latest script at:
http://code.google.com/p/xbmc-youtube/downloads/list

|YouTube 3.31|
- Fixed script so it works again.

Thank you very much!


- gears - 2009-02-28 22:43

Using the XBOX i can not get this to work. I am using the latest T3ch version and downloaded the 3.3 version of youtube. Plugin loads, opens list and freezes my xbox. Here is the relevant part to f the debug log.

http://pastebin.com/mb8532dc

Thanks for any help