Kodi Community Forum
XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (/forumdisplay.php?fid=116)
+--- Thread: XBMC HTTP-R, Remote Control Web App for PDA, PPC, or Smartphone (developers wanted) (/showthread.php?tid=40958)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21


- sparkie2640 - 2009-01-27 05:45

minimalko Wrote:I Have exactly the same problem. After I did suggested edits I get this

Warning: Invalid argument supplied for foreach() in C:\xampp\htdocs\XBMC\interface\ppc\inspire\index.php on line 62

Sorry but I am a total n00b when it comes to networks. I tried it on Nokia E71, also on PC using all known browsers including Opera 9.63..no luck though

Thanks in advance.

You installed xampp and not xampp lite.


- minimalko - 2009-01-27 10:50

sparkie2640 Wrote:You installed xampp and not xampp lite.

Yes I installed XAMPP. Perheaps I am missing some configuration that needs to be done. I did not change anything, just started apache in XAMPP.


- XiniX88 - 2009-01-27 11:49

Please download the script again... and try to configure it again... It's a problem in your config.php, the array which holds your XBMC settings is gone...
So it is not due to:
- wrong configured Apache/PHP
- wrong version of XAMPP

__
Btw, strange, your mobile is missing about 20px on a 240x320px screen... I'll make a more scaleable skin for the 0.5 release, add a grapical installer and add xampp lite (yes 2 versions, one with xampp lite and one without), so you can install it in 1 click.


- DragonFly - 2009-01-27 12:48

Perhaps it's the browser's scrollbars that's causing it to cut off some pixels? I've tried it on Opera 8.65 on a rather old PDA (WM2003) and experienced the same issue.


- minimalko - 2009-01-27 14:31

XiniX88 Wrote:Please download the script again... and try to configure it again... It's a problem in your config.php, the array which holds your XBMC settings is gone...
So it is not due to:
- wrong configured Apache/PHP
- wrong version of XAMPP

__
Btw, strange, your mobile is missing about 20px on a 240x320px screen... I'll make a more scaleable skin for the 0.5 release, add a grapical installer and add xampp lite (yes 2 versions, one with xampp lite and one without), so you can install it in 1 click.

Thanks, I tried but am still getting the same error. my config.php settings array is following:

Code:
$_CONF['xbmc'] = array(
    1 => array("name" => "XBMC", "ip" => "192.168.1.40", "port" => "8080", "mac" => "00:11:D8:C4:4E:98")

Where "XBMC" is name of folder in htdocs and "ip" is just my ip. Did not change anything else.

This is a screenshot of what I am getting:

[ATTACH]54[/ATTACH]

Thanks for your support.

EDIT: The screenshot is from Firefox browser, I see the same thing in Opera and Nokia E71 browser.


- DragonFly - 2009-01-27 15:24

minimalko Wrote:Yes I installed XAMPP.

Like XiniX88 said, you'll need to use Xampp LITE, you replied that you've installed the full flegged Xampp and it looks that way from your path in the error messages.

Just uninstall the full Xampp AND assuming your using Windows on your PC, you'll need to:
  • Download XamppLite http://www.apachefriends.org/en/xampp-windows.html#646, The ZIP version
  • Extract it to a directory of your liking e.g. D:\XamppLite
  • Make a Dir in D:\XamppLite\htdocs\ e.g "Interface" (without the double quotes)
  • Extract the HTTP-R archive to D:\XamppLite\htdocs\Interface
  • Goto D:\XamppLite\htdocs\Interface\includes\config.php and edit config.php to match the IP address of your XBMC
  • Run the "setup_xampp.bat" This configures XamppLite to run properly on your machine.
  • Either run the "xampp_start.exe" which initiates Apache and MySQL or
  • Run the "xampp-control.exe" to start Apache or MySQL manually or automatically as a service
  • Make SURE the webserver in XBMC is enabled and set to port 8080 and XBMC is running
  • For testing purposes, go to your computer webbrowser first and enter http://localhost/interface (or click this url)
  • Now you should see the HTTP-R interface
  • Try the same on your mobile device using "http://yourIP/interface" e.g. http://192.168.1.2/interface/



- sparkie2640 - 2009-01-27 16:08

minimalko Wrote:Yes I installed XAMPP. Perheaps I am missing some configuration that needs to be done. I did not change anything, just started apache in XAMPP.

Yes I know. You need xampp lite not xampp (it's the last one on the xampp download page)


- minimalko - 2009-01-27 16:35

DragonFly Wrote:Like XiniX88 said, you'll need to use Xampp LITE, you replied that you've installed the full flegged Xampp and it looks that way from your path in the error messages.

Just uninstall the full Xampp AND assuming your using Windows on your PC, you'll need to:
  • Download XamppLite http://www.apachefriends.org/en/xampp-windows.html#646, The ZIP version
  • Extract it to a directory of your liking e.g. D:\XamppLite
  • Make a Dir in D:\XamppLite\htdocs\ e.g "Interface" (without the double quotes)
  • Extract the HTTP-R archive to D:\XamppLite\htdocs\Interface
  • Goto D:\XamppLite\htdocs\Interface\includes\config.php and edit config.php to match the IP address of your XBMC
  • Run the "setup_xampp.bat" This configures XamppLite to run properly on your machine.
  • Either run the "xampp_start.exe" which initiates Apache and MySQL or
  • Run the "xampp-control.exe" to start Apache or MySQL manually or automatically as a service
  • Make SURE the webserver in XBMC is enabled and set to port 8080 and XBMC is running
  • For testing purposes, go to your computer webbrowser first and enter http://localhost/interface (or click this url)
  • Now you should see the HTTP-R interface
  • Try the same on your mobile device using "http://yourIP/interface" e.g. http://192.168.1.2/interface/

Well, what can I say. Regarding my stupidity I dont even deserve such quality support. Thank you so much it works perfect now.Laugh

sparkie2640 Wrote:Yes I know. You need xampp lite not xampp (it's the last one on the xampp download page)

Thanks, Sorry for not reading carefully.


- DragonFly - 2009-01-27 16:51

Glad to help.......

Being a skinner, you might have a word with XiniX88 in order to create themes for HTTP-R


- tetsuo1248 - 2009-01-27 23:41

Hi

Same sutpidity than Minimalko

Thanks XiniX88 for this great job


I'm Dumb - nhfilz - 2009-01-29 10:37

Hello guys,

This is my first post ever! Yay. Anyway, this is amazing. I love the idea of using this on my BlackBerry because unlike a remote, I will NEVER lose my Blackberry.

But I am having some issues. My device does not have wifi so the only way for me to get this to work is by accessing my computer via it's external ip right? well i believe that i have everything set up right (and it works with my LAN ip no problem). But it will not work.

I also noticed that on my router stats page, it says the wan ip for the router is the same ip i am getting when i check the external ip. Its late and my brain is starting to get fried. if someone knows what sillky dumb thing i am not doing, please let me know.

Also its good to meet you all!


- XiniX88 - 2009-01-29 10:54

nhfilz Wrote:Hello guys,

This is my first post ever! Yay. Anyway, this is amazing. I love the idea of using this on my BlackBerry because unlike a remote, I will NEVER lose my Blackberry.

But I am having some issues. My device does not have wifi so the only way for me to get this to work is by accessing my computer via it's external ip right? well i believe that i have everything set up right (and it works with my LAN ip no problem). But it will not work.

I also noticed that on my router stats page, it says the wan ip for the router is the same ip i am getting when i check the external ip. Its late and my brain is starting to get fried. if someone knows what sillky dumb thing i am not doing, please let me know.

Also its good to meet you all!

On your router go to your NAT settings, port: 80 outgoing port: 80, and give the IP of the computer where you are running XAMPP (something like 10.x.x.x or 192.168.1.x or 172.x.x.x).

Now go to http://www.whatismyip.com/ copy your IP address and paste in in your address bar of your browser to see if it is running.

Now you can also get it working on your blackberry.


- nhfilz - 2009-01-29 11:29

hmmm...

I am still having some issues. When I forward the port to the machine that the xmbc is on, I go and find the ip like you said, but when i go there, the router stats page comes up...


- XiniX88 - 2009-01-30 21:46

Wrong IP in your NAT... you've assigned your routers IP address to it...

80 => 80 192.168.1.254 (i guess) or 192.168.1.1. On your PC where xbmc is running, please do: windowkey + r, then press cmd, a "dos prompt" will appear, press ipconfig, make a screenshot of the highest section.

Go to your router, NAT and also make a screenshot of that page... Than I can give you hopefully the right settings.


- nhfilz - 2009-02-01 05:25

Hey sorry it has taken so long to get back to you.

I am in the IT field so I know about things such as the command prompt, how to check my ip etc. I feel really dumb.

My IPv4 address is 192.168.1.123 (what i assigned to it)

On my router config page, i have port 80 set to forward to 192.168.1.123. The lan ip for my router is 192.168.1.1. My wan ip for the router is 69.144.230.150. and when i go to a page to find my real ip, it tells me the same address.
Your IP Address Is 69.144.230.150

How can the routers wan ip and my computers real ip be the same?

it has to be something with my wireless connection to the router, as when i connect the computer via ethernet cord, the real ip is different than the wan ip.

But Im still confused.