Kodi Community Forum
[LINUX] HOW-TO get Live TV with VDR working in XBMC for Linux - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Announcements, Info, and General Discussion (/forumdisplay.php?fid=85)
+--- Forum: Tips, tricks, and step by step guides (/forumdisplay.php?fid=110)
+--- Thread: [LINUX] HOW-TO get Live TV with VDR working in XBMC for Linux (/showthread.php?tid=45314)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39


stream freezing (part 2) - baxternz - 2010-03-28 04:56

Here's some of the logs I get when I select a live TV channel:

15:56:19 T:140419595831504 M:1676972032 DEBUG: ------ Window Deinit (DialogBusy.xml) ------
15:56:19 T:140419314739536 M:1676972032 NOTICE: fps: 25.000000, pwidth: 720, pheight: 576, dwidth: 1050, dheight: 576
15:56:19 T:140419314739536 M:1676972032 DEBUG: OutputPicture - change configuration. 720x576. framerate: 25.00
15:56:19 T:140419314739536 M:1676972032 WARNING: CRenderManager::Configure - timeout waiting for previous frame
15:56:19 T:140419314739536 M:1676972032 NOTICE: Display resolution DESKTOP : 1360x768 @ 50.00 - Full Screen (12)
15:56:19 T:140419314739536 M:1676972032 DEBUG: CPullupCorrection: pattern lost
15:56:19 T:140419595831504 M:1676972032 NOTICE: Using GL_TEXTURE_2D
15:56:19 T:140419595831504 M:1676972032 DEBUG: GL: Requested render method: 0
15:56:19 T:140419595831504 M:1676972032 NOTICE: GL: Selecting Single Pass YUV 2 RGB shader
15:56:19 T:140419595831504 M:1676972032 DEBUG: GL: Shader compilation log:
15:56:19 T:140419595831504 M:1676972032 DEBUG: GL: Shader compilation log:
15:56:19 T:140419595831504 M:1676972032 NOTICE: GL: NPOT texture support detected
15:56:19 T:140419595831504 M:1676972032 NOTICE: GL: Using GL_ARB_pixel_buffer_object
15:56:19 T:140419482102096 M:1676951552 DEBUG: CDVDPlayer::HandleMessages - player started 2
15:56:19 T:140419482102096 M:1677000704 DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)
15:56:20 T:140419482102096 M:1676914688 DEBUG: CGUIInfoManager::SetCurrentMovie(pvr://channels/tv/all/2.pvr)

(at this point the channel is playing, for around 3 seconds)

15:56:21 T:140419325229392 M:1678807040 WARNING:
CDVDMessageQueue(audio)::Get - retrieved last data packet of queue
15:56:21 T:140419314739536 M:1678893056 WARNING: CDVDMessageQueue(video)::Get - retrieved last data packet of queue
15:56:22 T:140419314739536 M:1678921728 INFO: CDVDPlayerVideo - Stillframe detected, switching to forced 25.000000 fps
15:56:23 T:140419482102096 M:1678921728 INFO: AddOnLog: pvrclient/VDRClient for streamdev: No data in 2 seconds, queuing no signal image


Any idea what's happenning, and how I can get more debug info? is this a streamdev problem, or XBMC??


Thanks
Simon


UPDATE JAN20/2011 - was a VDR problem. XBMC front end now works fine (although not as fast or fully featured as the native VDR OSD, so not sure I'd switch yet!)


- anis745 - 2010-03-29 17:06

dmesg | grep -i dvb
I use a card PCTVSAT Pinnacle 400i DVB-S:
Quote:root@anis-desktop:/home/vdr/src/vdr/pvr-testing2# dmesg | grep -i dvb
[ 15.080391] bttv0: add subdevice "dvb0"
[ 15.108041] bt878_probe: card id=[0x1c11bd],[ Pinnacle PCTV Sat ] has DVB functions.
[ 15.263356] DVB: registering new adapter (bttv0)
[ 15.579963] DVB: registering adapter 0 frontend 0 (Conexant CX24110 DVB-S)...
root@anis-desktop:/home/vdr/src/vdr/pvr-testing2#
svn co http://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/pvr-testing2
cd pvr-testing2
./configure --enable-vdpau
bash: ./configure:No file or folder of this type

help ? :confused2:


- sphere - 2010-03-30 11:35

anis745 Wrote:dmesg | grep -i dvb
I use a card PCTVSAT Pinnacle 400i DVB-S:

svn co http://xbmc.svn.sourceforge.net/svnroot/xbmc/branches/pvr-testing2
cd pvr-testing2
./configure --enable-vdpau
bash: ./configure:No file or folder of this type

help ? :confused2:

Hi,

you have to do the command "./bootstrap" before the "./configure".
And AFAIK the "--enable-vdpau" is not needed anymore - but it don't hurts Wink

regards
sphere


Status? - rdoac - 2010-04-17 01:06

What's the status of pvrtesting2 now? I notice vnsi-server is now there, but can't configure it, or streamdev addon, with xbmc seg faulting about 1/2 times I try it.

Also, all my plugins are no longer there..


- tume2 - 2010-05-09 18:38

It is working for me r29920 vdr 1.7.14+vnci-server. Can you tell more exact what is the problem?


- dongioia - 2010-05-13 19:13

Hi, is the VNCI add-on more stable than the streamdev one?


- mushroom - 2010-05-18 22:54

does vnci server works with opensc plugin?


- flopma - 2010-05-21 08:49

Hi all,

I am experiencing troubles with VDR 1.7.14 with pvr-testing2 HEAD plus vnsi-server or streamdev HEAD. My config also include a TT S2 3200 card + CI + CAM + Smartcard.

I can tune on encrypted channels if I use gnutv + mplayer. But with (VDR + xineliboutput) or (xbmc + vdr + vnsiserver/streamdev), watching TV becomes a lottery.

As I have tried before, Mythtv, freevo, xbmc + tvheadend; I am becoming frustrated and think about buying a Dreambox DM8000 HD which has 4 CI and 2 CAM. It would be great to control it from XBMC beautiful interface, plus I have all my music managed by XBMC. Does anyone know if this is doable ? (XBMC controlling live TV from a Dreambox 8000 HD ?)

Thx!!!


- ivonovak - 2010-05-21 22:40

Sorry, reply to other post ....


- AuXBoX - 2010-06-04 12:27

is anyone using the Hauppauge HVR2200 with vdr?
i've just put in this card for the dual tuners and now vdr will not auto start on boot.
I'm using VNSI aswell

I can get it working with a manual start via terminal.

i also noticed on the xbmc.log an error which i'll have to post later when im home
but i remember it saying this
device 1 has no MPEG decoder


- AuXBoX - 2010-06-18 06:08

Is there a way for vdr to encode in h.264


- hman - 2011-01-04 15:21

Hi all,
also i tryed to use with Dharma streamdev, Tvheadend and Vnsi and just Vnsi is more stable solution to watch tv with xbmc.
Unfortunatelly it does'n still support DTS audio that is used by some HD channels. I tryed to ask for support here but i haven't response for now.


- opdenkamp - 2011-01-04 15:25

@hman:
maybe it helps if you ask in active topics and not bump old topics.


- cAizer - 2011-01-04 20:28

I have installed the things in https://launchpad.net/~lars-opdenkamp/+archive/xbmc-master-pvr?field.series_filter=lucid
but I cant get it to work.
It cannot find my HTS-TVHeadend server.
Is there any configuration I have missed?


- opdenkamp - 2011-01-04 21:11

@cAizer
this topic is (or better: was) for VDR. post your question here: http://forum.xbmc.org/showthread.php?tid=51945

also, like I said multiple times now (and as is in the package description): this is possibly unstable.

use https://launchpad.net/~lars-opdenkamp/+archive/xbmc-pvr

edit:
and post your debug log next time please.