Kodi Community Forum
[RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) (/showthread.php?tid=51322)



RE: - stammie - 2012-05-31 19:59

(2012-05-26 15:44)fredphoesh Wrote:  
(2011-07-07 00:40)cami Wrote:  For me it rarely works. Usually it causes xbmc to lock up/freeze. And pausing sometimes causes the video to stop playing.

Hi there, yep, seems there are others with this same issue, and I have 3 xbmc systems, two on windows, one linux, and all have a very odd fast forward behaviour, the counter jumps 3mins - 4 mins - 2mins - 5mins- 2mins - 5 etc... and then can freeze too...

It would be nice if the progress bar was click-able and you could go-to a certain spot in the show.

Tx for this addon!

Mark.

For those having this lock up/freeze and other weird bugs, I've just started having that problem and have discovered in my case its skin related.
I've been using Aeon Nox 3 and as soon as I play a stream xbmc locks up and I have to shut the program down with task manager to use the pc again,
but I've found if I switch back to the Confluence skin iplayer works perfectly.


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - dmcx - 2012-06-09 01:02

I can't get Horizon - The Transit of Venus (BBC HD) to work on my ATV2, but it works on my windows xbmc.

Can anyone confirm that it works on their ATV2? I have the updated librtmp.0.dylib. Don't know what I'm doing wrong.

Edit: After clicking play about 20 times, it worked. Once. But it fails far more often than it works.

Should the ATV be able to play the HD streams in 3200bps? Is there a limit on bandwidth (should wifi work?) or is the limit the ATV2's 720 output?


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - a5ian300zx - 2012-06-11 19:08

Hi,

I have the latest version and its great but i have two issues.

1) it crashes every time i pause it and play it

2) it crashes when i try to FF or RW

i have a fibre optic 60MB connection and with latest version of XMBC and also Aeon 3 theme.

any feedback or advice appreciated.

Thanks


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - exobuzz - 2012-06-12 21:30

(2012-06-11 19:08)a5ian300zx Wrote:  Hi,

I have the latest version and its great but i have two issues.

1) it crashes every time i pause it and play it

2) it crashes when i try to FF or RW

http://trac.xbmc.org/ticket/11122


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - dmcx - 2012-06-14 18:03

(2012-06-09 01:02)dmcx Wrote:  Edit: After clicking play about 20 times, it worked. Once. But it fails far more often than it works.

The problem is that Akamai servers don't work outside of the UK, must use limelight. (Until it geo-blocks too..)


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - ukjim - 2012-06-18 14:02

(2012-05-26 21:38)k_zeon Wrote:  just upgraded to 2.4.15 and if i try to play any thing from CBBeeies they play for a few minutes then stop. I am on ATV2 4.2.2 with Eden 11.0 stable.
I have tried setting the stream to different settings and each one will stop. Have updated the LibRTMP file to one that says it supports latest features
but there seems no way to actually get the version number etc from the file.
I am in UK so cannot figure out why it keeps stopping.

Can anyone help. thks

got the same problem with xbmcbutu with eden 11.0


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - hbunting - 2012-06-18 19:10

(2012-06-09 01:02)dmcx Wrote:  I can't get Horizon - The Transit of Venus (BBC HD) to work on my ATV2, but it works on my windows xbmc.

Can anyone confirm that it works on their ATV2? I have the updated librtmp.0.dylib. Don't know what I'm doing wrong.

Edit: After clicking play about 20 times, it worked. Once. But it fails far more often than it works.

Should the ATV be able to play the HD streams in 3200bps? Is there a limit on bandwidth (should wifi work?) or is the limit the ATV2's 720 output?

Try changing the "Stream source preference" to "Limelight" under the Streams tab in the iPlayer settings. I had some problems like this before and
changing that seems to have fixed it for me.


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - exobuzz - 2012-06-19 19:45

2.4.16 is released

2.4.16
* fix up live channels again
* disable bbc red button (currently unsure about stream id)


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - exobuzz - 2012-06-22 15:38

2.4.17 is released

2.4.17
* fix up hd streams (bitrate changed from 3200 to 2800kbit)


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - Hitcher - 2012-06-22 17:06

Thanks.


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - buncle - 2012-06-25 20:10

Does anyone happen to know the range of IP addresses/subnets from which the live streams are served? I am able to view episodes served from iPlayer while abroad (I am a UK citizen/license payer, but access via my own VPN in the UK), but I'm struggling to watch live.

Subnets '212.58.0.0' and '212.62.0.0' routed through my vpn work great for streaming episodes, however I have yet to identify specific subnets for live-streaming. Can anyone help?

EDIT: SOLVED! In case this might help anyone else, routing subnet 208.111.0.0 through my VPN fixes live streaming. (I'll definitely need to narrow down the range of IP addresses that I'm routing through - I'm obviously redirecting a massive number if addresses currently - but for now, this is working great!)


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - epatrickt - 2012-06-25 22:32

Thought I was doing well - ATV2 with latest SeasOnPass jailbreak and latest XBMC installed. Have worked out how to install the iplayer add-on (2.4.17) and have got all running. I can traverse the iplayer menu and can get it to play something - it shows working and choosing a stream but then just reverts to the available program lists. I can't find the answer to this, I have looked at the logfile and there are errors which I can't interpret enough to know what is wrong or what to do: http://pastebin.com/6Dk7V8gh

Anyone able to shed some light please? Many thanks


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - buncle - 2012-06-25 23:25

(2012-06-25 22:32)epatrickt Wrote:  ...it shows working and choosing a stream but then just reverts to the available program lists....

I had a very similar issue. Mine was resolved by going to the iPlayer "Add-On Settings", then under 'Streams' I selected 'Limelight' as the "Stream Source Preference" (instead of 'Any'). If Limelight doesn't work for you, try explicitly choosing 'Akamai' or one of the others to see if one particular source works for you.


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - frumpy_uk - 2012-06-29 22:58

(2012-06-22 15:38)exobuzz Wrote:  2.4.17 is released

2.4.17
* fix up hd streams (bitrate changed from 3200 to 2800kbit)

Great work, thanks for maintaining this wicked add-on.


RE: [RELEASE] iPlayer - BBC Video and Music Plugin (UK only!) - epatrickt - 2012-07-02 13:07

(2012-06-25 23:25)buncle Wrote:  
(2012-06-25 22:32)epatrickt Wrote:  ...it shows working and choosing a stream but then just reverts to the available program lists....

I had a very similar issue. Mine was resolved by going to the iPlayer "Add-On Settings", then under 'Streams' I selected 'Limelight' as the "Stream Source Preference" (instead of 'Any'). If Limelight doesn't work for you, try explicitly choosing 'Akamai' or one of the others to see if one particular source works for you.

Buncle thanks for that. I tried selecting the specific streams to no avail at first and then tried again a couple of days later - a reboot in between - to find that with Akamai selected, I can now get iplayer to play live and radio but not any of the recorded material. I can play the nasa tv add-on so I guess the streaming is working and iplayer is happy that I am in the UK (which I am).

Any ideas on the last hurdle please?

Thanks!