Kodi Community Forum
[RELEASE] Justin.tv (Video) Plugin - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Justin.tv (Video) Plugin (/showthread.php?tid=51981)



- Namerp - 2012-02-02 19:13

OpenElec (Eden-pre) JustTV 0.2.3

Channels open right but it plays nothing :/

Code:
18:01:44 T:2829396848  NOTICE: -->Python Interpreter Initialized<--
18:01:44 T:2829396848  NOTICE: Mode: 2
18:01:44 T:2829396848  NOTICE: URL:
18:01:44 T:2829396848  NOTICE: Name: liquidtlo
18:01:44 T:2829396848  NOTICE: catId: None
18:01:44 T:2829396848   ERROR:  EndOfDirectory - called with an invalid handle.
18:01:45 T:3018398416  NOTICE: DVDPlayer: Opening: rtmp://live-cdn.jtvnw.net/live/akamai2_21@6240 jtv=660911ebfe6863026fa4999c3f5e9da769f9ff66:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\2​2twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22i​mapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\22akamai2_21@6240\22,\20\22expiration\22:\201328205704.​6145949,\20\22server\22:\20\22akamai\22} swfUrl=http://www-cdn.jtvnw.net/widgets/live_embed_player.r0d388c71a067b3ec299c86cdbd708d53c259572e.swf?channel=liquidtl​o&referer=http://www.justin.tv/liquidtlo&userAgent=Mozilla/5.0%20(Windows%20NT%206.1;%20WOW64;%20rv:6.0)%20Gecko/20100101%20Firefox/6.0&channel=liquidtlo swfVfy=1 Pageurl=http://www.justin.tv/liquidtlo
18:01:45 T:3018398416 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:01:45 T:2829396848  NOTICE: Thread CDVDPlayer start, auto delete: false
18:01:45 T:2829396848  NOTICE: Creating InputStream
18:01:46 T:2829396848   ERROR: rtmp server sent error
18:01:46 T:2829396848   ERROR: Closing connection: NetStream.Play.StreamNotFound
18:01:46 T:2829396848   ERROR: CDVDPlayer::OpenInputStream - error opening [rtmp://live-cdn.jtvnw.net/live/akamai2_21@6240 jtv=660911ebfe6863026fa4999c3f5e9da769f9ff66:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\2​2twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22i​mapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\22akamai2_21@6240\22,\20\22expiration\22:\201328205704.​6145949,\20\22server\22:\20\22akamai\22} swfUrl=http://www-cdn.jtvnw.net/widgets/live_embed_player.r0d388c71a067b3ec299c86cdbd708d53c259572e.swf?channel=liquidtl​o&referer=http://www.justin.tv/liquidtlo&userAgent=Mozilla/5.0%20(Windows%20NT%206.1;%20WOW64;%20rv:6.0)%20Gecko/20100101%20Firefox/6.0&channel=liquidtlo swfVfy=1 Pageurl=http://www.justin.tv/liquidtlo]
18:01:46 T:2829396848  NOTICE: CDVDPlayer::OnExit()
18:01:46 T:2829396848  NOTICE: CDVDPlayer::OnExit() deleting input stream
18:01:46 T:3018398416   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.jtv.archives/?url=&mode=2&name=liquidtlo&iconimage=http%3A%2F%2Fstatic-cdn.jtvnw.net%2Fjtv_user_pictures%2Fliquidtlo-profile_image-ec057638e717d3fd-600x600.jpeg]
18:01:46 T:2829396848  NOTICE: Thread Background Loader start, auto delete: false
18:01:46 T:3018398416  NOTICE: CDVDPlayer::CloseFile()
18:01:46 T:3018398416 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:01:46 T:3018398416  NOTICE: DVDPlayer: waiting for threads to exit
18:01:46 T:3018398416  NOTICE: DVDPlayer: finished waiting



- tofen - 2012-02-02 23:37

divingmule Wrote:Most channels don't have archives. You can check in a web browser with
Code:
http://api.justin.tv/api/channel/archives/[i]CHANNEL_NAME[/i].json

You will get a 403 if the channel doesn't have archives. Let me know the channel name if you find one that should work but doesn't.

Try the OneMoreGameTV channel. I know that I have gotten there archive to work a few times before the latest patch.

http://api.justin.tv/api/channel/archives/onemoregametv.json

Also, before the patch I usually got a "archives not found" error on the channels without archives. Now, all channels goes straight into an empty page with just the ".." option to go back. No loading screen or anything.


- divingmule - 2012-02-03 15:10

Namerp Wrote:OpenElec (Eden-pre) JustTV 0.2.3

Channels open right but it plays nothing :/

Code:
18:01:44 T:2829396848  NOTICE: -->Python Interpreter Initialized<--
18:01:44 T:2829396848  NOTICE: Mode: 2
18:01:44 T:2829396848  NOTICE: URL:
18:01:44 T:2829396848  NOTICE: Name: liquidtlo
18:01:44 T:2829396848  NOTICE: catId: None
18:01:44 T:2829396848   ERROR:  EndOfDirectory - called with an invalid handle.
18:01:45 T:3018398416  NOTICE: DVDPlayer: Opening: rtmp://live-cdn.jtvnw.net/live/akamai2_21@6240 jtv=660911ebfe6863026fa4999c3f5e9da769f9ff66:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\2​2twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22i​mapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\22akamai2_21@6240\22,\20\22expiration\22:\201328205704.​6145949,\20\22server\22:\20\22akamai\22} swfUrl=http://www-cdn.jtvnw.net/widgets/live_embed_player.r0d388c71a067b3ec299c86cdbd708d53c259572e.swf?channel=liquidtl​o&referer=http://www.justin.tv/liquidtlo&userAgent=Mozilla/5.0%20(Windows%20NT%206.1;%20WOW64;%20rv:6.0)%20Gecko/20100101%20Firefox/6.0&channel=liquidtlo swfVfy=1 Pageurl=http://www.justin.tv/liquidtlo
18:01:45 T:3018398416 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:01:45 T:2829396848  NOTICE: Thread CDVDPlayer start, auto delete: false
18:01:45 T:2829396848  NOTICE: Creating InputStream
18:01:46 T:2829396848   ERROR: rtmp server sent error
18:01:46 T:2829396848   ERROR: Closing connection: NetStream.Play.StreamNotFound
18:01:46 T:2829396848   ERROR: CDVDPlayer::OpenInputStream - error opening [rtmp://live-cdn.jtvnw.net/live/akamai2_21@6240 jtv=660911ebfe6863026fa4999c3f5e9da769f9ff66:{\22swfDomains\22:\20[\22justin.tv\22,\20\22jtvx.com\22,\20\22xarth.com\22,\20\22twitchtv.com\22,\20\2​2twitch.tv\22,\20\22newjtv.com\22,\20\22jtvnw.net\22,\20\22wdtinc.com\22,\20\22i​mapweather.com\22,\20\22facebook.com\22,\20\22starcrafting.com\22],\20\22streamName\22:\20\22akamai2_21@6240\22,\20\22expiration\22:\201328205704.​6145949,\20\22server\22:\20\22akamai\22} swfUrl=http://www-cdn.jtvnw.net/widgets/live_embed_player.r0d388c71a067b3ec299c86cdbd708d53c259572e.swf?channel=liquidtl​o&referer=http://www.justin.tv/liquidtlo&userAgent=Mozilla/5.0%20(Windows%20NT%206.1;%20WOW64;%20rv:6.0)%20Gecko/20100101%20Firefox/6.0&channel=liquidtlo swfVfy=1 Pageurl=http://www.justin.tv/liquidtlo]
18:01:46 T:2829396848  NOTICE: CDVDPlayer::OnExit()
18:01:46 T:2829396848  NOTICE: CDVDPlayer::OnExit() deleting input stream
18:01:46 T:3018398416   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.jtv.archives/?url=&mode=2&name=liquidtlo&iconimage=http%3A%2F%2Fstatic-cdn.jtvnw.net%2Fjtv_user_pictures%2Fliquidtlo-profile_image-ec057638e717d3fd-600x600.jpeg]
18:01:46 T:2829396848  NOTICE: Thread Background Loader start, auto delete: false
18:01:46 T:3018398416  NOTICE: CDVDPlayer::CloseFile()
18:01:46 T:3018398416 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
18:01:46 T:3018398416  NOTICE: DVDPlayer: waiting for threads to exit
18:01:46 T:3018398416  NOTICE: DVDPlayer: finished waiting

Could you turn on system debugging, add-on setting debug, and http://pastebin.com your xbmc.log. Did version 0.2.2 - 0.2.1 work for you?


- divingmule - 2012-02-03 15:11

tofen Wrote:Try the OneMoreGameTV channel. I know that I have gotten there archive to work a few times before the latest patch.

http://api.justin.tv/api/channel/archives/onemoregametv.json

Also, before the patch I usually got a "archives not found" error on the channels without archives. Now, all channels goes straight into an empty page with just the ".." option to go back. No loading screen or anything.

Looking into it, thanks.


- eyoussef - 2012-02-03 15:42

I had installed 0.2.1 on a friends atv, now that it's at 0.2.3 it obviously doesn't work. Since there are no updates available on the atv, I have to do a manual update. Will it over write the previous version or do I have to physically delete 0.2.1 and then go ahead and install 0.2.3?


- divingmule - 2012-02-03 16:14

eyoussef Wrote:I had installed 0.2.1 on a friends atv, now that it's at 0.2.3 it obviously doesn't work. Since there are no updates available on the atv, I have to do a manual update. Will it over write the previous version or do I have to physically delete 0.2.1 and then go ahead and install 0.2.3?

Use 'install from zip' from Settings>Add-ons and you should be good.

@tofen, I think I've found the problem. A workaround for now would be too add a favorite to the add-on's favorites. You don't have any at the moment, correct?


- tofen - 2012-02-03 21:27

divingmule Wrote:@tofen, I think I've found the problem. A workaround for now would be too add a favorite to the add-on's favorites. You don't have any at the moment, correct?

Yes! Worked just fine after I added it to the add-on Favorites.
I only had it Followed / Favored in my JTV account before, and that didn't work.
Thanks'!


- RedPenguin - 2012-02-05 02:50

divingmule Wrote:Some channels are private, you need a password to join. I haven't tried to code support for this, patch is welcomeSmile.



As far as I know, there isn't anything that I can do from the add-on side of things.

Hopefully you end up finding some sort of solution for this as I found a private HLN channel that the plugin refuses to play so I am just watching it in Firefox.

Also it seems like it will be fairly hard to try and record the channel with something like rtmpdump also since I see no way at all to send a password. I tried rtmpsuck but it didn't seem to work, the file was empty afterwards.


Rename Follows - RedPenguin - 2012-02-05 09:55

Hey divingmule, I just got an idea.

Since you really can't get more info from the API and have more details on the channels, can you implement something where we the user can rename it?

I mean like I could right click Muskymusk and name it Bravo.

Thanks again, love the plugin.


- Namerp - 2012-02-06 00:02

@divingmule
version 0.2.2 didn´t work (see the eden pre problem)

Some videos are playing, if the videos (in the browser) are redirected to twitch.tv they are not working in 0.2.3. Couldn´t really verify that. At pastebin the log shows 1 Video which is working and the second isnt´t.

http://pastebin.com/inAM7qvW


- fondary - 2012-02-06 02:32

Thank you for this great plugin !


- divingmule - 2012-02-06 16:24

RedPenguin Wrote:Hey divingmule, I just got an idea.

Since you really can't get more info from the API and have more details on the channels, can you implement something where we the user can rename it?

I mean like I could right click Muskymusk and name it Bravo.

Thanks again, love the plugin.

We may be able to do something like that, when I get time Oo, I'll look into it.


- divingmule - 2012-02-06 16:34

Namerp Wrote:@divingmule
version 0.2.2 didn´t work (see the eden pre problem)

Some videos are playing, if the videos (in the browser) are redirected to twitch.tv they are not working in 0.2.3. Couldn´t really verify that. At pastebin the log shows 1 Video which is working and the second isnt´t.

http://pastebin.com/inAM7qvW

Yeah, twitch.tv videos... Japz and I where looking into this a page or two back. They add a three digit code to the playpath and we haven't yet found the source.


- Namerp - 2012-02-06 17:35

divingmule Wrote:They add a three digit code to the playpath and we haven't yet found the source.
Sad ok, so maybe sometime later Wink


- tofen - 2012-02-06 20:13

divingmule Wrote:Yeah, twitch.tv videos... Japz and I where looking into this a page or two back. They add a three digit code to the playpath and we haven't yet found the source.

Strange, I have been watching a lot of stuff that is redirected to Twitch.tv when typed in a browser, and never encountered that error.
The channel I gave you to test the archives, onemoregametv, is redirected to Twitch.tv for example, and I've got that one to work without any problems.
Actually almost everything I watch with this add-on is really Twitch.tv channels.

Maybe you could try to contact GarMan on Reddit who is a Twitch.tv developer and get this resolved? He seems to be very helpful and open about things. http://www.reddit.com/user/GarMan

Great job otherwise divingmule. I don't think I have thanked you enough before Smile