Kodi Community Forum
[MOD] xTV SAF (Spouse Acceptance Factor) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Skin Help and Support (/forumdisplay.php?fid=67)
+---- Forum: xTV SAF (/forumdisplay.php?fid=76)
+---- Thread: [MOD] xTV SAF (Spouse Acceptance Factor) (/showthread.php?tid=59576)



xTV SAF Movie library mode - s00n - 2010-03-30 08:21

Hi
love the skin, just need to know how to default the skin to have library mode and have the selection of genre, titles and etc without going to root .
any help is appreciated.

thanks

Sunny

PS: i am new to xbmc


- wyrm - 2010-03-31 03:08

s00n Wrote:Hi
love the skin, just need to know how to default the skin to have library mode and have the selection of genre, titles and etc without going to root .
any help is appreciated.

thanks

Sunny

PS: i am new to xbmc

Sunny,

Goto : System -> Settings -> Skin -> Media Sources and select 'Movies button links to library'. Your Movies will then default to Library mode. There is a setting for TV and for Music Videos. The 'Set Default Movie Source' relates to file mode only, so you can't say to default to a particular library entry at this stage. I think I will add how this is handled to my todo list, as I think I can do better in how things are handled (especially in library mode).

Wyrm (xTV SAF)


Feedback and help for Noob's - wyrm - 2010-03-31 03:42

Hey Everyone,

<rant>

Another one of my semi regular BITCHES about the lack of feedback.

The reason that I release this skin Mod to you lot is that it's my way of giving back to the XBMC community. I don't particularly need my Ego stroked (I'm quite comfortable with my place in the world), but it would be nice to have some feedback on bugs or features that people would like to see fixed. Thus far ,the last release of the skin has had about 600 downloads and I've had about half a dozen comments posted since then (and than includes a couple lost to the lightning strike). And to the people asking, "Yes I'm fine thank you, just a bit sore still. I'm on the mend, just slower that I would like, thus the grumpy attitude".

Now this would not really be an issue, but yesterday I again found a section of the skin that could cause XBMC to shutdown (crash). This was caused by the layout of that particular screen changing since the skin was first written, so XBMC could not write out some information that it needed to and thus crashed. No big deal (now fixed), but I can't believe that this has not been spotted by at least one person from the 600 downloads that the skin has received.

PLEASE post any bugs or missing features to this or the bug thread so I can do something about them.

Also please note that I live in Perth Western Australia (the other side of the planet from most of you), so there will just about always be a delay of at least 12 hour between a question from users and an answer from me. If you know the answer to a users question, by all means jump in with an answer it (that's the way you can give back to the community)

</rant>

Wyrm (xTV SAF)


- mcborzu - 2010-03-31 05:15

When I was taking a peek at you playercontrol.xml, the List view Image was blank(Library Mode). It shows for a split second when I leave season level to tv show level...

[Image: wyrm.png]


My info:
W7
r28202


- wyrm - 2010-03-31 05:26

mcborzu Wrote:When I was taking a peek at you playercontrol.xml, the List view Image was blank(Library Mode). It shows for a split second when I leave season level to tv show level...

My info:
W7
r28202

mcborzu,

Thank you, will have a look at it. Don't use Library mode much (although I hope to make it more useful to me and others in my next release), so I don't get to see these problems much. Part of the reason for the above rant. This is exactly the reason I need feedback.

Best of luck with your upcoming skin release. There are a number of things I like the look of, may just have to 'borrow' a couple of them for a future xTV SAF release.

Thanks again

Wyrm (xTV SAF)


- willers.nail - 2010-04-01 14:54

Great skin my girlfriend always did love this skin and now that you have deservedly given it the title xTV SAF she agrees and loves it more lol.

Anyways few little probs at the moment I have with it is that I need to be able to access the raw video files from the home screen via a button. I know I can do this by not linking the Movies and TV Show buttons to the library but would still like a direct way of doing it from the home menu.

The next thing is that I think it would be great if we could have media flags on all the content in the library's.

Another problem may be a bug is that the title and text on the info screen when playing a video is not shown on the bottom panel and is floating between the video itself and the bottom pane.

Cheers for this great skin


- wyrm - 2010-04-02 01:18

willers.nail Wrote:Great skin my girlfriend always did love this skin and now that you have deservedly given it the title xTV SAF she agrees and loves it more lol.

Anyways few little probs at the moment I have with it is that I need to be able to access the raw video files from the home screen via a button. I know I can do this by not linking the Movies and TV Show buttons to the library but would still like a direct way of doing it from the home menu.

The next thing is that I think it would be great if we could have media flags on all the content in the library's.

Another problem may be a bug is that the title and text on the info screen when playing a video is not shown on the bottom panel and is floating between the video itself and the bottom pane.

Cheers for this great skin

willers.nail,

Thank you, my Boss and the kids find the skin useful, so that's the main point for me.

I'm going away for a few days with the family, so will probably not be able to post to the forum, but I am taking a laptop with me. Hopefully I will be able to get a bit of work done on the skin. Currently working on the Video info screen, including adding media flags.

On your bug, I think I know what you are talking about, but a screenshot and your platform details would be helpful. Could you please post them and I will take a look when I get back.

Wyrm (xTV SAF)


- Smiff - 2010-04-06 15:22

hey wyrm, after playing with navix i realise this badly needs a buffering % indicator, shouldn't be too hard, will post back later if i get time tonight.

have a good trip man and keep up the work! Smile

edit: ok here's my first quick mod:
http://sharebee.com/f263b5b9

changes:
1) adds buffering % to fullscreen video display
2) moves buffering label so its doesn't overlap menu bar

installation:
replace your VideoFullScreen.xml from xTV SAF v0.90 in \PAL, with this one.

tested on windows and xbox, PAL and 720p, with mplayer/dvdplayer
screenshot included

if anyone has any suggestions for similar small tweaks please post (may need cleaning up so it translates properly?)


- wyrm - 2010-04-09 15:17

Smiff Wrote:hey wyrm, after playing with navix i realise this badly needs a buffering % indicator, shouldn't be too hard, will post back later if i get time tonight.

have a good trip man and keep up the work! Smile

edit: ok here's my first quick mod:
http://sharebee.com/f263b5b9

changes:
1) adds buffering % to fullscreen video display
2) moves buffering label so its doesn't overlap menu bar

installation:
replace your VideoFullScreen.xml from xTV SAF v0.90 in \PAL, with this one.

tested on windows and xbox, PAL and 720p, with mplayer/dvdplayer
screenshot included

if anyone has any suggestions for similar small tweaks please post (may need cleaning up so it translates properly?)

Smiff,

Just got back. Took an ancient (PIII Celeron 733MHz) laptop with me to do a little work on the skin. Not finished yet (as above system was PAINFULLY SLOW), but I was working on a new VideoInfo screen. Have rudimentary support for media flagging in this screen now.

Will take a look at you mod, but sounds interesting, so can't see why it can't make its way into v0.95.

Wyrm (xTV SAF)


- Smiff - 2010-04-09 23:34

only a tiny mod. i need to go back to my list of ideas i had before, the ones that didn't make it into .90
but anyway i've found this skin pretty solid overall... most of the problems i have with xbmc (streaming video drops etc.) are not skin issues :/


- Smiff - 2010-04-10 17:45

we have "user script on homepage" - why not "user plugin on homepage"?


- Death-Axe - 2010-04-11 13:57

Hi, thanks for updating this skin to work properly with the newer builds and adding features; very much appreciated! I use this skin on the xbox connected to an sdtv; not many skins now support this.

Can I ask for a feature? there are watched overlays in aeon (used on my htpc connected to a hdtv) in the file mode. It puts a tick at the side of a watched item. It would be nice to have this in xtv, as it is not that practical to use library mode on my xbox.

Or is there an easy way to add this myself as a mod (of a mod hehe)?


- Smiff - 2010-04-11 14:45

^ that sounds like a great feature. i also don't use the library.

which reminds me.. the windows version has the very nice feature of generating thumbnails for every video. i realise this is probably excluded from the xbox branch for performance reasons.. but has anyone asked Arnova if he can do a "generate thumbnails for videos when idle" function? slightly OT sorry.


- wyrm - 2010-04-11 16:54

Death-Axe Wrote:Hi, thanks for updating this skin to work properly with the newer builds and adding features; very much appreciated! I use this skin on the xbox connected to an sdtv; not many skins now support this.

Can I ask for a feature? there are watched overlays in aeon (used on my htpc connected to a hdtv) in the file mode. It puts a tick at the side of a watched item. It would be nice to have this in xtv, as it is not that practical to use library mode on my xbox.

Or is there an easy way to add this myself as a mod (of a mod hehe)?

Axe,

That's OK, I too am using the skin on a xbox with sdtv (but I now have a NEW 1080P panel that I would like to throw some 16x9 stuff at).

Will take a look at Aeon and see how its being looked after there. I would like to change how the watched overlay is handled anyway, but again not sure if it will make it into v0.95.

One question though, why don't you use library mode. I don't use it, as as things currently stand it's too difficult to keep media sources separated (adults from kids). I hope to have something in the new version to fix this, so I will probably be changing over to using library mode from that point on. But this sort of thing is useful to know, so that maybe I can do something to fix (improve) things.

Make sure you reply, so that we can improve the skin.

Wyrm (xTV SAF)


- wyrm - 2010-04-11 17:09

mcborzu Wrote:When I was taking a peek at you playercontrol.xml, the List view Image was blank(Library Mode). It shows for a split second when I leave season level to tv show level...


My info:
W7
r28202

mcborzu,

sorry did not get back to you sooner on this. Not entirely sure where I need to look to fix your problem. You are using library mode and just navigating thru your TV shows (so either MyVideo.xml or MyVideoNav.xml) or is the screenshot from somewhere else in the skin?

I will have a bit of a play from this end and see if I can't duplicate the problem, but I am currently using Win XP with r27024. Also only really use library mode when I am testing for things (mostly using file mode), so have not seen this as yet. Might be a build issue. I've had a couple of those (things have changed with XBMC and I have needed to change the skin to fix).

Please keep posting problems like this, as I'm sure there are all sorts of little problems lurking in the skin.

Wyrm (xTV SAF)