Kodi Community Forum
Sick Beard - Automatic TV Show Episode download/sort/rename, nfo/tbn maker & TV Guide - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (/forumdisplay.php?fid=116)
+--- Thread: Sick Beard - Automatic TV Show Episode download/sort/rename, nfo/tbn maker & TV Guide (/showthread.php?tid=63591)



- thezoggy - 2011-02-15 17:28

fishypops Wrote:I am having problems with post processing not working. I am trying to trouble shoot it. I have now found an error:

011-02-14 18:32:09.884000 POSTPROCESSER :: Automatic post-processing attempted but dir doesn't exist

What does this mean ?

that you have the post processing folder set to one that doesn't exist. from the lack of info provided I can only assume you are doing nzb blackhole method and have the tv download dir set to something invalid.


- DrStrange - 2011-02-15 19:58

thezoggy Wrote:go to config > episode downloads, what is your search freq?
It's set at 60 minutes. Shouldn't Sick Beard snatch the nzb when it starts up/when the system is booted if the nzb is available?


- thezoggy - 2011-02-15 20:11

DrStrange Wrote:It's set at 60 minutes. Shouldn't Sick Beard snatch the nzb when it starts up/when the system is booted if the nzb is available?

depends on when last search was run. also search providers have limits in place for api on how many request and how freq. they can be made. honestly I'd suggest using multiple providers or changing your search freq to like 30mins or both.

if you are doing a watch folder w/scan and process. then yes.


- stekre - 2011-02-15 20:12

I think I have found a minor error.

When I add several hosts in xbmc notifications (separated by comma), I just get a test message for the first host. If I go to home and push "update xbmc" it updates all hosts but it says "unable to contact xbmc host".

So functionality seem to work, but not test message and it gives an error when sending xbmc notification.


- jakebake - 2011-02-15 21:44

thezoggy Wrote:yes both sab and sickbeard run in the background. think of it like a web server. if you want proof just launch your task manager and look for the proper .exe name in your list of processes.

Alright cool... can I get sickbeard and sab to start automatically at startup?


- thezoggy - 2011-02-15 23:34

jakebake Wrote:Alright cool... can I get sickbeard and sab to start automatically at startup?

zillions of ways to do this, probably the easiest is just to create a shortcut to the .exe files you want to run in the startup folder on your start menu.


- thezoggy - 2011-02-15 23:34

stekre Wrote:I think I have found a minor error.

When I add several hosts in xbmc notifications (separated by comma), I just get a test message for the first host. If I go to home and push "update xbmc" it updates all hosts but it says "unable to contact xbmc host".

So functionality seem to work, but not test message and it gives an error when sending xbmc notification.

once we get some of these new changes pushed out i'll take a look at it. lots of new goodies very soon Smile


- jakebake - 2011-02-16 00:12

I was downloading some movies and tv shows and most of the time they download and sickbeard (or couch potato) rename them and place them in the right folder but now I keep getting folders that say "UNPACKED tv show name." I can't figure out how to fix this. If it says unpacked I have to change the folder name and manual post process it


- dysan911 - 2011-02-16 04:21

Im trying to setup the Post-Processing part.

The instructions below mention how to edit that "Autoprocesstv.cfg" file which I did successfully and then it totally loses me on setting the appropriate script as your post processing script inside Sabnzbd+


I went over ever setting in Sab and don't see anything regarding a Post Procssing Script.

Thanks!


Change the host, port, username, and password values to the appropriate settings for your Sick Beard server. Then set the appropriate script as your postprocessing script inside SABnzbd+/HellaNZB:

sabToSickbeard.py - linux/OSX SABnzbd+

sabToSickbeard.exe - Windows SABnzbd+

hellaToSickbeard.py - HellaNZB


- tboooe - 2011-02-16 06:19

EDIT: forget it...figured it out...please delete


- jakebake - 2011-02-16 07:00

This problem is really starting to annoy me! Right now I am downloading first season of Blue Bloods (This is not the only show it does this to) and the shows are listed like:
Blue Bloods S0*E0* Episode Name 720p WEB DL DD5 1 H 264 NT

Some episodes will be post processed fine yet others will be in the completed downloads folder as UNPACK Blue Bloods S01E05 What You See 720p WEB DL DD5 1 H 264 NT. Sick beard will not post process with the UNPACK in the name.

Is there any reason for this??


- midgetspy - 2011-02-16 08:50

jakebake Wrote:This problem is really starting to annoy me! Right now I am downloading first season of Blue Bloods (This is not the only show it does this to) and the shows are listed like:
Blue Bloods S0*E0* Episode Name 720p WEB DL DD5 1 H 264 NT

Some episodes will be post processed fine yet others will be in the completed downloads folder as UNPACK Blue Bloods S01E05 What You See 720p WEB DL DD5 1 H 264 NT. Sick beard will not post process with the UNPACK in the name.

Is there any reason for this??

Of course, why would SB process an episode that SAB claims it is in the middle of extracting? The real problem here is that there is a SAB bug where it leaves _UNPACK_ in the filename after it's done, and there's nothing SB can do about that.


- dysan911 - 2011-02-16 17:31

Not that anyone was going to help me on this one but Its all good. I figured it out.



dysan911 Wrote:Im trying to setup the Post-Processing part.

The instructions below mention how to edit that "Autoprocesstv.cfg" file which I did successfully and then it totally loses me on setting the appropriate script as your post processing script inside Sabnzbd+


I went over ever setting in Sab and don't see anything regarding a Post Procssing Script.

Thanks!


Change the host, port, username, and password values to the appropriate settings for your Sick Beard server. Then set the appropriate script as your postprocessing script inside SABnzbd+/HellaNZB:

sabToSickbeard.py - linux/OSX SABnzbd+

sabToSickbeard.exe - Windows SABnzbd+

hellaToSickbeard.py - HellaNZB



- thezoggy - 2011-02-16 18:14

jakebake Wrote:This problem is really starting to annoy me! Right now I am downloading first season of Blue Bloods (This is not the only show it does this to) and the shows are listed like:
Blue Bloods S0*E0* Episode Name 720p WEB DL DD5 1 H 264 NT

Some episodes will be post processed fine yet others will be in the completed downloads folder as UNPACK Blue Bloods S01E05 What You See 720p WEB DL DD5 1 H 264 NT. Sick beard will not post process with the UNPACK in the name.

Is there any reason for this??

posting the same problem over and over isnt going to get anything answered faster. like i mention before, this is a setting in sab that is responsible for this. go on sab's forums and hit them up about fixing this.


- jakebake - 2011-02-16 19:23

thezoggy Wrote:posting the same problem over and over isnt going to get anything answered faster. like i mention before, this is a setting in sab that is responsible for this. go on sab's forums and hit them up about fixing this.

I only posted twice, but would be nice if this forum had a delete function. Anyways, thanks for the help (didn't see where you said that before) I'll go check out the SAB forum for this problem.