Kodi Community Forum
Initial native support for DXVA2 in SVN - Time to say goodbye to your firstborns - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Kodi General Help and Support (/forumdisplay.php?fid=111)
+---- Forum: Windows support (/forumdisplay.php?fid=59)
+---- Thread: Initial native support for DXVA2 in SVN - Time to say goodbye to your firstborns (/showthread.php?tid=69306)



- mindweaver - 2010-02-03 16:51

Sorry to ask again. But is there some new dependency I am missing? Since DXVA was introduced I am unable to build XBMC.

I get alot of these:

Code:
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\CrystalHD\h264_parser.c(232) : warning C4146: unary minus operator applied to unsigned type, result still unsigned
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\CrystalHD\h264_parser.c(339) : warning C4146: unary minus operator applied to unsigned type, result still unsigned
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\CrystalHD\h264_parser.c(918) : warning C4244: 'argument' : conversion from 'double' to 'int', possible loss of data
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(351) : error C2146: syntax error : missing ';' before identifier 'h264'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(351) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(351) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(352) : error C2146: syntax error : missing ';' before identifier 'vc1'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(352) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(352) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(367) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(367) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2228: left of '.bBufType' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(373) : error C2039: 'vc1' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(373) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2039: 'vc1' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2228: left of '.bBufType' must have class/struct/union
CrystalHD.cpp

I am building with the BuildSetup.bat


- Balthazar2k4 - 2010-02-03 16:58

mindweaver Wrote:Sorry to ask again. But is there some new dependency I am missing? Since DXVA was introduced I am unable to build XBMC.

I get alot of these:

Code:
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\CrystalHD\h264_parser.c(232) : warning C4146: unary minus operator applied to unsigned type, result still unsigned
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\CrystalHD\h264_parser.c(339) : warning C4146: unary minus operator applied to unsigned type, result still unsigned
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\CrystalHD\h264_parser.c(918) : warning C4244: 'argument' : conversion from 'double' to 'int', possible loss of data
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(351) : error C2146: syntax error : missing ';' before identifier 'h264'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(351) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(351) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(352) : error C2146: syntax error : missing ';' before identifier 'vc1'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(352) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(352) : error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(367) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(367) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(368) : error C2228: left of '.bBufType' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(373) : error C2039: 'vc1' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(373) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2039: 'h264' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2228: left of '.bStatus' must have class/struct/union
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2039: 'vc1' : is not a member of 'DXVA::CDecoder::Check::'
        ..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(350) : see declaration of 'DXVA::CDecoder::Check::'
..\..\xbmc\cores\dvdplayer\DVDCodecs\Video\DXVA.cpp(374) : error C2228: left of '.bBufType' must have class/struct/union
CrystalHD.cpp

I am building with the BuildSetup.bat

Do you have the latest DirectX SDK installed (August 09)?


- mindweaver - 2010-02-03 17:04

Balthazar2k4 Wrote:Do you have the latest DirectX SDK installed (August 09)?

Not sure which version I have. I will try and install it, thanks.


- mindweaver - 2010-02-03 17:23

I installed August 09 and I get the same errors :/


- elupus - 2010-02-03 18:19

You are missing the platform sdk with the dxva headers. It's normally included when you install visual studio I think.

What visual studio and what os are you trying to compile on?


- Nickman99 - 2010-02-03 18:25

elupus Wrote:You are missing the platform sdk with the dxva headers. It's normally included when you install visual studio I think.

What visual studio and what os are you trying to compile on?
I get the same errors.
I compile on Visual C++ 2008 Express Edition, Windows 7.


- elupus - 2010-02-03 18:27

That cut build log posted doesn't show everything. There aught to be an error telling what failed to include above all those errors.


- mindweaver - 2010-02-03 18:39

Visual Studio 2008, Windows 7 64-bit

http://tillytech.se/BuildLog.htm


- Nickman99 - 2010-02-03 18:39

elupus Wrote:That cut build log posted doesn't show everything. There aught to be an error telling what failed to include above all those errors.
The definitions of DXVA_Status_H264 and DXVA_Status_VC1 can't be found (DXVA.cpp). Thats where the errors come from.


- o_dog - 2010-02-03 18:43

anyone got this to work on Intel 4500MHD? or any 4500HD version?


- tiben20 - 2010-02-03 18:57

dxva headers are from the windows platform sdk


- Nickman99 - 2010-02-03 19:25

tiben20 Wrote:dxva headers are from the windows platform sdk
Thanks, the errors are gone.
I've installed "Microsoft Windows SDK for Windows 7 and .NET Framework 3.5 SP1".


- Rob79 - 2010-02-03 19:41

I am also getting the total green screen on the ATI HD2600, going to try on my HD3450 when I get home, so have we come to a conclusion on what is causing the green screen? I have updated my catalyst just to see if that was it. Running Windows 7 32bit. Looking forward to this feature though, and thanks for all the hard work >Wink


- elupus - 2010-02-03 19:42

Odd.. that stuff should be in dxva.h


- Hitcher - 2010-02-03 20:11

Rob79 Wrote:I am also getting the total green screen on the ATI HD2600, going to try on my HD3450 when I get home, so have we come to a conclusion on what is causing the green screen? I have updated my catalyst just to see if that was it. Running Windows 7 32bit. Looking forward to this feature though, and thanks for all the hard work >Wink
I get the same with my HD2400 but having just tried Boxee (for DXVA testing purposes) everything's fine so hopefully that means it's something that can be fixed for XBMC.