Kodi Community Forum
[Linux] HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Announcements, Info, and General Discussion (/forumdisplay.php?fid=85)
+--- Forum: Tips, tricks, and step by step guides (/forumdisplay.php?fid=110)
+--- Thread: [Linux] HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware (/showthread.php?tid=70068)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - pumkinut - 2012-08-11 00:06

Gave the right EDID information for my 1080p LG set. Even gave me a modeline for 23.976.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - robo989 - 2012-08-11 04:37

(2012-08-11 00:06)pumkinut Wrote:  Gave the right EDID information for my 1080p LG set. Even gave me a modeline for 23.976.

Cheers, will give them a go Smile


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - puntloos - 2012-08-30 01:39

Just a datapoint: I'm on OpenElec 1.95.7 and it seems to work out of the box for me, I'm pretty sensitive to judder etc, and I haven't spotted many problems. (an occasional stutter but so far I'm putting them down to buffering/performance issues rather than timing)

also OpenElec doesn't actually have the nvidia-settings command so I think you're pretty much sunk if you need tuning beyond what the OpenElec guys did.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - zofiel - 2012-09-02 11:59

Deleted


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Stefanhvt - 2012-09-03 15:15

(2012-08-30 01:39)puntloos Wrote:  Just a datapoint: I'm on OpenElec 1.95.7 and it seems to work out of the box for me, I'm pretty sensitive to judder etc, and I haven't spotted many problems. (an occasional stutter but so far I'm putting them down to buffering/performance issues rather than timing)

also OpenElec doesn't actually have the nvidia-settings command so I think you're pretty much sunk if you need tuning beyond what the OpenElec guys did.

And what about out of sync issues? Openelec 1.95.7 still uses the old audio engine so I would only use it if the audio is in perfect sync.
(2012-08-11 00:06)pumkinut Wrote:  Gave the right EDID information for my 1080p LG set. Even gave me a modeline for 23.976.

I've not noticed this yet. For me it was necessary to add the 23.976 modeline manually.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - puntloos - 2012-09-04 00:54

(2012-09-03 15:15)Stefanhvt Wrote:  And what about out of sync issues? Openelec 1.95.7 still uses the old audio engine so I would only use it if the audio is in perfect sync.
The only sync problem I noticed is movies that are not 24p, but I believe I can fix that by selecting sync audio to TV? THere's some option.
Quote:I've not noticed this yet. For me it was necessary to add the 23.976 modeline manually.



RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Stefanhvt - 2012-09-04 23:08

(2012-09-04 00:54)puntloos Wrote:  
(2012-09-03 15:15)Stefanhvt Wrote:  And what about out of sync issues? Openelec 1.95.7 still uses the old audio engine so I would only use it if the audio is in perfect sync.
The only sync problem I noticed is movies that are not 24p, but I believe I can fix that by selecting sync audio to TV? THere's some option.
Quote:I've not noticed this yet. For me it was necessary to add the 23.976 modeline manually.

The amount of sensitivity for this differs from person to person.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - puntloos - 2012-09-05 01:27

(2012-09-04 23:08)Stefanhvt Wrote:  The amount of sensitivity for this differs from person to person.

Very true. Dunno, I guess AV sync sensitivity is an unusual discipline, I think I'm about as sensitive as the next guy, but also the material has to be obvious. Dialogue is difficult (for one, the actual movies usually aren't shot this way, audio is dubbed in later, so the source itself might actually be off) but when you see and hear gunshots even the slightest discrepancies are obvious.

I'm aware openelec doesn't do audioengine yet (and I cant wait for different reasons...) but are there good alternatives to it? Is live linux xbmc tried and proven or is any build that supports audioengine going to be "touchy" by necessity?


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Stefanhvt - 2012-09-05 02:05

(2012-09-05 01:27)puntloos Wrote:  
(2012-09-04 23:08)Stefanhvt Wrote:  The amount of sensitivity for this differs from person to person.

Very true. Dunno, I guess AV sync sensitivity is an unusual discipline, I think I'm about as sensitive as the next guy, but also the material has to be obvious. Dialogue is difficult (for one, the actual movies usually aren't shot this way, audio is dubbed in later, so the source itself might actually be off) but when you see and hear gunshots even the slightest discrepancies are obvious.

I'm aware openelec doesn't do audioengine yet (and I cant wait for different reasons...) but are there good alternatives to it? Is live linux xbmc tried and proven or is any build that supports audioengine going to be "touchy" by necessity?

I've heard it's quite stable. I'm using this build: http://www.xbmcfreak.nl/en/xbmcbuntu-12-04-with-pre-frodo-mid-august-release/

After install I've updated the nvidia drivers to the newest and added a 23.976 modeline.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - leepenny - 2012-09-13 14:12

I have sooo many questions as I just cannot find the correct xorg config to get fluid playback. But I will be restrained and post a couple of questions at a time.
1. When finding out the modes for my tv do I have to bypass the receiver
2. When set up correctly using the xorg posted previously I still get dropped frames? Is this the norm
Receiver; Pioneer VSXS300 TV; Samsung 46 inch led tv
I have been trying to fix my problems for a good while now and feel like I am sinking in quicksand(all be it slowly)
Running xbmcubuntu 11.10 ;open gl 3.3.0 ;nvidia 304.43
gpu; nvidia geforce 210; intel celeron dual core @2.4 (one core always maxed out)

PS Please be kind although knowledgeable in some areas, this is not one of them


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - FernetMenta - 2012-09-13 16:53

leepenny, how many dropped frames do you observe? can you post output of xbmc-xrandr and a debug log?


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Stefanhvt - 2012-09-13 17:35

(2012-09-13 14:12)leepenny Wrote:  I have sooo many questions as I just cannot find the correct xorg config to get fluid playback. But I will be restrained and post a couple of questions at a time.
1. When finding out the modes for my tv do I have to bypass the receiver
2. When set up correctly using the xorg posted previously I still get dropped frames? Is this the norm
Receiver; Pioneer VSXS300 TV; Samsung 46 inch led tv
I have been trying to fix my problems for a good while now and feel like I am sinking in quicksand(all be it slowly)
Running xbmcubuntu 11.10 ;open gl 3.3.0 ;nvidia 304.43
gpu; nvidia geforce 210; intel celeron dual core @2.4 (one core always maxed out)

PS Please be kind although knowledgeable in some areas, this is not one of them

Can you make sure the mode is actually working? Give this commands to linux while a video is playing:

export DISPLAY=:0
nvidia-settings -nt -q refreshRate3


It will show the hz output, which should be 23.976 hz for smooth playback.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - villeneuve - 2012-09-13 17:51

I get 23.971 hz when doing that. Is that ok, too?


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - Stefanhvt - 2012-09-13 18:08

No, it's not. You should make a modeline for 23.976.


RE: HOW-TO achieve perfect playback at 23.97 or 59.94 Hz with NVIDIA GPU hardware - leepenny - 2012-09-13 18:27

First thing first @fernetmenta will post log later this evening, frames lost is about 60 ish on start of movie then after whole movie about 200-800. TBH I dont tend to sit through a film with the codec info on (not very wife friendly) so frames dropped is a ball park figure.

After typing xbmc-xrandr into putty I get an error: command not found
entering xrandr in putty I get an error -
No protocol specified

Can't open display :0
After entering this is putty when a movie is playing

export DISPLAY=:0
nvidia-settings -nt -q refreshRate3

I get an error - no protocol specified
ERROR: The control display is undefined; please run NVidia settings --help for usage information

@fernetmenta Thank you for answering my question so quickly and will do my best to provide any info you need