Kodi Community Forum
[RELEASE] Pandora Radio (Script) Music Addon (Updated 2011-11-13 : V1.2.8) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Music Add-ons (/forumdisplay.php?fid=148)
+---- Thread: [RELEASE] Pandora Radio (Script) Music Addon (Updated 2011-11-13 : V1.2.8) (/showthread.php?tid=70471)



- tinfox - 2011-12-27 16:43

thewarm Wrote:V1.29 works for me using the newly released beta of Eden!

I clicked on the refetch keys... script failed. Works anyway!

Link at MF is jacked. Is 1.29 mirrored somewhere? Can I get a bin off of the git?


- thewarm - 2011-12-27 17:37

tinfox Wrote:Link at MF is jacked. Is 1.29 mirrored somewhere? Can I get a bin off of the git?

I just checked... this link IS good!
http://www.mediafire.com/?0hbda1p2r94u78j


- ZestyChicken - 2011-12-27 17:53

thewarm Wrote:I just checked... this link IS good!
http://www.mediafire.com/?0hbda1p2r94u78j

The script runs intermittently on Eden Beta on OSX. Sometimes fails, sometimes shows. The icon does not appear under Music as it does under Dharma (well a Dec 2011 Dharma nightly).

Overall I love the script. The smoke backdrop is stunning. I wouldn't mind something to create a moving picture though to prevent burn-in on my plasma.


- ZestyChicken - 2011-12-27 19:07

ZestyChicken Wrote:The script runs intermittently on Eden Beta on OSX. Sometimes fails, sometimes shows. The icon does not appear under Music as it does under Dharma (well a Dec 2011 Dharma nightly).

Overall I love the script. The smoke backdrop is stunning. I wouldn't mind something to create a moving picture though to prevent burn-in on my plasma.

Holy crap - I just noticed there is a cool visualization running in the background on the smoke backdrop. Never noticed that before. Awesome! Also solves the burn-in issue.


- htpc guy - 2011-12-27 20:15

ZestyChicken Wrote:Holy crap - I just noticed there is a cool visualization running in the background on the smoke backdrop. Never noticed that before. Awesome! Also solves the burn-in issue.

Glad you like itBig Grin


- jmj52 - 2011-12-27 21:55

Having a problem with 1.2.9 on eden beta for OSX. Plays about 4 songs then quits. Wont allow me to restart add-on until I close/open XBMC. Here is the log:

http://pastebin.com/FiAPh1As


- bostoneric - 2011-12-29 05:22

once you select the down arrow to hide the controls/artist list how do you get it back up?

and is there a way to add more skins?


- Cocheese - 2011-12-29 17:46

Could the prob be with pandora constantly asking "are you still listening" @ the website?


- Joebeer - 2011-12-31 10:25

I have 3 favorite music add-ons. (pandora, grooveshark and mflow) I use pandora the most. I just noticed that grooveshark and mflow aren't working. Is there a fix 4 that? I know this isn't the right place 2 ask but I remember an Advancedsettings.xml fix in this thread I believe but I might be wrong. I gave up searching after 40 pages. I'm on atv2 4.3 Eden beta


- macf1an - 2011-12-31 13:22

head to the grooveshark and mflow threads - it's all there
(hint: mflow is dead, grooveshark isn't yet)


- Bandit_Kaine - 2012-01-01 03:51

Please fix pandora.. It's the only reason i use my apple tv anymore and it seems to be (somewhat) broken lately.

1. Stops playing after about 4 songs.
2. Doesn't reload (script error), I have to reboot the appletv.
3. Doesn't show song or artist information just random numbers.

I'm running openelec.


Further info on issue - friedfarmer - 2012-01-01 21:38

friedfarmer Wrote:I've been having a problem with v1.2.9
It will play exactly 4 songs in any channel then it stops until I select a channel again.
This was not occuring when v1.2.8 was working. Any ideas?

Windows 7
latest nightly xbmc build, (now using Eden Beta 1 build - same issues)

Well I stumbled unto more info regarding this issue:

#1. When running xbmc in windowed mode it works fine, no stopping after 4 songs. Also on the pandora startup screen the last icon in bottom row is "zzz". Everything runs perfectly.
#2. When running in true fullscreen it stops after 4 songs. Must restart it by clicking on a channel again, then 4 songs again, etc. etc. etc. Also the last icon on Pandora startup screen bottom row is a "circled i" not the zzz's.
#3. I tried full screen in windowed mode and still stops after 4 songs. Last icon on Pandora startup screen bottom row is a "circled i" not the zzz's.

So it appears the issue has definitely something to do with the windows screen mode.

any ideas?


- volkswagner - 2012-01-03 03:36

Thanks for a great XBMC add-in!

ZestyChicken Wrote:Holy crap - I just noticed there is a cool visualization running in the background on the smoke backdrop. Never noticed that before. Awesome! Also solves the burn-in issue.


Hmn,

I cant get anything but the tiny "P" Pandora icon flashing when I use the "hide down arrow". I have tried the default theme and Tansparancy! theme. Also if just left on the Pandora interface window, the screensaver won't kick in either.

How can I get some sort of visualization or screen saver?

I'm using 1.29 version of the script and Windows XP, XBMC 10.1

Also I'd rather not have to run the T! theme since it does not have a remote friendly power/exit/sleep button. This is not a show stopper if I can get some sort of visualiztion going... maybe I can program a button on the remote.

I do get an error in the log when using Pandora, but I can get visualizion to work when using the XBMC built in music player.


Code:
20:15:11 T:624 M:304619520  NOTICE: DVDPlayer: Opening: http://audio-sjl-t2-2.pandora.com/access/5143663530629151649?version=4&lid=523809434&token=j3TneDconC%2FKqOxR%2FseoxqMwTIPpZYhT2%2FhpvPgf0JXi85%2FZZoIGs60b1LNCAm​nv63YY8xBVNs5sG3lXc5pQw%2F2TDlSbbYoaJvD6Qoa1fBPZGOkTGEVhgtQ9wsFuVG7WT7pyy75yTfde​3X64owJUw%2FZUqluJ%2BDHPShVS%2FSII3eUZOAmFIeNQh3FRjOCqhNIi1xbU%2Fy4POnLJcG2Cz5QU​znPaTQ1IEfQpqS52Slzk%2FrMbp07n%2BSpe%2FVZ3zRv%2FRziHIHZjpLQy5xsNgmesk2JvUd%2B9Wd​DEarJV4PVgTl2LgqKAA0%2Bc800SsRABk5tfBs%2FzQ8OjtPMtrv5eJsXxia0elgX5zxYEsvVb
20:15:11 T:624 M:304615424 WARNING: CDVDMessageQueue(player)::Put MSGQ_NOT_INITIALIZED
20:15:11 T:2924 M:304599040  NOTICE: Creating InputStream
20:15:11 T:2924 M:304209920  NOTICE: Creating Demuxer
20:15:13 T:2924 M:299610112  NOTICE: Opening audio stream: 0 source: 256
20:15:13 T:2924 M:299610112  NOTICE: Finding audio codec for: 86017
20:15:13 T:2924 M:299491328  NOTICE: Creating audio thread
20:15:13 T:2924 M:299470848 WARNING: CDVDMessageQueue(video)::Put MSGQ_NOT_INITIALIZED
20:15:13 T:2400 M:299450368  NOTICE: running thread: CDVDPlayerAudio::Process()
20:15:13 T:2400 M:299483136  NOTICE: Creating audio device with codec id: 86017, channels: 2, sample rate: 44100, no pass-through
20:15:13 T:2448 M:299253760  NOTICE: PANDORA: onPlayBackStarted: http://audio-sjl-t2-2.pandora.com/access/5143663530629151649?version=4&lid=523809434&token=j3TneDconC%2FKqOxR%2FseoxqMwTIPpZYhT2%2FhpvPgf0JXi85%2FZZoIGs60b1LNCAm​nv63YY8xBVNs5sG3lXc5pQw%2F2TDlSbbYoaJvD6Qoa1fBPZGOkTGEVhgtQ9wsFuVG7WT7pyy75yTfde​3X64owJUw%2FZUqluJ%2BDHPShVS%2FSII3eUZOAmFIeNQh3FRjOCqhNIi1xbU%2Fy4POnLJcG2Cz5QU​znPaTQ1IEfQpqS52Slzk%2FrMbp07n%2BSpe%2FVZ3zRv%2FRziHIHZjpLQy5xsNgmesk2JvUd%2B9Wd​DEarJV4PVgTl2LgqKAA0%2Bc800SsRABk5tfBs%2FzQ8OjtPMtrv5eJsXxia0elgX5zxYEsvVb
20:15:13 T:2400 M:297517056 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available
20:15:14 T:624 M:297201664   ERROR: ADDON: Dll MilkDrop, throws an exception 'Unknown exception' during m_pStruct->Render (CVisualisation::Render). Contact developer 'Team XBMC' with bug reports
20:15:14 T:624 M:283209728   ERROR: ADDON: Dll MilkDrop, throws an exception 'Access violation' during m_pDll->Create. Contact developer 'Team XBMC' with bug reports
20:19:01 T:2400 M:278544384 WARNING: CDVDMessageQueue(audio)::Get - asked for new data packet, with nothing available



- grahambr - 2012-01-03 17:22

Hi all -

I have been scanning the forum trying to find instructions on how to install this....can someone point me in the right direction?

I found this link: http://lesliex317537.com/2011/02/27/how-to-get-pandora-on-jailbroken-apple-tv-2/

I ran it..it appeared to work fine, but there is no PANDORA option in MUSIC add-on that I can see.

Please help... I am very new to XBMC.


- grahambr - 2012-01-03 17:49

Nevermind...got it to work from this post:

http://forum.xbmc.org/showpost.php?p=760364