Kodi Community Forum
[DEPRECIATED] XBMC Subtitles - Addon Script (previously OpenSubtitles OSD) - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Subtitle Add-ons (/forumdisplay.php?fid=143)
+---- Thread: [DEPRECIATED] XBMC Subtitles - Addon Script (previously OpenSubtitles OSD) (/showthread.php?tid=75437)



- DigiTech - 2011-12-08 22:37

amet Wrote:we need a debug log, my signature has how to

Hi Amet the only log i found is located in:

users/x/appdata/roaming/xbmc/xbmc.log

is that the one? if it is so, where can i upload that log or can i paste it here?

Thanks again!


- amet - 2011-12-09 08:53

DigiTech Wrote:Hi Amet the only log i found is located in:

users/x/appdata/roaming/xbmc/xbmc.log

is that the one? if it is so, where can i upload that log or can i paste it here?

Thanks again!

http://wiki.xbmc.org/index.php?title=Log_file


- DigiTech - 2011-12-10 17:59

amet Wrote:http://wiki.xbmc.org/index.php?title=Log_file

Here is the log Amet, i tried to open the first two tv shows subtitles with subdivx none of them worked (it opened the sub but nothing happened) and then the last one with opensubtitles which suceed..

http://pastebin.com/9mFL2x1w


- amet - 2011-12-10 20:50

DigiTech Wrote:Here is the log Amet, i tried to open the first two tv shows subtitles with subdivx none of them worked (it opened the sub but nothing happened) and then the last one with opensubtitles which suceed..

http://pastebin.com/9mFL2x1w

thats not a debug log, you need to enable debug logging

if you are running addon with icefilms you are on your own, I cant run icefilms here...


- DigiTech - 2011-12-10 22:25

Well thanks for the "help" anyway.
I''ll try to find out on my own as you said.


- tschi - 2011-12-11 11:55

hi, I am using last eden pre build on win7 (in french), and the subtitle addon + external player (mphc, zomplayer + vsfiter or ffdshow subtitles), the media files are stored on freenas with SMB shares.
I have some issue with special character (é, à etc)
It seems the subtitles are not saved in UTF8 (notepad++ say the files is ANSI as UTF8).
If I open it with notepad++ and coverted to UTF8, it is ok.
Is it possible to save file as UTF8 with XBMC Subtitle ?
Thank you for your consideration Smile


- amet - 2011-12-11 12:15

tschi Wrote:hi, I am using last eden pre build on win7 (in french), and the subtitle addon + external player (mphc, zomplayer + vsfiter or ffdshow subtitles), the media files are stored on freenas with SMB shares.
I have some issue with special character (é, à etc)
It seems the subtitles are not saved in UTF8 (notepad++ say the files is ANSI as UTF8).
If I open it with notepad++ and coverted to UTF8, it is ok.
Is it possible to save file as UTF8 with XBMC Subtitle ?
Thank you for your consideration Smile

its all up to the subtitle provider, addon does not fiddle with the subtitle at all.

we download, extract and rename ... that is all


- Evilcheese - 2011-12-11 19:50

Hi,
Is subscenter support broken again? I'm getting the same problem again. It finds results but hangs a while after selecting the file in which I want to download and then it says that it cannot save the files - Same problem as before


- john.doe - 2011-12-19 19:30

Subtitle from http://titlovi.com/ not work anymore.Sad


- arubinst - 2011-12-22 19:43

Support for subdivx.com seems to be broken since a couple of days ago.

The addon keeps reporting "No Subtitles Found!". I've manually checked the website and subs are indeed available.


- arubinst - 2011-12-23 15:00

Ok, I found what's wrong with subdivx.

The addon is asking the page to sort search results by the number of downloads

Code:
url = main_url + "index.php?accion=5&masdesc=&[b]oxdown=1[/b]&pg=" + str(page) + "&buscar=" + urllib.quote_plus(searchstring)

The problem is that something is broken in subdivx.com and sorting by number of downloads yields nothing.

A simple workaround for now is sorting results by date, for example.

Code:
url = main_url + "index.php?accion=5&masdesc=&[b]oxfecha=2[/b]&pg=" + str(page) + "&buscar=" + urllib.quote_plus(searchstring)

This will yield results starting with the most recent.

I hope this helps anyone!


- jamesonmula - 2011-12-23 20:24

arubinst Wrote:Ok, I found what's wrong with subdivx.

The addon is asking the page to sort search results by the number of downloads

Code:
url = main_url + "index.php?accion=5&masdesc=&[b]oxdown=1[/b]&pg=" + str(page) + "&buscar=" + urllib.quote_plus(searchstring)

The problem is that something is broken in subdivx.com and sorting by number of downloads yields nothing.

A simple workaround for now is sorting results by date, for example.

Code:
url = main_url + "index.php?accion=5&masdesc=&[b]oxfecha=2[/b]&pg=" + str(page) + "&buscar=" + urllib.quote_plus(searchstring)

This will yield results starting with the most recent.

I hope this helps anyone!

Hi arubinst!

I am the one who did the original development of the script. I am not a Python expert and, you know, it's hard to find some free time during Hols, but I will do my best to have this mess fixed ASAP.

Thanks for your workaround, it will be a great help!


- jamesonmula - 2011-12-23 21:40

jamesonmula Wrote:Hi arubinst!

I am the one who did the original development of the script. I am not a Python expert and, you know, it's hard to find some free time during Hols, but I will do my best to have this mess fixed ASAP.

Thanks for your workaround, it will be a great help!

OK, fixed it and sent to Amet...


Subscenter service version 1.3 - orivar - 2011-12-24 14:07

Hi everyone,

I've been informed of a new issue with the Subscenter service (thanks Ido). It seems there's been another small change to the website which resulted in scraping problems for some TV shows and movies.
A new version has been uploaded to the github repo. Amet, please review and distribute it.

@Evilcheese: The new version will not address the issues you're having. Subscenter have been publishing .sub formatted subtitles for some time but do not actually host them. If you go to the website itself and look for whichever subtitle that's causing the issue you reported you will see that instead of a subtitles file they upload a dummy file and in the notes they direct you to a hosting service with the actual subtitle.
I have no intention of discovering and following said links, scraping the variety of possible hosting services is a PITA Oo. Please use the Sratim service (their site does host .sub formatted files) or wait for a .srt formatted file to be released.

Happy Holidays.


- The_Ben - 2011-12-24 18:16

Hi,
I've recently installed the addon on my ATV2G, and I'm having difficulties with it.
While I can search for subtitles and even download them (or at least that's what the addon says), they don't display afterwards - the video keeps playing as if I did nothing whatsoever.
This happens from all of the subtitles sources I've tried, in both languages I tried (English & Hebrew).

Any help on the matter will be most appreciated,
Ben

P.S
Subtitles that are in the same dir as the video display perfectly fine. i.e if I have 2 files in a folder, one is movie.mkv and the other is movie.sub, the subtitles WILL display just fine.