Kodi Community Forum
CouchPotato - Automatic Movie Downloader via NZB & Torrents - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (/forumdisplay.php?fid=116)
+--- Thread: CouchPotato - Automatic Movie Downloader via NZB & Torrents (/showthread.php?tid=75960)



- TheStretchedElf - 2011-10-13 08:39

I have "filename" in my my rename options set to

<thename> (<year>) [<quality>]<cd>.<ext>

but this is what I get

[Image: couchpotatorename.jpg]

What can I do to prevent the superfluous "cd" being added?


- MrHaugen - 2011-10-13 11:26

darkscout Wrote:https://github.com/RuudBurger/CouchPotato/

You can just install python on windows and do it that way.

Or get py2exe: http://www.py2exe.org/

Could you elaborate please? I'm pretty new to anything web that's not IIS, and I have minimal Linux experience. So all this is pretty new to me. Is there a Python version that is editable? And what exactly can I do with py2exe?

I do have a Python version installed on my server I think. As I'm also running Sickbeard, SABnzbd+ and Headphones from it. Not sure who is using it though. Most seemed to get packaged with web components?


- johnmerrick - 2011-10-13 13:40

any ideas on why the cp userscript would suddenly stop working?

I keep getting web page not available even though it is!

thanks


- clubwerks - 2011-10-13 17:06

TheStretchedElf Wrote:I have "filename" in my my rename options set to

<thename> (<year>) [<quality>]<cd>.<ext>

but this is what I get

[Image: couchpotatorename.jpg]

What can I do to prevent the superfluous "cd" being added?

You could probably start by taking the <cd> out of the renaming options, since I don't think that's actually an option.


- bwqbbq - 2011-10-13 20:34

TheStretchedElf Wrote:I have "filename" in my my rename options set to

<thename> (<year>) [<quality>]<cd>.<ext>

What can I do to prevent the superfluous "cd" being added?

I don't think you properly added <cd> in there. Perhaps you forgot the "<>", recheck your settings. The <cd> normally adds at least "cd1" whereas you just have "cd" in the name.


- clubwerks - 2011-10-13 21:21

What's weird is that it only put the cd tag on the nfo, tbn and fanart.


- newtothis - 2011-10-13 21:36

I saw that Full NFO files was in progress,is there a way to set this up now?
Loving the programme, thank you for all the hard work.


- BULLIT - 2011-10-19 03:50

Hey Guys.
Just started using this tool about a month ago and it's awesome. Although, I was wondering where the options are for renaming the fanart and thumbs that are downloaded. mine all download as Movie.tbn, fanart.jpg and so on. I'm running it i Linux Mint. Any help would be great. Thanks.


- clubwerks - 2011-10-19 04:31

BULLIT Wrote:Hey Guys.
Just started using this tool about a month ago and it's awesome. Although, I was wondering where the options are for renaming the fanart and thumbs that are downloaded. mine all download as Movie.tbn, fanart.jpg and so on. I'm running it i Linux Mint. Any help would be great. Thanks.

I don't think there are options for renaming those. I think it just downloads them in standard XBMC naming convention.


- BULLIT - 2011-10-19 16:39

clubwerks Wrote:I don't think there are options for renaming those. I think it just downloads them in standard XBMC naming convention.

Yeah, Not sure. Although the guy at the top of this page seems to be getting his fanart and tbn's with cd at the end of them. My movie folder always turn out like this,

Fast Five.mkv
movie.tbn
fanart.jpg
movie.nfo

Not,

Fast Five.mkv
Fast Five.tbn
Fast Five.nfo
Fast Five-fanart.jpg


- clubwerks - 2011-10-19 16:54

BULLIT Wrote:Yeah, Not sure. Although the guy at the top of this page seems to be getting his fanart and tbn's with cd at the end of them. My movie folder always turn out like this,

Fast Five.mkv
movie.tbn
fanart.jpg
movie.nfo

Not,

Fast Five.mkv
Fast Five.tbn
Fast Five.nfo
Fast Five-fanart.jpg


What's wrong with that? Those work fine as long as each movie is in it's own folder.


- nrgaway - 2011-10-19 17:23

clubwerks Wrote:What's wrong with that? Those work fine as long as each movie is in it's own folder.

Programs like Plex only delete files related to the filename, so when deleting "Fast Five" it would delete "Fast Five"* and the remaining thumbs, etc would not get deleted in the above case; sucks for me Smile


- BULLIT - 2011-10-19 18:15

clubwerks Wrote:What's wrong with that? Those work fine as long as each movie is in it's own folder.

Actually a lot, When you use multiple ways to play this content and already have 800+ movies, I don't want to change it all now. Media Companion names them for me the way I need. Just wanting to see if this does as well.


- acegutta22 - 2011-10-19 20:39

hello eveyone Ive been using this program for 2 weeks with no problem but as of last night it wont let me add any movie and now when i try to use the userscript i get this Error 500 Internal any sugestions?


- clubwerks - 2011-10-19 20:52

I guess when you're in an XBMC forum asking about a program that was written with XBMC integration in mind, you kind of get what you get in regards to how the program operates.