Kodi Community Forum
[RELEASE] cdART Manager Script - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (/forumdisplay.php?fid=151)
+---- Thread: [RELEASE] cdART Manager Script (/showthread.php?tid=77031)



RE: [RELEASE] cdART Manager Script - Martijn - 2012-04-28 20:31

Got a database error when trying to run. If you want a full log let me know
http://xbmclogs.com/show.php?id=2002 (error is in the end of the log)


RE: [RELEASE] cdART Manager Script - giftie - 2012-04-29 01:38

(2012-04-28 20:31)Martijn Wrote:  Got a database error when trying to run. If you want a full log let me know
http://xbmclogs.com/show.php?id=2002 (error is in the end of the log)

Linux? I thought you were a Windows Guy? Smile Wow, lots of errors in that log.. From what I can see, you started the script by selecting the Build Database in background from the settings screen, correct?

I think I know the problem.. This probably was that this was the first and only time you ran the script, correct? The folder that the script uses to store its database has not yet been created by XBMC(ie you haven't clicked on OK in the settings...) If this is the case, I need to do a test and make sure that this folder has been created. I already do this if the script is started, it will automatically open the settings page.

If this was also the case, the quick work around on your side would be to open up the settings and click on OK, though XBMC might have already created the '/storage/.xbmc/userdata/addon_data/script.cdartmanager' folder.

If this wasn't the case, maybe a debug log would help..

Thanks


RE: [RELEASE] cdART Manager Script - Martijn - 2012-04-29 03:17

Yes i'm a windows guy. I only use OpeneElec cause windows started showing BSOD cause my hardware is failing and this keeps running Wink
and it is so damn easy to set up Big Grin

The error are known issues of next aired and do pollute the logsSmile
Indead started it through build in background. First did run the the add-on setting before started the build but not sure if i clicked ok before actually building it.
So that would explain some things as the folder wasn't created yet and i already had the setting panel open.

Will do some more thinkering. Also saw you use the fanart XML. Perhaps the JSON is somewhat easier to use. Will do some quick code comparison on that.


RE: [RELEASE] cdART Manager Script - Wanilton - 2012-04-29 05:22

@Giftie, latest translate for portuguese (Brazil), download here:

http://dl.dropbox.com/u/25170804/cdartmanager/strings.xml

Thanks,

Wanilton


RE: [RELEASE] cdART Manager Script - giftie - 2012-04-29 06:21

(2012-04-29 05:22)Wanilton Wrote:  @Giftie, latest translate for portuguese (Brazil), download here:

http://dl.dropbox.com/u/25170804/cdartmanager/strings.xml

Thanks,

Wanilton

Thanks for the translation..


RE: [RELEASE] cdART Manager Script - giftie - 2012-04-29 17:49

New test version available. A couple of fixes
https://github.com/downloads/Giftie/script.cdartmanager/script.cdartmanager.2.5.5.zip

2.5.5
- added option to settings enable/disable "All Artists" when building Database
- added ability to cancel local artist building
- added more testing to insure that work folder has been created
- added logging of script settings


RE: [RELEASE] cdART Manager Script - Wanilton - 2012-04-29 19:58

@giftir, latest translate to Portuguese (Brazil), version 2.5.5, download here:

http://dl.dropbox.com/u/25170804/cdartmanager/strings.xml

In setting addon, I have 3 item in English
Files & Folders
Custom Colors
Extra Settings,

I like translate 3 phrases for pt br, too, is possible add strings?

thanks

Wanilton


RE: [RELEASE] cdART Manager Script - giftie - 2012-04-29 21:17

Thanks again.

I fixed the fixed english strings that you found. I added one more string Smile lol..

Code:
<string id="32143">Extra Settings</string>

The other two are already in the strings, I just needed to add them to the settings.

(2012-04-29 19:58)Wanilton Wrote:  @giftir, latest translate to Portuguese (Brazil), version 2.5.5, download here:

http://dl.dropbox.com/u/25170804/cdartmanager/strings.xml

In setting addon, I have 3 item in English
Files & Folders
Custom Colors
Extra Settings,

I like translate 3 phrases for pt br, too, is possible add strings?

thanks

Wanilton



RE: [RELEASE] cdART Manager Script - Wanilton - 2012-04-29 23:21

(2012-04-29 21:17)giftie Wrote:  Thanks again.

I fixed the fixed english strings that you found. I added one more string Smile lol..

Code:
<string id="32143">Extra Settings</string>

The other two are already in the strings, I just needed to add them to the settings.

(2012-04-29 19:58)Wanilton Wrote:  @giftir, latest translate to Portuguese (Brazil), version 2.5.5, download here:

http://dl.dropbox.com/u/25170804/cdartmanager/strings.xml

In setting addon, I have 3 item in English
Files & Folders
Custom Colors
Extra Settings,

I like translate 3 phrases for pt br, too, is possible add strings?

thanks

Wanilton

Thank you, I add new translate string 32143, download here:

http://dl.dropbox.com/u/25170804/cdartmanager/strings.xml

Wanilton


RE: [RELEASE] cdART Manager Script - giftie - 2012-05-06 16:10

New test version, hopefully the last one..

https://github.com/downloads/Giftie/script.cdartmanager/script.cdartmanager.2.5.6.zip


RE: [RELEASE] cdART Manager Script - giftie - 2012-05-07 00:25

Another update. Thanks Martijn for all the bug checking...

https://github.com/downloads/Giftie/script.cdartmanager/script.cdartmanager.2.5.7.zip


RE: [RELEASE] cdART Manager Script - LanceyJSC - 2012-05-11 15:03

Guys is there a full tutorial for this. I have spent the last 2 days trying wrap my head around this.

I have my music structure setup correctly.

ARTIST >> ALBUM >> SONGS

I'm more interested in where I put my fanart.jpg and possibly artist.jpg as I listen to obscure stuff getting cd arts itself is non existent.

I should my imagine my 1st question is does CD ART actually handle local artist and fanart?

2nd would be could someone please help as I'm getting quite frustrated.

Thanks in advanced


RE: [RELEASE] cdART Manager Script - giftie - 2012-05-11 18:29

(2012-05-11 15:03)LanceyJSC Wrote:  Guys is there a full tutorial for this. I have spent the last 2 days trying wrap my head around this.

I have my music structure setup correctly.

ARTIST >> ALBUM >> SONGS

I'm more interested in where I put my fanart.jpg and possibly artist.jpg as I listen to obscure stuff getting cd arts itself is non existent.

I should my imagine my 1st question is does CD ART actually handle local artist and fanart?

2nd would be could someone please help as I'm getting quite frustrated.

Thanks in advanced

cdART Manager does handle finding and downloading of Artist Fanart, Artist Logos, cdARTs and Cover Art. It does not at the moment handle Artist Art(artist.jpg).

artist.jpg and fanart.jpg need to go into the Artist level of your file structure. You also have to update the music library for these images to be picked up.(I believe)

Also the first page of this thread does have some messages in regards of the add on setup.(first two)


RE: [RELEASE] cdART Manager Script - WhiteHartMart - 2012-05-13 09:01

Hi - just got back into the world of XBMC and have a OpenElec build running. I see the add on is showing as 'Broken' in the menus and that other OE users have had issues on over the past few months.

I've downloaded the latest version here but just get 'Script failed' on start up. Looking at the most recent post on the OE forums would suggest this still isn't compatible.

Just checking if this is the case really or if there's a workaround at all?


RE: [RELEASE] cdART Manager Script - Martijn - 2012-05-13 09:09

(2012-05-13 09:01)WhiteHartMart Wrote:  Hi - just got back into the world of XBMC and have a OpenElec build running. I see the add on is showing as 'Broken' in the menus and that other OE users have had issues on over the past few months.

I've downloaded the latest version here but just get 'Script failed' on start up. Looking at the most recent post on the OE forums would suggest this still isn't compatible.

Just checking if this is the case really or if there's a workaround at all?

latest version posted by giftie works for me on openelec.
Post a full Debug Log on http://xbmclogs.com/ or use the script listed in my signature