Kodi Community Forum
[RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] YouTube (Video) Plugin - De facto default standard YouTube Addon for XBMC (/showthread.php?tid=79487)



Where do you put this code? - Ry J - 2011-06-14 18:37

pike Wrote:Good News everyone that runs Git HEAD of XBMC, a while back I managed to convince grandmaster Elupus to enable something that can best be described as "Download to local disk and then play" it's all transparent but (for now) it needs an advanced setting added/changed:

Code:
<network>
   <cachemembuffersize>0</cachemembuffersize>
  </network>

with this in place, XBMC will download http videos to disk transparently, you might have noticed there is new buffer info in the dialog ? If you pause playback, this will increase until it reached 100% this means the full video clip sits local on hdd. It can best be described as how Youtube works in a WWW browser or Quicktime.



So if you're feeling that youtube is throttling you too much, simply pause playback for a minute or so and that should give trouble free playback for X mins depending on length of clip and your connection.

This seems like a pretty niffty fix but I don't understand where I insert this code. Can you give a little bit more detail as to what file I insert this into?


- activate - 2011-06-15 11:51

Is this advanced setting working on atv2 with the nightlies.


- Ry J - 2011-06-16 01:08

activate Wrote:Is this advanced setting working on atv2 with the nightlies.

Not really sure. I found a link to that quote in the icefilms thread. Then when I replied to it I ended up in this thread. It was kinda weird.


- pike - 2011-06-16 01:21

Ry J Wrote:This seems like a pretty niffty fix but I don't understand where I insert this code. Can you give a little bit more detail as to what file I insert this into?

http://wiki.xbmc.org/index.php?title=Advanced_Configuration
Quote:advancedsettings.xml

This file, which may be created by a user in their UserData folder, can contain additional settings and can contain pre-defined values for the settings available in the GUI (thus removing them from the GUI settings screens.) Useful for advanced users and for installers.

http://wiki.xbmc.org/index.php?title=Advancedsettings.xml

==

need more help? ask specific questions then..


- speed32219 - 2011-06-16 03:11

I've upgraded librtmp to the latest version and have no more incompatible errors and all other addons work great. When I try and play any genre movie, I'm getting the same error over and over again. Here is a copy of the error:

YouTube Version 2.04
Ubuntu 10.10, 2.6.35-28-generic
XBMC Built on Apr 25 2011 (Git:Unknown)


Code:
21:01:42 T:119356272 M:731127808   DEBUG: Process - The source file to load is /home/XBMC/.xbmc/addons/plugin.video.youtube/default.py
21:01:42 T:119356272 M:731127808   DEBUG: Process - Setting the Python path to /home/XBMC/.xbmc/addons/plugin.video.youtube:/home/XBMC/.xbmc/addons/script.module.beautifulsoup/lib:/home/XBMC/.xbmc/addons/script.module.cryptopy/lib:/home/XBMC/.xbmc/addons/script.module.simplejson/lib:/usr/share/xbmc/addons/script.module.pil/lib:/home/XBMC/.xbmc/addons/script.module.danishaddons/:/home/XBMC/.xbmc/addons/script.web.viewer/lib:/home/XBMC/.xbmc/addons/script.module.elementtree/lib:/usr/share/xbmc/addons/script.module.pysqlite/lib:/usr/lib/python2.6:/usr/lib/python2.6/plat-linux2:/usr/lib/python2.6/lib-tk:/usr/lib/python2.6/lib-old:/usr/lib/python2.6/lib-dynload:/usr/local/lib/python2.6/dist-packages:/usr/lib/python2.6/dist-packages:/usr/lib/pymodules/python2.6:/usr/lib/pymodules/python2.6/gtk-2.0:
21:01:42 T:119356272 M:731127808   DEBUG: Process - Entering source directory /home/XBMC/.xbmc/addons/plugin.video.youtube
21:01:42 T:119356272 M:731127808   DEBUG: Instantiating addon using automatically obtained id of "plugin.video.youtube" dependent on version 1.0 of the xbmc.python api
21:01:42 T:119356272 M:731127808  NOTICE: YouTube-2.0.4
21:01:44 T:5818176 M:731119616    INFO: Loading skin file: DialogProgress.xml
21:01:44 T:5818176 M:731119616   DEBUG: Load DialogProgress.xml: 5.74ms
21:01:44 T:5818176 M:731119616   DEBUG: DialogProgress::StartModal called
21:01:44 T:5818176 M:731119616   DEBUG: ------ Window Init (DialogProgress.xml) ------
21:01:44 T:5818176 M:731119616   DEBUG: Alloc resources: 0.46ms (0.01 ms skin load)
21:01:44 T:119356272 M:731119616    INFO: Scriptresult: Success
21:01:44 T:119356272 M:731119616    INFO: Python script stopped
21:01:44 T:119356272 M:731119616   DEBUG: Thread Python Thread 119356272 terminating
21:01:44 T:5818176 M:731119616   DEBUG:  WaitOnScriptResult - plugin exited prematurely - terminating
[b]21:01:44 T:5818176 M:731119616   ERROR: Playlist Player: skipping unplayable item: 0, path [plugin://plugin.video.youtube/?path=/root/explore/movies&action=play_video&videoid=EkyPw6Q6430][/b]
21:01:44 T:5818176 M:731119616   DEBUG: Playlist Player: no more playable items... aborting playback
21:01:44 T:2983197552 M:731119616   DEBUG: Thread Background Loader start, auto delete: 0
21:01:44 T:5818176 M:731119616   DEBUG: waiting for python thread 49 to stop
21:01:44 T:5818176 M:731119616   DEBUG: python thread 49 destructed
21:01:44 T:2983197552 M:731119616   DEBUG: Thread Background Loader 2983197552 terminating
21:01:44 T:5818176 M:731119616   DEBUG: ------ Window Deinit (DialogProgress.xml) ------

Failing and Working: http://pastebin.com/4DcqvNyi

FYI: I did get one video to load and it would load any time I came back to it. It almost looks like a scrapper issue, like files are not there.
The YouTube genre was crime and the selection is The Negotiator.


Uncaught Error - mooreted - 2011-06-16 07:19

Using Dharma 10.1 on Mint 11 x64. Trying to get any Youtube shows to play results in an uncaught error. Here is my log with Youtube debugging on:

http://www.box.net/shared/bqqpyz5yozvkzvr7p10q


Stream failing (Curl error) - SniperCharlie - 2011-06-16 22:49

I am on Dharma on OSX, and the youtube plugin has been failing for me.

Here is the log:
http://pastebin.com/jeCYTrrU

Notice the URL passed to DVDplayer has IP=64.0.0.0 which doesn't seem correct.

Any information would be greatly appreciated. I am not at home at the moment but if you need a debug log I can do that. I have no advancedsettings.xml, and tried the most recent version as well from the repo with no improvement.

I tried with and without being logged in. This is just a video from the search results.

Thanks!


- HenrikDK - 2011-06-16 23:14

SniperCharlie Wrote:I am on Dharma on OSX, and the youtube plugin has been failing for me.

Here is the log:
http://pastebin.com/jeCYTrrU

Notice the URL passed to DVDplayer has IP=64.0.0.0 which doesn't seem correct.

Any information would be greatly appreciated. I am not at home at the moment but if you need a debug log I can do that. I have no advancedsettings.xml, and tried the most recent version as well from the repo with no improvement.

I tried with and without being logged in. This is just a video from the search results.

Thanks!

Hi, the "&ip=" part of that url is only used for localization and geo-location (and in my experience never corresponds to you're own ip), the real address is immediately after the "http://", but since the error message comes from the dvdplayer's curl module and is basically "curl failed with code 56" theres not much we can do. The only thing i could find about this message would seem to indicate it was related to youtube having server issues.

http://www.google.com/search?q=curl+56&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a#sclient=psy&hl=en&safe=off&client=firefox-a&rls=org.mozilla:en-US%3Aofficial&source=hp&q=%E2%80%9Dcurl+failed+with+code+56%22&aq=f&aqi=p-p1&aql=&oq=&pbx=1&fp=93cad48529e129ce&biw=1280&bih=687

Note: this might also be firewall related though i doubt it since the python plugin was able to contact google to provide the search listing


- TapRackPull - 2011-06-21 20:35

I would like to create a keystroke in keyboard.xml to activate the youtube plugin.
Before i spin my wheels for days would
<y>XBMC.ActivateWindow(video,plugin://plugin.video.youtube)</y>
be a working key map for youtube? Or is something missing from this line?
I appreciate any input.


- TapRackPull - 2011-06-21 21:21

OR... would either of these lines of code be more accurateConfused

<y>RunPlugin(plugin://plugin.video.youtube)</y>

<y>RunPlugin(plugin.video.youtube)</y>


- HenrikDK - 2011-06-21 22:21

TapRackPull Wrote:OR... would either of these lines of code be more accurateConfused

<y>RunPlugin(plugin://plugin.video.youtube)</y>

<y>RunPlugin(plugin.video.youtube)</y>
Hi haven't tried this myself but I think the answer you're looking for might be here:
http://forum.xbmc.org/showthread.php?tid=42073


- TapRackPull - 2011-06-22 01:46

@HenrikDK

That was EXACTLY what I needed. I don't know where you dug that up, but thanks man.


- atr675 - 2011-06-23 05:17

Any update how I can playall or continuous playback?


- SwiftNano - 2011-06-23 15:33

mooreted Wrote:Using Dharma 10.1 on Mint 11 x64. Trying to get any Youtube shows to play results in an uncaught error. Here is my log with Youtube debugging on:

Hi All,

Sorry if I am missing something I know there have been a few posts for this but I am unclear from what was said if this is something that is being worked on or something that cannot be fixed/needs fixing by someone else?

I too am experiencing uncaught error when trying to watch anything from the "Shows" category i.e. 4OD shows. It appears for me after selecting the specific show to list the episodes to play rather than trying to play a specific stream. If you need a log posted let me know.

YouTube Version 2.0.4
Ubuntu 10.04
XBMC Dharma 10.1


- HenrikDK - 2011-06-23 23:14

SwiftNano Wrote:Hi All,

Sorry if I am missing something I know there have been a few posts for this but I am unclear from what was said if this is something that is being worked on or something that cannot be fixed/needs fixing by someone else?

I too am experiencing uncaught error when trying to watch anything from the "Shows" category i.e. 4OD shows. It appears for me after selecting the specific show to list the episodes to play rather than trying to play a specific stream. If you need a log posted let me know.

YouTube Version 2.0.4
Ubuntu 10.04
XBMC Dharma 10.1

Yeah seems youtube changed layout again, i'll look into a fix.