Kodi Community Forum
HOW-TO synchronize your XBMC Media Center between every room in the house: Lifehacker - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Announcements, Info, and General Discussion (/forumdisplay.php?fid=85)
+--- Forum: Tips, tricks, and step by step guides (/forumdisplay.php?fid=110)
+--- Thread: HOW-TO synchronize your XBMC Media Center between every room in the house: Lifehacker (/showthread.php?tid=80829)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38


- Blaxxor - 2012-01-31 09:05

So what do I have to change in my current Dharma SQL setup to be able to update to Eden without getting any errors ?

(3 PC's)

//Stellan


- kri kri - 2012-02-01 21:11

Do I need to set up my sources on each computer now? I have 2 xbmc installs and my desktop I created a new profile and my tv and movies just showed up.


- Ned Scott - 2012-02-02 07:39

kri kri Wrote:Do I need to set up my sources on each computer now? I have 2 xbmc installs and my desktop I created a new profile and my tv and movies just showed up.

http://forum.xbmc.org/showpost.php?p=1004948&postcount=329


- Jedfordski - 2012-02-05 10:41

I've setup MySQL on my Server, followed the intructions and added the Advancedsettings.xml file to all PC's. However, XBMC has now slowed to a crawl, it's taking ages to go from one menu to the next, assuming it doesn't just hang. Any ideas?


- Ned Scott - 2012-02-06 06:20

The XBMC Wiki how-to has been turned into a multi-page guide. I figure this format will be easier to follow and less overwhelming. It also includes a little part about using path subs for converting local shares to network shares, and a list of other userdata items that are safe to path sub.

Thoughts, feedback, criticisms, praise, insults, etc?

http://wiki.xbmc.org/index.php?title=HOW-TO:Sync_multiple_libraries


CWinFileSMB Error - mholzma - 2012-02-09 04:14

First, awesome guide and I think the wiki is good (but I'd leave the bit about the database name and how XBMC tries to append 58 to it)

I am trying to do a path substitution for the sources.xml and mediasources.xml from my XMBC installation on my windows 7 pc to my Samba running on a linux box. I can access the share without a problem, but I get the following error in the xbmc.log:

ERROR: CWINFileSMB: Unable to open file '\' Error '123

It won't save any of the sources I create. Is this a permission problem or some type of windows to linux credential issue?

Thanks


- macrossmaxim - 2012-02-09 04:46

So I went through this for the last 3 days and thought i would share.

The mysql part is pretty straight forward except the recent change for CREATING the database in Eden. If you create the db prior it won't work just add the user in mysql and edit your advancedsettings.xml.

Thumbnail sharing is very straight forward just check that you can browse to that location and copy past the path right into the advancedsettings.xml.

I run a mac mini on my tv dedicated to xbmc with windows and mac satellite machines all running eden beta2 with a single dlna remote on my tablet. It's a breeze to add new ones as you just need to modify the xml slightly per machine.

Your friends are the xbmc.log it pretty much tells you all you need to know and enabling debugging for even more info. Here's my advancedsettings.xml.


<advancedsettings>
<videodatabase>
<type>mysql</type>
<host>192.168.0.11</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
<name>xbmc_video</name>
</videodatabase>

<musicdatabase>
<type>mysql</type>
<host>192.168.0.11</host>
<port>3306</port>
<user>xbmc</user>
<pass>xbmc</pass>
<name>xbmc_music</name>
</musicdatabase>

<pathsubstitution>

<substitute>
<from>/Volumes/Media 2/</from>
<to>SMB://192.168.0.11/media2/</to>
</substitute>

<substitute>
<from>/Volumes/Media 1/</from>
<to>SMB://192.168.0.11/media1/</to>
</substitute>

<substitute>
<from>/Volumes/HP 2TB/</from>
<to>SMB://192.168.0.11/media3/</to>
</substitute>

<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>SMB://192.168.0.11/xbmc/Library/Application Support/XBMC/userdata/Thumbnails/</to>
</substitute>

</pathsubstitution>

</advancedsettings>


- malibu327 - 2012-02-09 06:58

This guide helped a lot compared to other guides(lifehacker). Although, there was one thing that wasnt in this guide that I needed for mine to work, and that was adding an exception to the windows firewall. I added it to the wiki link you provided in the mysql windows setup section. If yall find it "non-useful" or grammatically incorrect please edit or delete it, but I did have to make an exception in my windows firewall in my test environment and my actual xbmc server. Thanks for the guide.

Ned Scott Wrote:The XBMC Wiki how-to has been turned into a multi-page guide. I figure this format will be easier to follow and less overwhelming. It also includes a little part about using path subs for converting local shares to network shares, and a list of other userdata items that are safe to path sub.

Thoughts, feedback, criticisms, praise, insults, etc?

http://wiki.xbmc.org/index.php?title=HOW-TO:Sync_multiple_libraries



- Ned Scott - 2012-02-09 22:19

malibu327 Wrote:This guide helped a lot compared to other guides(lifehacker). Although, there was one thing that wasnt in this guide that I needed for mine to work, and that was adding an exception to the windows firewall. I added it to the wiki link you provided in the mysql windows setup section. If yall find it "non-useful" or grammatically incorrect please edit or delete it, but I did have to make an exception in my windows firewall in my test environment and my actual xbmc server. Thanks for the guide.

Your addition was great! That's the great thing about a wiki, you can instantly add whatever is missing, and even if you make a mistake or two (not that I saw any with your's) then that's easily updatable too.


- mattdamon - 2012-02-10 00:19

chrissbu Wrote:From what I understand, even if you've used other tools for scraping metadata for the content, XBMC will still cache the thumbnails into a common thumbnail directory.

I'm having a problem getting the path substitution to work at all. I've created a folder on //jeeves/videos/XBMCThumbs, and added the code for the path substitution, but XBMC is still leaving the thumbnails on a local drive. I've tried

Code:
<pathsubstitution>
  <substitute>
    <from>special://masterprofile/Thumbnails/</from>
    <to>smb://jeeves/videos/XBMCThumbs</to>
  </substitute>
</pathsubstitution>






as well as

Code:
<pathsubstitution>
  <substitute>
    <from>special://masterprofile/Thumbnails/</from>
    <to>//jeeves/videos/XBMCThumbs</to>
  </substitute>
</pathsubstitution>

but nether seem to work. One thing I found is that I'm not running one of the nightlies...I'm using the main release. I will look at updating to one of the nightlies if that might take care of it.

Try this.....

<pathsubstitution>
<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>\\YOUR PC NAME\Users\YOUR USERNAME\AppData\Roaming\XBMC\userdata\Thumbnails</to>
</substitute>
</pathsubstitution>

this works perfectly over my 4 machines advanced settings.xml saved in the userdata folder of each machine

note that you will have to share your userdata folder on your local machine


- mattdamon - 2012-02-10 00:25

Hi guys,

Have my databases working great with eden beta 2 running over 4 machines. What I am trying to do without success is share my tv logos across the network. They work on the local machine but not sure where they are stored so i can set them to share across the other machines.


- Ned Scott - 2012-02-10 00:59

try adding a pathsub for /addon_data/

http://wiki.xbmc.org/index.php?title=HOW-TO:Sync_multiple_libraries/Sync_other_parts_of_XBMC#Add-on_data


- mattdamon - 2012-02-10 10:14

Ned Scott Wrote:try adding a pathsub for /addon_data/

http://wiki.xbmc.org/index.php?title=HOW-TO:Sync_multiple_libraries/Sync_other_parts_of_XBMC#Add-on_data

I have added path sub for addon data but no luck?


- snoopy78 - 2012-02-10 19:32

Hi Guys,

i just get really confused about my XBMC EDEN BETA 3 path substitution.

currently i have my advancedsettings.xml like that
"
<advancedsettings>
<videodatabase>
<type>mysql</type>
<host>172.16.0.2</host>
<port>3306</port>
<user>USER</user>
<pass>PASS</pass>
<name>xbmc_video</name>
</videodatabase>

<musicdatabase>
<type>mysql</type>
<host>172.16.0.2</host>
<port>3306</port>
<user>USER</user>
<pass>PASS</pass>
<name>xbmc_music</name>
</musicdatabase>

<pathsubstitution>
<substitute>
<from>special://masterprofile/keymaps/</from>
<to>smb://USER:PASS@172.16.0.2/xbmc/xbmc/userdata/keymaps/</to>
</substitute>
<substitute>
<from>special://masterprofile/Thumbnails/</from>
<to>smb://USER:PASS@172.16.0.2/xbmc/xbmc/userdata/Thumbnails/</to>
</substitute>

<substitute>
<from>special://masterprofile/sources.xml</from>
<to>SMB://USER:PASS@172.16.0.2/xbmc/xbmc/userdata/sources.xml</to>
</substitute>

<substitute>
<from>special://masterprofile/mediasources.xml</from>
<to>SMB://USER:PASS@172.16.0.2/xbmc/xbmc/userdata/mediasources.xml</to>
</substitute>
</pathsubstitution>

</advancedsettings>


The SQL is up and running, the keymap and thumbnails also work.
Only the sources.xml & mediasources.xml give me errors in the log.

"
18:19:25 T:9892 NOTICE: Loading media sources from special://masterprofile/sources.xml
18:19:25 T:9892 ERROR: CWINFileSMB: Unable to open file '\' Error '123
18:19:25 T:9892 ERROR: CSettings::LoadSources Error loading special://masterprofile/sources.xml: Line 0, Failed to open file
"


Don't really know why anymore...:confused2:

Clients are 3x XBMC Eden Beta 3 Win 7 Clients and the server is a Qnap TS-119PII server (smb share is called xbmc).

BR
snoopy78


- Herkatus - 2012-02-11 13:27

Hi!

I used to have XBMC live on a HTPC. But then I decided to shift my files to a NAS (xtreamer etrayz) and share it.

Now I have a HTPC with openlec xbmc 10.1 and a ATV2 with eden... I know that, to share the library, it has to be the same release but that's not my problem, at least now...

Firstly I exported the db on my live htpc, afterwards I followed the guide. I have user, db, xml... everything is created. After everything created I went to openelc htpc and import the db but now there's the problem: it looks like is importing but it doesn't... nor to xbmc nor to mysql... I just can't put everything to work... And I'm also having difficulties stating the contents of the sources...
help?