Kodi Community Forum
XBMC Commander - Yet another unofficial third-party XBMC remote for iPad - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Supplementary Tools for Kodi (/forumdisplay.php?fid=116)
+--- Thread: XBMC Commander - Yet another unofficial third-party XBMC remote for iPad (/showthread.php?tid=81018)



- DarkHelmet - 2011-04-21 11:56

I love the look of it. Have you guys tried changing the looks of it in the settings section? I agree about the gestures remote though. I find myself switching to other ipod remotes in case I need a remote functionality.


- crud - 2011-04-21 18:17

flxfxp Wrote:Hey grywnn,

I love the XBMC Commander app, it rocks! However, I don't like the whole schoolboard kind of look. It would be awesome to have a theme that looks kind of like this:

[Image: IMG_0022.png]

What do you think? Thanks and keep on rocking!

that is awesome, I was thinking that this kind of switch would be great for the already almost perfect app.

the gestures thing is great but way too sensitive to use as a remote for navigation. I have this on my iphone too and find myself using the controls section. Strange why it was left out of the ipad app.


- Greddy2000 - 2011-04-23 02:48

Love the app.

Can we get a resume playback of a movie when we select play from the movie selection screen? We can do this in xbmc, and it really helps to start watching where you left off.

And is there a way to launch xbmc from within the app?


- Elbert - 2011-04-23 16:45

A great application. Just installed it on my iPad and I absolutely love it. Thanks a lot!


Thumbnails for Movie Sets - BruceH - 2011-04-23 18:41

My first post here.
Having to say that I love XBMC & I love the XBMC commander app on both iPad and iPhone.
Only have one niggle.
I can't see a thumbnail image for movie sets on the app.
I see the thumbnails on XBMC itself.
I see thumbnails for all other movies.
I also see thumbnails for the movies within the app.

Is anyone else having this problem?
Does anyone know the JSON commands that are being called, so I could attempt to debug this.

Thanks,
Bruce.


- mjreddy - 2011-04-24 01:58

Greddy2000 Wrote:Love the app.

Can we get a resume playback of a movie when we select play from the movie selection screen? We can do this in xbmc, and it really helps to start watching where you left off.

And is there a way to launch xbmc from within the app?

Just purchased today! Agreed, great app! I pray that you continue to develop it (unlike collect3) and I'm sure the folks onnthis board will help support it's development...

Some thoughts/suggestions I had:

What do you think about adding DLNA/upnp support to the app? There are apps in app store that are able to stream from and serve to xbmc via upnp... Would be awesome to have a single app able of controlling your entire media experience! I suppose if anyone is close to figuring out how to natively bake AirPlay into xbmc, this wont be as vital...)

Also, as someone already suggested allowing this app to launch xbmc would be great. I suppose all you would need to do is have it connect to a vnc on the computer and pass some command line arguments or even just hokeys... Hotkeys would be cool to enable even more versatility (I currently have hotkeys setup to switch my monitor array and open xbmc on my tv, at present I have to use hippo remote to do this first then open commander)

Would it be possible for the gesture based remote to interpret a clockwise/counterclockWise rotary movement as a scroll command? Sort of like unwire using a knob to scroll? Currently it seems to see it as discrete directional swipes depending on where in rotation u are...

I'm sure adding different themes to the app is part of your plans, may I suggest a coverflow type option as the interface, would def be cool.

Is it possible for the app to now the current play/pause state and accordingly display only the play or pause button rather than both?

Loading of bookmarks within the app?

What about incorporating a web browser into the app so links don't have to switch to safari? Also this could allow people to checkon the stuff we rely on to keep our xbmc uptodate (sabnzb, couchpotato, sickbeard, and hopefully soon audiomatic!!) from within the app.

Sorry for the long list, but my minds running wild with the possibilities and it finally seems like someone has stepped to the plate of creating an appealing fully functional remote for the iPad here...

Thanks again! Look fwd to ur next update... Big Grin


- dzlzfame - 2011-04-24 17:14

"Enqueue Album" does not work on the iPhone version, even though the button is there in the interface.

Will this be implemented?

Also, will artist or album search be implemented in the iPhone version?

Thanks.


- ihjones - 2011-04-24 20:06

Any app which would reliably connect to the XBMC OOB would be great! So far I haven't found one Sad

It should be simple enough to configure right? disable the Windows firewall, create a profile on the router to allow passthrough via the selected port, configure XBMC, configure the app and voila!! sadly no way to date has there be any way to connect Sad

Several days of opening firewalls, changing ports, hacking the network, now my netwok is completely exposed to the world Sad but I can connect to the XBMC finally YAY!!!! now to secure the network.. lets hope I don't inadvertently close the connection to my remote..


- ihjones - 2011-04-24 21:33

On the XBMC Commander
There is something going on with with the movie list which shows only 41 movies? some of those listed are somehow duplicated!! yet those duplicated movies are not duplicated in the "Commander" files list?? Just when I thought I'd got the library hierarchy all figured out, this happens!! Have been trying to track the issue to it's source which maybe the skin or how I originally set up how XBMC loads. Not sure how this happened but we have a movies list and a videos list?? there is only an option to start up XBMC with videos loaded (ie not movies..), the app only lists movies, so things are a mess Sad Am going to have to investigate this more..

The video library on the XBMC doesn't appear to be corrupted in any way which lists all movies flawlessly with no duplicates and correct posters.

The cache has been cleared and rebuilt but no change, not sure but does XBMC commander read nfo data or searches different criteria to build lists where the files listing doesn't. Reason I say that is because when movies listing are displayed not only is it limited to 41 movies and some are duplicates but also some movies show different posters than the file library and on the XBMC itself!!

Ok so added the whole library to the "Movies" source yet still no more than 41 movies listed..


Any ideas?


- ihjones - 2011-04-24 22:05

Additionally, had some issues when selecting remote often causes the commander app to crash! I'm thinking now maybe was caused by path name changes. we'll see.


- clipper99 - 2011-04-25 05:59

The problem I was having with all my movie/tv/music missing because I "upgraded" to XBMC nightly builds is SORT OF fixed with the latest XBMC Commander release.
SORT OF as in all my library icons reappeared but now I can only play music. I can't get any TV shows or movies to play. I can get movie trailers to work and play through XBMC.


- zepfan - 2011-04-25 06:37

Nightly builds are experimental. If it's causing problems, don't use it.


- Montevideo - 2011-04-25 13:21

Montevideo Wrote:Have said earlier on the thread how much I love this app, and it remains true.

Having an issue with the music though - doesn't seem to read the library completely. For example, I just added an EP to iTunes, it has been picked up and can be played in XBMC but the app only sees the artist and the ep but not the actual tracks?

If you tap play album the ipad quits to the home screen? Any ideas?

If I use my harmony remote I can navigate to the EP and choose tracks, so it's not an XBMC issue.

Also, enqueue doesn't seem to work - certainly not all the time anyway.

Still love it though.

Also, should add, I have deleted the cache in the app and redownloaded data - no help

Apologies for taking so long with the crash log from this - had guests staying with us, so had no time really... Still having the problem, seems to be only with the music library - some songs, which show up fine in XBMC, do not show up in Commander, and if you try and play the album the app crashes.

Not sure which part of the crash log is relevant, or where to send the full thing - this part below seems to be the crash as far as I can tell?

Thread 9 Crashed:
0 libsystem_kernel.dylib 0x329c2a1c 0x329b1000 + 72220
1 libsystem_c.dylib 0x30ca13b4 0x30c6e000 + 209844
2 libsystem_c.dylib 0x30c99bf8 0x30c6e000 + 179192
3 libstdc++.6.dylib 0x36f39a64 0x36ef5000 + 281188
4 libobjc.A.dylib 0x3202306c 0x3201d000 + 24684
5 libstdc++.6.dylib 0x36f37e36 0x36ef5000 + 273974
6 libstdc++.6.dylib 0x36f37e8a 0x36ef5000 + 274058
7 libstdc++.6.dylib 0x36f37f5a 0x36ef5000 + 274266
8 libobjc.A.dylib 0x32021c84 0x3201d000 + 19588
9 CoreFoundation 0x33740062 0x33737000 + 36962
10 XBMC-Commander 0x0001528e 0x1000 + 82574
11 Foundation 0x34b43382 0x34b26000 + 119682
12 Foundation 0x34bb55c6 0x34b26000 + 587206
13 libsystem_c.dylib 0x30ca130a 0x30c6e000 + 209674
14 libsystem_c.dylib 0x30ca2bb4 0x30c6e000 + 215988

Thread 9 crashed with ARM Thread State:
r0: 0x00000000 r1: 0x00000000 r2: 0x00000001 r3: 0x00000000
r4: 0x014c5000 r5: 0x00000006 r6: 0x061dd73c r7: 0x014c4b64
r8: 0x3496e778 r9: 0x00000065 r10: 0x3efbd798 r11: 0x3efc49f8
ip: 0x00000148 sp: 0x014c4b58 lr: 0x30ca13bb pc: 0x329c2a1c
cpsr: 0x00000010

Hopefully that will help?


- GraveDilute - 2011-04-26 08:18

Hi,

My problem is simple, I can only use the "remote" part of the app. I am using it on an iPad 1.
I have the Library working beautifully on my HTPC so am wondering whether I am doing something wrong? By the absolute lack of information on the XBMC commander website, I'm assuming that the app is just meant to automatically populate everything to mirror the main library?

Any tips?


- grywnn - 2011-04-26 13:55

Hi everyone.

Still on vacation, but i'm stuck in my hotel room with a twisted ankle today.
While this is no fun at all, at least i find the time to catch up with some questiones that have arisen in my absence.

I'll answer these in reverse order, and as good as i can without access to my development machine or any testing environments Smile

Quote:I have the Library working beautifully on my HTPC so am wondering whether I am doing something wrong? By the absolute lack of information on the XBMC commander website, I'm assuming that the app is just meant to automatically populate everything to mirror the main library?
Yep, these should work automatically.
I can think of a few possible causes, mostly depending on which version of xbmc you're running:
- If your running 9.11 (aka Camelot), please consider updating your XBMC installation. XBMC Commander won't work with XBMC versions < 10.0
- On the other side, if you're running svn or nightly builds, update XBMC Commander to 2.0.3. The interface i'm using for communication is currently under heavy development. And although i'm trying to keep up, you'll have to expect breakage.

@montevideo:
I'll have a look at the crash log when i'm back home next week. I think the part you posted should be sufficient.

Quote:The problem I was having with all my movie/tv/music missing because I "upgraded" to XBMC nightly builds is SORT OF fixed with the latest XBMC Commander release.
SORT OF as in all my library icons reappeared but now I can only play music. I can't get any TV shows or movies to play. I can get movie trailers to work and play through XBMC.
Thanks for the info, i'll have a look at it. That's one more loose thread after the recent JSON changes Smile

@ihjones:
Hard to debug without detailed insight to your systems / libraries.
Missing items are usually related to exotic caracter encodings that make the jSON parser choke and stop parsing. Duplicate items i haven't heard of yet though.
Please check if everything is looking fine on XBMCs web interface, to rule out any errors on the servers side.

Quote:"Enqueue Album" does not work on the iPhone version, even though the button is there in the interface.
Sounds like a bug, i'll check this when i'm back.
Advanced search options will be added at some point, it's not in the app atm because data is only stored when requested, and thus not available for offline search.

@mjreddy:
VNC support would be interesting, this actually might improve the virtual keyboard a lot. But i'll have to find a free vnc client library first, since i won't be able to do this from scratch. I'll have a look at the chickan of the vnc source code, and if it's not too complicated i might give it a try. Will still be a lot of work though, so don't raise your expectations too high Smile
upnp is similar...

All your other points will be considered.

@BruceH, considering movie set thumbnails:
I'm doing a VideoLibrary.getMovies, and take the thumbnails that i get in the response. The command looks something like this:
Code:
{"jsonrpc": "2.0", "method": "VideoLibrary.GetMovies", "id": "1"}
pre-svn should return thumbnails by default, so look for your sets in the response and see if they got a "thumbnail": item.

@greddy2000:
Resume playback is theoretically posible, but i'd have to use the old http api to gain direct access to XBMCs database for this, since this function is not exposed on XBMCs api for remote controls.
I won't go for this for now, cause the old api won't be available much longer - and i don't want to add functionality that might stop working forever with the next XBMC update (or the one after that).
I'll add a feature request for this to XBMCs tracker.

@flxfxp:
Love the "mockup", would require some basic redesigning though.
But i'll have to touch the base code again sooner or later, i'll consider things like a split view (thats what we're looking at there) or a cover flow again.

Quote:I have one problem with this app, which I wonder if other people recognize. If I select a song from my music selection and press play, the song starts immediately, but it takes a while (like a bit over a second) before I actually hear some sound. If I use the normal remote this doesn't happen. Quite weird. Also I can't stop the music using the stop button in the "remote" part.
I've heard about the stop button a few times now, i'll check this when i'm home.
The delay is new to me.
I've experienced something similar when i started using XBMC, but that was pulseaudio related back then and is long fixed in my installation. No idea atm.

Quote:When you user remote screen which displays currently playing item, when playing music I see song name but I cant see Album name.
Yep i thing i'm just displaying artist - track up there. You're right, i should add some more info.

Thats it for today folks, i'll adress the posts i've left out later.