Kodi Community Forum
[RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Video Add-ons (/forumdisplay.php?fid=154)
+---- Thread: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC (/showthread.php?tid=81052)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - jamontes - 2013-01-03 13:33

Hi,

I've found a version problem that prevents Youtube, Vimeo, and BlipTv plugins from work on systems (like Fedora releases) where the XBMC comes from a GIT version.

For instance, at my local system (Fedora 16) the XBMC release reported by the API is "11.0 Git:Unknown".
The problem is located at the funtion getXBMCVersion() of "CommonFunctions.py" file of the script.module.parsedom module, which is used by the three above plugins.

So whenever I launch any of the three plugins mentioned, getXBMCVersion() cannot converts the string reported by the API to a float value (expected by getParameters() to know which version of XBMC is working with), and the whole plugin chrash.

I've collected the whole xbmc.log with the Vimeo plugin runing in debug mode so you can see the problem ( http://pastebin.com/TKAze6ya ). I've tested on Fedora 16 and Fedora 17 and found the same problem. However, I've tested on my Openelec (Eden flavour) Raspberry Pi and everything works fine (as the API reports "11.0", which can be converted to float to make the release comparison ).

In order to fix the problem, I've did a quick patch to get only the digits part from the string reported by the API at the getXBMCVersion() function of the script.module.parsedom module. This is the original fragment of code:

def getXBMCVersion():
>>>>log("", 3)
>>>>version = xbmc.getInfoLabel( "System.BuildVersion" )
>>>>log(version, 3)
>>>>if version.find("-") -1:
>>>>>>>>version = version[:version.find("-")]
>>>>version = float(version)
>>>>log(repr(version))
>>>>return version

And this is the (dirty and quick) patched version:
def getXBMCVersion():
>>>>log("", 3)
>>>>version = xbmc.getInfoLabel( "System.BuildVersion" )
>>>>log(version, 3)
>>>>#jamontes modified this:
>>>>version_pat = re.compile('^[0-9.]+')
>>>>version_num = version_pat.findall(version)[0]
>>>>#if version.find("-") -1:
>>>>>>>>#version = version[:version.find("-") -1]
>>>>version = float(version_num)
>>>>log(repr(version))
>>>>return version

I'm sorry for the dirty patch, as I'm new to python and XBMC plugins world. I hope you would fix it in a more ellegant way due to my lack of knowledge on python.

Many thanks in advance for all The Collective have done and kind regards,
jamontes


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - chtamina - 2013-02-20 00:48

Is it possible to toggle view status for the watched videos?


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - oavaldezi - 2013-03-28 07:03

Can't login with Vimeo plugin version 3.5.1 on XBMC 12.1 (OpenELEC 3.0.0 on a Raspberry Pi). Here's the debug log:

20:31:47 T:2942854240 NOTICE: [Vimeo-3.5.1] executeAction : '{'action': 'settings', 'path': '/root/login'}'
20:31:47 T:2942854240 NOTICE: [Vimeo-3.5.1] login : ''
20:31:55 T:2942854240 NOTICE: [Vimeo-3.5.1] _login : ''
20:31:56 T:2942854240 NOTICE: [Vimeo-3.5.1] login_get_verifier : 'login_get_verifier - auth_url: http://vimeo.com/oauth/authorize?oauth_token=3d98aeec037a456b2198ab2a4ea7c2eb&permission=write'
20:31:56 T:2942854240 NOTICE: [Vimeo-3.5.1] extractCrossSiteScriptingToken : ''
20:31:56 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'called for : {'link': 'http://vimeo.com/log_in'}'
20:31:56 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'Got request'
20:31:56 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'connecting to server...'
20:31:57 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'Done'
20:31:58 T:2942854240 NOTICE: [Vimeo-3.5.1] ExtractVersion6CrossSiteScriptingToken : ''
20:31:58 T:2942854240 NOTICE: [Vimeo-3.5.1] extractCrossSiteScriptingToken : 'Done: [u'1fd56914f93f4c9c797e1ea210c9951d']'
20:31:58 T:2942854240 NOTICE: [Vimeo-3.5.1] performHttpLogin : ''
20:31:58 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'called for : 'http://vimeo.com/log_in''
20:31:58 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'Posting data: action=login&token=1fd56914f93f4c9c797e1ea210c9951d&password=***my password goes here***&email=***my email goes here***&service=vimeo'
20:31:58 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'connecting to server...'
20:31:59 T:2942854240 NOTICE: [Vimeo-3.5.1] fetchPage : 'Done'
20:31:59 T:2942854240 NOTICE: [Vimeo-3.5.1] performHttpLogin : 'Done'
20:31:59 T:2942854240 NOTICE: [Vimeo-3.5.1] checkIfHttpLoginFailed : ''
20:31:59 T:2942854240 NOTICE: [Vimeo-3.5.1] checkIfHttpLoginFailed : 'Done'
20:31:59 T:2942854240 NOTICE: [Vimeo-3.5.1] login_get_verifier : 'login_get_verifier sanity check failed, bad username or password?'
20:31:59 T:2942854240 NOTICE: [Vimeo-3.5.1] login : 'Done'
20:31:59 T:3042865152 ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/?action=settings&path=%2froot%2flogin
20:31:59 T:3042865152 ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/?action=settings&path=%2froot%2flogin) failed
20:31:59 T:2942854240 NOTICE: Thread Background Loader start, auto delete: false
20:32:56 T:2866066528 NOTICE: ES: Client from 192.168.0.19 timed out
20:45:36 T:2916398176 NOTICE: Thread Jobworker start, auto delete: true
20:45:36 T:2849289312 NOTICE: Thread Background Loader start, auto delete: false
20:46:25 T:2849289312 NOTICE: Previous line repeats 6 times.
20:46:25 T:2849289312 NOTICE: Thread XBPyThread start, auto delete: false


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - carlinux - 2013-04-07 03:49

Same error message here..
Huh


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - sthomas13 - 2013-05-13 20:05

is this addon working for anyone? I can't search or browse for videos at all.


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - oavaldezi - 2013-05-13 21:11

I can search and browse, but I can't log in, so I can't access my playlists.

The plugin's page on XBMC's wiki (http://wiki.xbmc.org/index.php?title=Add-on:Vimeo) points to this support forum, but It seems like the developer(s) aren't reading what gets posted here.


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - OlliLaukkanen - 2013-05-28 23:11

Is anybody here who can help fixing the login issue?


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - matiasw - 2013-05-29 22:08

(2013-05-28 23:11)OlliLaukkanen Wrote:  Is anybody here who can help fixing the login issue?

Yes, have a look here: http://code.google.com/p/vimeoxbmc/issues/detail?id=12


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - OlliLaukkanen - 2013-05-31 17:19

Works like a charm. This should be changed in the official addon repo..


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - oavaldezi - 2013-06-02 22:09

For those unwillling or unable to apply the patch referenced in post #233 above, the files VimeoLogin.py and VimeoLogin.pyo can be edited manually, substituting "http://vimeo.com/log_in" for "https://vimeo.com/log_in".


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - carbuncle - 2013-09-04 11:41

I am experiencing some strange behaviour with the add on. I'm using frodo and this add on isn't functional at all.

Whatever option I pick (categories, HD videos, search) it says "No results!"

I know there's some issues with this add on, particularly " The plugin uses Vimeo Oauth API, and thus requires a synchronized system clock on the machine running XBMC. All communication with Vimeo will fail if the system has a time drift of even a few minuts. "

Is that the reason why I get no results?

Also here's a log:

Code:
10:59:18 T:2744075328  NOTICE: Vimeo-3.5.2 ARGV: ['plugin://plugin.video.vimeo/', '1', '']
10:59:20 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Vimeo'
10:59:22 T:2744075328  NOTICE: CommonFunctions-2.5.1
10:59:22 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : ''
10:59:22 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Downloader'
10:59:22 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : 'Done'
10:59:23 T:2727298112  NOTICE: Thread Background Loader start, auto delete: false
10:59:29 T:2744075328  NOTICE: Thread XBPyThread start, auto delete: false
10:59:29 T:2744075328  NOTICE: -->Python Interpreter Initialized<--
10:59:31 T:2744075328  NOTICE: Vimeo-3.5.2 ARGV: ['plugin://plugin.video.vimeo/', '2', '?login=false&path=%2froot%2fexplore']
10:59:32 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Vimeo'
10:59:34 T:2744075328  NOTICE: CommonFunctions-2.5.1
10:59:34 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : ''
10:59:34 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Downloader'
10:59:34 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : 'Done'
10:59:35 T:2744075328  NOTICE: [Vimeo-3.5.2] getXBMCVersion : '12.2'
10:59:35 T:2727298112  NOTICE: Thread Background Loader start, auto delete: false
10:59:38 T:2744075328  NOTICE: Thread XBPyThread start, auto delete: false
10:59:38 T:2744075328  NOTICE: -->Python Interpreter Initialized<--
10:59:40 T:2744075328  NOTICE: Vimeo-3.5.2 ARGV: ['plugin://plugin.video.vimeo/', '3', '?api=groups&folder=category&login=false&path=%2froot%2fexplore%2fgroups']
10:59:41 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Vimeo'
10:59:42 T:2744075328  NOTICE: CommonFunctions-2.5.1
10:59:43 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : ''
10:59:43 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Downloader'
10:59:43 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : 'Done'
10:59:44 T:2744075328  NOTICE: [Vimeo-3.5.2] getXBMCVersion : '12.2'
10:59:44 T:2744075328  NOTICE: [Vimeo-3.5.2] list : ''
10:59:45 T:2744075328  NOTICE: Previous line repeats 2 times.
10:59:45 T:2744075328  NOTICE: [Vimeo-3.5.2] _get_categories : ''
10:59:45 T:2744075328  NOTICE: [Vimeo-3.5.2] _get_categories : 'Done'
10:59:45 T:2744075328  NOTICE: [Vimeo-3.5.2] list : 'Done'
10:59:46 T:3041230848   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/?api=groups&folder=category&login=false&path=%2froot%2fexplore%2fgroups
10:59:46 T:3041230848   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/?api=groups&folder=category&login=false&path=%2froot%2fexplore%2fgroups) failed
10:59:46 T:2744075328  NOTICE: Thread Background Loader start, auto delete: false
10:59:49 T:2744075328  NOTICE: Thread XBPyThread start, auto delete: false
10:59:49 T:2744075328  NOTICE: -->Python Interpreter Initialized<--
10:59:51 T:2744075328  NOTICE: Vimeo-3.5.2 ARGV: ['plugin://plugin.video.vimeo/', '4', '?channel=staffpicks&login=false&path=%2froot%2fexplore%2fstaffpicks']
10:59:53 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Vimeo'
10:59:54 T:2744075328  NOTICE: CommonFunctions-2.5.1
10:59:54 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : ''
10:59:54 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Downloader'
10:59:54 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : 'Done'
10:59:55 T:2744075328  NOTICE: [Vimeo-3.5.2] getXBMCVersion : '12.2'
10:59:55 T:2744075328  NOTICE: [Vimeo-3.5.2] list : ''
10:59:56 T:2744075328  NOTICE: Previous line repeats 2 times.
10:59:56 T:2744075328  NOTICE: [Vimeo-3.5.2] _getvideoinfo : ''
10:59:57 T:2744075328  NOTICE: [Vimeo-3.5.2] _getvideoinfo : 'Done'
10:59:57 T:2744075328  NOTICE: [Vimeo-3.5.2] list : 'Done'
10:59:57 T:3041230848   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/?channel=staffpicks&login=false&path=%2froot%2fexplore%2fstaffpicks
10:59:57 T:3041230848   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/?channel=staffpicks&login=false&path=%2froot%2fexplore%2fstaffpicks) failed
10:59:58 T:2744075328  NOTICE: Thread Background Loader start, auto delete: false
11:00:00 T:2744075328  NOTICE: Thread XBPyThread start, auto delete: false
11:00:00 T:2744075328  NOTICE: -->Python Interpreter Initialized<--
11:00:02 T:2744075328  NOTICE: Vimeo-3.5.2 ARGV: ['plugin://plugin.video.vimeo/', '5', '?channel=hd&login=false&path=%2froot%2fexplore%2fhd']
11:00:03 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Vimeo'
11:00:05 T:2744075328  NOTICE: CommonFunctions-2.5.1
11:00:05 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : ''
11:00:05 T:2744075328  NOTICE: [StorageClient-2.5.2] '__init__' : 'Setting table to : Downloader'
11:00:05 T:2744075328  NOTICE: [Vimeo-3.5.2] __init__ : 'Done'
11:00:06 T:2744075328  NOTICE: [Vimeo-3.5.2] getXBMCVersion : '12.2'
11:00:06 T:2744075328  NOTICE: [Vimeo-3.5.2] list : ''
11:00:07 T:2744075328  NOTICE: Previous line repeats 2 times.
11:00:07 T:2744075328  NOTICE: [Vimeo-3.5.2] _getvideoinfo : ''
11:00:07 T:2744075328  NOTICE: [Vimeo-3.5.2] _getvideoinfo : 'Done'
11:00:07 T:2744075328  NOTICE: [Vimeo-3.5.2] list : 'Done'
11:00:08 T:3041230848   ERROR: GetDirectory - Error getting plugin://plugin.video.vimeo/?channel=hd&login=false&path=%2froot%2fexplore%2fhd
11:00:08 T:3041230848   ERROR: CGUIMediaWindow::GetDirectory(plugin://plugin.video.vimeo/?channel=hd&login=false&path=%2froot%2fexplore%2fhd) failed
11:00:08 T:2744075328  NOTICE: Thread Background Loader start, auto delete: false
11:00:11 T:2744075328  NOTICE: Thread XBPyThread start, auto delete: false
11:00:12 T:2744075328  NOTICE: Previous line repeats 1 times.
11:00:12 T:2744075328  NOTICE: -->Python Interpreter Initialized<--
11:00:12 T:2727298112  NOTICE: -->Python Interpreter Initialized<--
11:00:26 T:2735686720  NOTICE: Thread Background Loader start, auto delete: false
11:00:29 T:2744075328  NOTICE: Previous line repeats 2 times.
11:00:29 T:2744075328  NOTICE: Thread Jobworker start, auto delete: true
11:00:33 T:2735686720  NOTICE: Previous line repeats 1 times.
11:00:33 T:2735686720  NOTICE: Thread XBPyThread start, auto delete: false
11:00:33 T:2735686720  NOTICE: -->Python Interpreter Initialized<--
11:01:03 T:2777674816  NOTICE: Thread Jobworker start, auto delete: true
11:01:04 T:2857366592  NOTICE: Thread XBPyThread start, auto delete: false
11:01:04 T:2857366592  NOTICE: -->Python Interpreter Initialized<--
11:03:09 T:2735686720  NOTICE: XBMC Log Uploader: started
11:03:09 T:2735686720  NOTICE: XBMC Log Uploader: settings: len(email)=26
11:03:09 T:2735686720  NOTICE: XBMC Log Uploader: settings: skip_oldlog=True
11:03:15 T:2735686720  NOTICE: XBMC Log Uploader: reading log...



RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - Mojonba - 2013-09-07 18:12

Not working here either. It shows no results everywhere.


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - MattH7 - 2013-10-14 14:42

(2013-09-07 18:12)Mojonba Wrote:  Not working here either. It shows no results everywhere.
Definitely broken with Frodo. Doesn't work with mint 15 or Fedora 19, so not OS specific. Explore Vimeo always comes up with no results on all options. Please mark add on broken in repo, until fixed as this add on is useless to normal XBMC users and hasn't been working for months.


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - PantsOnFire - 2013-10-23 22:06

MattH7, remember that the fact it's not working for you doesn't mean it's dead for everyone.
I for one use Win7, Frodo 12.0 XBMC final and I was using Vimeo successfully for the last few days in a row.

However today I found a problem. I am not getting the 'no results' error, but I am getting:
"Error! Script failed!: plugin.video.vimeo"

Debug log here:

http://pastebin.com/735xwNKe


RE: [RELEASE] Vimeo (Video) Plugin - De facto default standard Vimeo Addon for XBMC - ruuk - 2013-10-25 23:30

I mucked around and got my Vimeo to work.

Replace this in your ~/.xbmc/addons/plugin.video.vimeo folder (right click, save as)

http://xbmc.2ndmind.com/VimeoPlayer.py

I can't guarantee this is stable, won't cause errors, will last long, etc... I just messily jammed in some code.
If it breaks again, don't ask me for a fix, as I am not the maintainer of this addon. I'm just posting this in the hopes that it will be useful.