Kodi Community Forum
[Release] Forum Browser - Programs Addon - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (/forumdisplay.php?fid=151)
+---- Thread: [Release] Forum Browser - Programs Addon (/showthread.php?tid=85018)



RE: [RELEASE] Forum Browser - Programs Addon - hasselhof - 2013-02-28 20:25

Hi ruuk, while uninstalling FB I got a script error message saying error service.py see log

Web viewer update auto downloaded ok.

Did a complete fresh install of FB v1.3.0 on windows xp, confluence but the pictures in my FB thread at the hub still don't show maybe something in the log may help. They work on my linux box (but that's not a fresh install)

Here is a link to my liked posts at the hub

The 403 error in web viewer is now fixed for me thanks.

The pictures from Benja1min are also broke in my web browser (chrome) & on my phone there broken also, but they work in FB.

Thanks for the updates.


Re: [RELEASE] Forum Browser - Programs Addon - ruuk - 2013-03-01 00:34

Hasselhof: The like counts are for the post, not the user.


RE: [RELEASE] Forum Browser - Programs Addon - hasselhof - 2013-03-01 01:00

(2013-03-01 00:34)ruuk Wrote:  Hasselhof: The like counts are for the post, not the user.


oh ok thats fine then Smile


RE: [RELEASE] Forum Browser - Programs Addon - hasselhof - 2013-03-01 17:26

Hi ruuk,


just found this, maybe you have already seen it ?. Number 14 was me Big Grin
Did you know they have FB in there super repo ?


RE: [RELEASE] Forum Browser - Programs Addon - ruuk - 2013-03-01 17:32

(2013-03-01 17:26)hasselhof Wrote:  Hi ruuk,


just found this, maybe you have already seen it ?. Number 14 was me Big Grin
Did you know they have FB in there super repo ?

Didn't know the site existed Smile


v1.3.1 - ruuk - 2013-03-01 20:38

Version 1.3.1

Changes:

- Tapatalk: Added check for 'current_action' (API 4) in addition to current check for 'current_activity' (API 3)
- When changing logo in forum settings, now asks if you want to edit the URL instead of browse site images
- When logo is changed in forum settings, the old cached logo is now deleted
- Added search posts option to forums window context menu
- ParserBrowser: Handle more URL formats and fixes for parsing posts on some forums
- Added wrench icon tab to Forums Manager to help indicate that forum settings are to the right

On my REPO.

Added searching posts. Still need to add a way to jump to the posts thread. I'll probably add a search button to the main window in the near future.

hasselhof: Well, you've been asking for it forever - here's a start on it Smile


RE: v1.3.1 - hasselhof - 2013-03-03 19:39

(2013-03-01 20:38)ruuk Wrote:  Version 1.3.1

Changes:

- Tapatalk: Added check for 'current_action' (API 4) in addition to current check for 'current_activity' (API 3)
- When changing logo in forum settings, now asks if you want to edit the URL instead of browse site images
- When logo is changed in forum settings, the old cached logo is now deleted
- Added search posts option to forums window context menu
- ParserBrowser: Handle more URL formats and fixes for parsing posts on some forums
- Added wrench icon tab to Forums Manager to help indicate that forum settings are to the right

On my REPO.

Added searching posts. Still need to add a way to jump to the posts thread. I'll probably add a search button to the main window in the near future.

hasselhof: Well, you've been asking for it forever - here's a start on it Smile

Hi ruuk

Thanks for the update, have had a very quick test of the search facility working really well.
Will give further feedback when I get five minutes, as I've been the family IT man all weekend Frown


v1.3.2 - ruuk - 2013-03-04 21:55

Version 1.3.2

Changes:

- Posts window with search results now shows 'New Search' button
- Added threads searching
- Added 'Search' button to main window which when clicked shows 'Search Posts' and 'Search Threads' buttons, and removed the search posts option from the forums window context menu
- Added option to 'General' settings: 'Searching Posts: Open Thread On Post Click' - When searching posts and selecting a post, causes the thread to be opened and then the post selected to be displayed, instead of just showing the post content
- Added help for setting 'Searching Posts: Open Thread On Post Click'
- Fix for decoding errors on some messages when displaying a signature

On my REPO.

I'm thinking of changing the button order to: Forums, Subscriptions, Messages, Search, Settings.

Any thoughts?


v1.3.3 - ruuk - 2013-03-05 23:47

Version 1.3.3

Changes:

- Added forums context menu item 'Search <FORUMNAME>' for searching within a single forum
- Added threads/subscriptions context menu item 'Search <THREAD/FORUMNAME>' for searching within a single thread/forum
- When searching posts, post title area now shows the thread topic
- Added 'Search User Posts' button in 'Search' button menu which allows you to enter a user name and search that users posts
- Added 'Search In Posts Of <USER>' in online users list context menu
- Improved display of posts by creating items first and then adding them to the list all at once
- Fix for some post encoding errors
- Fix improvement for 'Forbidden' errors issue that doesn't cause any extra delays

On my REPO.


v1.3.4 - ruuk - 2013-03-07 05:37

Version 1.3.4

Changes:

- Improved progress contrast on forums window with dark header backgrounds
- ParserBrowser: IPBoard: Improved thread parsing and improved post parsing (especially for single post threads)
- Moved video functions to WebViewer and changed WebViewer requirement to 0.9.6
- Added ShareSocial as an optional import in addon.xml

On my REPO.

I was originally thinking of adding youtube and vimeo as optional imports, but since XBMC will ask you to import when you try to play video through those plugins, I think I'll leave it as is. That way people will only be importing them if they actually use them (not to mention youtube is there by default for just about everyone anyway).

FYI: WebViewer now plays Video like FB does.


RE: [RELEASE] Forum Browser - Programs Addon - ruuk - 2013-03-07 08:29


  1. Item 1
  2. Item 2
  3. Item 3

  • One
  • Two
  • Three
  • Four



Re: [RELEASE] Forum Browser - Programs Addon - hasselhof - 2013-03-07 20:17

Hi ruuk nice to see your still at it Big Grin
Hopefully check out some of your updates Friday.


RE: [RELEASE] Forum Browser - Programs Addon - ruuk - 2013-03-07 20:18

(2013-03-07 20:17)hasselhof Wrote:  Hi ruuk nice to see your still at it Big Grin
Hopefully check out some of your updates Friday.

Smile


RE: [RELEASE] Forum Browser - Programs Addon - ruuk - 2013-03-07 22:48

I introduced a new bug in the notifier. I'll post an update later when I can.
I'll have a fix for the keyboard mod issues as well. It actually involves replacing the XBMC skin keyboard because I could find no other way. I'll therefore have choices for the keyboard skin. There'll be a generic keyboard, and ones that match other skins. I've already done Confluence, and I'll probably add Transparency as well. I'll be matching the font size for readability and just making the edit box larger.


RE: [RELEASE] Forum Browser - Programs Addon - hasselhof - 2013-03-08 19:47

Hi ruuk,

did dome more testing, using xbmcbuntu, Confluence, FB v1.3.4

My Tapatalk activity is still showing me viewing my profile all the time.

Good idea to be able to browse to a url when changing logo's. I like the way you present the current logo's address in the keyboard when changing logo. The url based changing of logo's is working really well, the one I did worked great and is a much better logo than the auto scraped offerings. On a side note after typing in the url for the logo, then pressing done on the onscreen keyboard, the forums list is not getting refreshed with the new logo, you have to go out of the forum list and back in again to see the new logo.

Can confirm the cached logo's are being deleted ok.

The forums settings window where you choose the colour, logo & description is working great.

The wrench icon is a nice icon and does what you are aiming for, but it could do with a better colour background than grey as it tends to blend in too much, maybe a red background.

Search threads option from forums window context is working really well, I like how the search terms are in red & the partial matches are in yellow.

Good call on the "New search" buttons focus, ie when you do a quick repeat search the time restriction window appears, the "New search" button is still focused for you to try again after the time limit expires, & what I really like is the search terms are still typed in ready to go.Cool

Thread searching is working great.

If using the "Search posts" from the button on main screen, you are presented with a list of results, if you go into any post, then come back out again the post title thread topic says "none" but before it said the title, not sure if this is the desired effect you were after ?.


when turning on "Searching posts: open thread on post click" in settings this stops the posts from being able to be displayed full screen when selecting the posts. ie with "Searching posts: open thread on post click" switched "off" you get a list of individual posts relating to your search term, click on one and it goes fullscreen. If you have "Searching posts: open thread on post click" switched "on" then the posts won't go fullscreen. I actually prefer the context menu entry of "open post thread" the context menu option works nicely.

help for "Searching posts: open thread on post click" is fine.

Swapping over the settings button with the forums button on main page makes great sense for the everyday user, thanks for asking first Big Grin

Searching user posts button is another function I use regularly in a browser, but once you've typed the name of the user could you just browse the users post with the latest one first, instead of typing in a search term as well, or is this an xbmc.org limitation ?.

The forums window is looking top notch I really like it.

Web viewer pulled version 0.9.6 ok

How do I instigate a Share social import ( I've done a fresh install, got rid of all old settings folders etc etc.) tried for 10 mins but couldn't get it to activate.?

Now you've implemented a comprehensive search system, could I ask for a saved search list somehow like in your google images add-on, or what I would find useful is that the last typed entry into the keyboard appears the next time you pull the keyboard to the screen,(just trying to save typing with the remote) what do you think ?

I really like the direction your taking this project in, you look like your devoting a lot of spare time to it & it really shows.
I will continue to test it till it breaks over the coming days. Ignore any of the findings if they relate to any problems that you already know about & have mentioned already.

Over & out, awaiting your next release Wink