Kodi Community Forum
[RELEASE] Missing Movie Plugin - Find Movies and TV Shows that are not in the library - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (/forumdisplay.php?fid=151)
+---- Thread: [RELEASE] Missing Movie Plugin - Find Movies and TV Shows that are not in the library (/showthread.php?tid=90258)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22


- devkid - 2012-03-05 16:28

Does anyone know what exactly is the problem with SMB shares? Where is XBMC technically limited so that SMB shares are not working for this addon?
I might want to take a look into it once I know whats the problem.
Thanks!


- Popeye - 2012-03-05 21:47

devkid Wrote:Does anyone know what exactly is the problem with SMB shares? Where is XBMC technically limited so that SMB shares are not working for this addon?
I might want to take a look into it once I know whats the problem.
Thanks!

Python can't access smb shares. Something like os.path.exists(smb_path) will fail since python doesnt know how to handle smb:// ..


- Sentir101 - 2012-03-06 14:02

PatK Wrote:Interesting.... Sentir101's version pops up a script error and would seem to choke, but I'm presented with a list of things not in my library.. successive attempts failed to produce an onscreen list, but did produce a file in my document prescribed area.
Could you please generate a debug log of you trying to access the addon and the missing lists? (both TV Shows and Movies if you can) You can put it up here.

PatK Wrote:By putting the .txt extension to it, I was then able to open it with notepad.
steeve23 Wrote:Can select Movies or TV shows, it showed up a list of the files missing and produced a output file where I had asked it to, as PatK mentions it needs a .txt extension, but that can be added on the filename in the settings instead of when it has been generated.
Yeah I did that so people could decide what extension to use, it only saves in plain text so you will always be able to read it anyway, the extension is unimportant.

douggoodwin Wrote:Just installed 2.0.17
Not working for me. I clicked "Unadded Movies" it starts Loading, then stops.
Could you please also generate a debug log?

When I have the time I'll check if I can fix it, but I'm usually pretty busy with my study so it could take some time.


- PatK - 2012-03-06 17:12

I've edited out some of the movie and TV listings, but should contain the relevant script errors, for both Movies and TV shows http://pastebin.com/pniGAKPk A list of missing videos does show up in my document folder and appears correct.

Minor irritant... as visualized here is not found in the library and is listed, but in fact is in the library under this name.

http://imageshack.us/photo/my-images/140/imagetsd.jpg/

Wondering if renaming in lwould eliminate this issue?


- Sentir101 - 2012-03-06 21:22

PatK Wrote:I've edited out some of the movie and TV listings, but should contain the relevant script errors, for both Movies and TV shows http://pastebin.com/pniGAKPk A list of missing videos does show up in my document folder and appears correct.

Minor irritant... as visualized here is not found in the library and is listed, but in fact is in the library under this name.

http://imageshack.us/photo/my-images/140/imagetsd.jpg/

Wondering if renaming in lwould eliminate this issue?

Whoops, this seems to be a little mistake on my part, I didn't test after I added the newline after every missing file in the logger. This screwed it over. I also noticed from your Debug Log that it wasn't handling multipath sources correctly, I hopefully fixed that by unescaping the path. Your issue in the image was a consequence of me using unicode conversions in the wrong place, this should be fixed too (the ' is causing problems here, so if you had removed that it would probably have worked). I'll put in a debug option in the add-on settings so that I won't have to get through all the crap that is logged when XBMC is in debug mode and then I'll upload the new version.


- Sentir101 - 2012-03-06 22:04

Here is Missing Movie Viewer 2.0.18:

Changes:
  • Fix Unicode
  • Handle multi-path sources better
  • Added a debug option in the add-on settings

The truncated file path may also be fixed (it's not reproducible anymore on my end).

Download


- devkid - 2012-03-07 00:09

If someone is interested, I did some fixes to make it work on my OpenELEC system. Most importantly I added SMB support. Stumbled upon lots of other issues. I know there are still issues left that do not get handled correctly.
This is based upon version 2.0.17 IIRC.
  • SMB support
  • support for stacked view
  • fixed some unicode issues
  • fixed some linux issues

Download


- PatK - 2012-03-07 00:10

Missing Movie Viewer 2.0.18 Gives me similar results...

key items seem to be: http://pastebin.com/buE7gCWm

Menu selection 'Movie' or 'TV Shows' give identical results as a text file in the path specified. If you need more on the paste bin let me know. The log is 7 megs


- mrfatboy - 2012-03-07 00:28

Quote:If someone is interested, I did some fixes to make it work on my OpenELEC system. Most importantly I added SMB support. Stumbled upon lots of other issues. I know there are still issues left that do not get handled correctly.
This is based upon version 2.0.17 IIRC.
SMB support
support for stacked view
fixed some unicode issues
fixed some linux issues

Download





Never mind! It does work. Great job. I forgot my movies are .m4v and not .mp4. I had to add a custom extension in the add on.

thanks!


- Sentir101 - 2012-03-07 01:20

PatK Wrote:Missing Movie Viewer 2.0.18 Gives me similar results...

key items seem to be: http://pastebin.com/buE7gCWm

Menu selection 'Movie' or 'TV Shows' give identical results as a text file in the path specified. If you need more on the paste bin let me know. The log is 7 megs

Okay, this should fix it.

Changes:
  • Fix output to file
  • Changed some strings
  • Use localized strings

I only made it use the localized strings to find out how this works, but if anyone wants they can translate the strings in strings.xml, send them to me and I'll include them in the release.

Download


Many thanks for this useful plug-in. - PatK - 2012-03-07 21:15

Success.. works like a champ now, both TV and Movies output to the screen on completion (a little concerned when the requester stood for a bit of time before reporting) their respective info. Nod

Win/7/64 running T! SVN Eden RC2


- ferent - 2012-03-07 21:54

It didn't works for me, I'm using Linux. Here you have a screenshot with the results:

[Image: instantnea4.jpg]


- Sentir101 - 2012-03-07 22:37

ferent Wrote:It didn't works for me, I'm using Linux. Here you have a screenshot with the results:

...

It's probably because you are on Linux, I don't have a setup where I can easily debug this so I don't know how fast I'll be able to fix it. Please turn on the debug setting of the add-on (the switch in the add-on settings) and access the Missing Movies and Missing Episodes items. Then upload the log here. What are these ".directory" files/directories for by the way?


- devkid - 2012-03-07 23:42

ferent Wrote:It didn't works for me, I'm using Linux. Here you have a screenshot with the results:
You could try with the version I posted on the previous page. It still has some issues but for me it runs on Windows and on Linux. Maybe you are lucky too.
It also fixes some issues and adds SMB support and support for stacked view.


- Sentir101 - 2012-03-08 11:03

devkid Wrote:You could try with the version I posted on the previous page. It still has some issues but for me it runs on Windows and on Linux. Maybe you are lucky too.
It also fixes some issues and adds SMB support and support for stacked view.

Weird, I hadn't noticed that post... *facepalm*, if you're OK with it I could merge your changes into my code (or you can do it and send a pull request to me or the OP on Github)