Kodi Community Forum
[RELEASE] Weather Plus Addon - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Weather Add-ons (/forumdisplay.php?fid=155)
+---- Thread: [RELEASE] Weather Plus Addon (/showthread.php?tid=95329)



Polish Translation of Weather.com Plus - superbaton - 2011-05-27 23:14

Hi,

In the link below you can find the file with polish translation of Weather.com Plus main menuSmile

http://www.mediafire.com/?c623s4blcdexnrc

brightsr can you add it to the Weather.com Plus?

Smile


- dallasnights - 2011-05-28 00:22

couple of really dumb questions,
1) Where can I download the latest version can you post a link
2) Where do I install is this correct /Applications/XBMC.frappliance/XBMCData/XBMCHome/addons/skin.confluence and just over write the stuff there

Thanks all


- brightsr - 2011-05-28 00:29

@superbaton

That should be put into skin's language xml folder.
If a skin has no polish langauge xml, you can't select polish in XBMC's settings and addon's polish xml is useless.

But you can translate text of addon's settings with the linked file below.
If you do it and post here, I'll thank you and update. Smile


- brightsr - 2011-05-28 00:31

dallasnights Wrote:1) Where can I download the latest version can you post a link

You can download from this repo. : http://xbmc-addons.googlecode.com/svn/packages/repository.googlecode.xbmc-addons.zip


- dallasnights - 2011-05-28 00:32

wow thanks for the fast response great support!


- jtucker1972 - 2011-05-28 03:42

I am getting the following error with the latest version 2.1.4. I made sure I updated the Confluence skin to the latest version.

21:39:02 T:3592 M:2299797504 ERROR: Traceback (most recent call last):
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\default.py", line 41, in ?
Main()
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\xbmcplugin_weathe​r.py", line 76, in __init__
self._accu_hourly_forecast()
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\xbmcplugin_weathe​r.py", line 535, in _accu_hourly_forecast
forecasts = self.WeatherClient.accu_fetch_hourly_forecast()
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\WeatherClient.py", line 2129, in accu_fetch_hourly_forecast
htmlSource = self._fetch_data( self.BASE_ACCU_FORECAST_URL % ( self.code, "hourly"+date[1] ), 1 )
IndexError: list index out of range
21:39:02 T:3592 M:2299797504 INFO: -->End of Python script error report<--


- brightsr - 2011-05-28 04:55

jtucker1972 Wrote:I am getting the following error with the latest version 2.1.4. I made sure I updated the Confluence skin to the latest version.

21:39:02 T:3592 M:2299797504 ERROR: Traceback (most recent call last):
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\default.py", line 41, in ?
Main()
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\xbmcplugin_weathe​r.py", line 76, in __init__
self._accu_hourly_forecast()
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\xbmcplugin_weathe​r.py", line 535, in _accu_hourly_forecast
forecasts = self.WeatherClient.accu_fetch_hourly_forecast()
File "C:\Users\James\AppData\Roaming\XBMC\addons\weather.weatherplus\WeatherClient.py", line 2129, in accu_fetch_hourly_forecast
htmlSource = self._fetch_data( self.BASE_ACCU_FORECAST_URL % ( self.code, "hourly"+date[1] ), 1 )
IndexError: list index out of range
21:39:02 T:3592 M:2299797504 INFO: -->End of Python script error report<--

Please let me know the area code you can find in the log file, and your selected language for accuweather.com


- brightsr - 2011-05-28 05:12

[UPDATE] v.2.1.5

- Fixed : NOAA 6 day forecast bugs


- Jezz_X - 2011-05-28 06:14

New 2.1.5 version doesn't work on eden xbmc old one worked fine (by old I mean pre other services because thats what I had installed)
Quote:14:13:34 T:16852 M:1539842048 ERROR: Error Type: <type 'exceptions.SyntaxError'>
14:13:34 T:16852 M:1539842048 ERROR: Error Contents: ("Non-ASCII character '\\xec' in file D:\\XBMC Dev\\XBMC_New\\portable_data\\addons\\weather.weatherplus\\WeatherClient.py on line 825, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details", ('D:\\XBMC Dev\\XBMC_New\\portable_data\\addons\\weather.weatherplus\\WeatherClient.py', 825, 0, None))
14:13:34 T:16852 M:1539739648 ERROR: Traceback (most recent call last):
File "D:\XBMC Dev\XBMC_New\portable_data\addons\weather.weatherplus\default.py", line 40, in <module>
from xbmcplugin_weather import Main
File "D:\XBMC Dev\XBMC_New\portable_data\addons\weather.weatherplus\xbmcplugin_weather.py", line 18, in <module>
import WeatherClient as WeatherClient
SyntaxError: ("Non-ASCII character '\\xec' in file D:\\XBMC Dev\\XBMC_New\\portable_data\\addons\\weather.weatherplus\\WeatherClient.py on line 825, but no encoding declared; see http://www.python.org/peps/pep-0263.html for details", ('D:\\XBMC Dev\\XBMC_New\\portable_data\\addons\\weather.weatherplus\\WeatherClient.py', 825, 0, None))



- brightsr - 2011-05-28 06:20

Jezz_X Wrote:New version doesn't work on eden xbmc old one worked fine 2.1.5

I fixed it. Can you reinstall 2.1.5 and test it?


- Jezz_X - 2011-05-28 06:28

Nope still fails I also get a bunch of errors in the log while installing it
http://www.pastie.org/1983541


- brightsr - 2011-05-28 06:41

Jezz_X Wrote:Nope still fails I also get a bunch of errors in the log while installing it
http://www.pastie.org/1983541

I don't know why errors occur during install and i got them, too.
Anyway, I tried to reinstall it and it's working well on Dharma.
I don't have Eden, so I'm going to get one to test.


- Jezz_X - 2011-05-28 06:50

Right guess I'll have to go back to the version of the addon that did work then and not add it to confluence git for a while then. I can't really add it to eden git if it fails to work Sad


- brightsr - 2011-05-28 07:14

@Jezz_X

I fixed it again. Actually, I didn't know about eden.
I added encoding information that seems to be mandatory for eden, and it's working now.
Please reinstall and try to test.


- Jezz_X - 2011-05-28 07:28

brightsr Wrote:@Jezz_X

I fixed it again. Actually, I didn't know about eden.
I added encoding information that seems to be mandatory for eden, and it's working now.
Please reinstall and try to test.

yeah works now and its probably because eden uses a newer version of python than the old inbuilt 2.4 windows is on 2.6 I think so maybe thier rules changed