Kodi Community Forum
[RELEASE] Pneumatic - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Add-ons Help and Support (/forumdisplay.php?fid=27)
+---- Forum: Program Add-ons (/forumdisplay.php?fid=151)
+---- Thread: [RELEASE] Pneumatic (/showthread.php?tid=97657)



RE: [RELEASE] Pneumatic - mattisi - 2012-10-20 13:46

@popeye
Quote:mattisi, the log would be very helpful. I have other users with similar issues.
Also, the API has not changed, important is that you use the plush skin...

i'm sorry i switched back to sab 6.x immediately, but its not working anymore too:-(
do you want logs anyway? which one? where to find?

the plush-skin i dont use. i prefer the smpl one..lesser clicking needed.
is that really a problem? seriously, dont like the trendyfancy plush skinBig Grin
i ever used smpl skin without any problems! ..anything changed?

EDIT:
figured out with popeye. many thanks!
If you get just the message: "waiting for nzb download " seconds counting up endless and sab is downloading
Make Sure in Sabnzbd "Switches->Config" that no Renaming Rule is ticked!


Sv: [RELEASE] Pneumatic - Popeye - 2012-10-20 16:43

Pm the xmbc debug log in a pastebin link to me.
Don't worry about the skin, it was just me being confused..


RE: Sv: [RELEASE] Pneumatic - redsoxboi21 - 2012-10-24 05:10

(2012-10-18 09:30)Popeye Wrote:  Read the first post... Big Grin

Thanks... I must have missed that part. I've got it working now and I love it!

But there is one question I have... How do I get the post processing to work? I am using it for movies and I want it to post process it into my Movies section in XBMC with all the correct metadata. I know that it is supposed to fail and it does, but how can I get it to retry and post process automatically after I watch it? Do I have to do it manually every time?


RE: Sv: [RELEASE] Pneumatic - Popeye - 2012-10-24 09:20

(2012-10-24 05:10)redsoxboi21 Wrote:  
(2012-10-18 09:30)Popeye Wrote:  Read the first post... Big Grin

Thanks... I must have missed that part. I've got it working now and I love it!

But there is one question I have... How do I get the post processing to work? I am using it for movies and I want it to post process it into my Movies section in XBMC with all the correct metadata. I know that it is supposed to fail and it does, but how can I get it to retry and post process automatically after I watch it? Do I have to do it manually every time?

In pneumatic settings you have post processing options. You can select if you want automatic repair or delete or if you want to be asked every time. The response at the end can sometimes fail and then you have to go into the penumatic/newznab incomplete folder and context menu select your actions.


RE: [RELEASE] Pneumatic - redsoxboi21 - 2012-10-24 14:06

Ok, but my movie will not be in the "movies category" on SAB. It's just in a Default category. How can I make it automatically go in the movie category?


RE: [RELEASE] Pneumatic - Popeye - 2012-10-24 14:30

(2012-10-24 14:06)redsoxboi21 Wrote:  Ok, but my movie will not be in the "movies category" on SAB. It's just in a Default category. How can I make it automatically go in the movie category?

Have you looked at the settings for Pneumatic? It's on the first tab...


RE: [RELEASE] Pneumatic - Popeye - 2012-10-25 00:06

I have added a small but important bullet to the prerequisites on the first page:
3. SABnzbd (in switches/naming) cannot have the two "Replace..." settings enabled


RE: [RELEASE] Pneumatic - wreckthisplace - 2012-10-25 02:04

Hey all,

I'm really looking for some help with some things. I am a complete newbie when it comes to this at the moment and am very eager to learn how to setup what it is I want to do. I've tried reading and researching, but it gets a little complicated and I'm about to pull my hair out. I'm slowly learning all of the capabilities of XBMC and all of it's amazing add-ons and this is one I am very interested in trying out.

My end goal is this: I would love to be able to have XBMC (or my computer) automatically download content that I tell it to download from usenet via NZB and then have it place the content into the appropriate folders with artwork and information, as well as potentially stream it as it is downloading. Now, I am fully aware that this can be done. I'm just having a really hard time putting all of the pieces together. So far I have downloaded and installed the Pneumatic add-on for XBMC, the Newznab add-on for XBMC and the most recent version of SABnzbd for Mac OS X Lion 10.7.3. My first issue is with SABnzbd. When I open the application in OS X, nothing happens. It says it's running in the background, but I get no application window, nothing in the task bar or no setup wizard. Essentially, I can't do a thing with it.

Other than that, would anyone be able to help me achieve what I am aiming to achieve? If there's anywhere you can point me to that deals with what I need to do and is easy to sift through and understand based on my OS, that would also be much appreciated.

I do have a usenet account, so that is not a problem. I usually use NZBdrop and NZBVortex but as far as I know, they don't work alongside XBMC.

Any help asap would be so much appreciated.

Thanks so much.


RE: [RELEASE] Pneumatic - redsoxboi21 - 2012-10-25 04:28

(2012-10-24 14:30)Popeye Wrote:  
(2012-10-24 14:06)redsoxboi21 Wrote:  Ok, but my movie will not be in the "movies category" on SAB. It's just in a Default category. How can I make it automatically go in the movie category?

Have you looked at the settings for Pneumatic? It's on the first tab...

Thanks again! But there is a problem. Once it repairs, it goes to a folder that is watched by CouchPotato, which is what is supposed to happen, but CP always says that the movie is unknown? Any way to fix this? How do you have it set up?


RE: [RELEASE] Pneumatic - Popeye - 2012-10-25 10:37

(2012-10-25 04:28)redsoxboi21 Wrote:  Thanks again! But there is a problem. Once it repairs, it goes to a folder that is watched by CouchPotato, which is what is supposed to happen, but CP always says that the movie is unknown? Any way to fix this? How do you have it set up?

I dont follow. Why should the repaired things end up in a watched folder? The watch folder is for nzb's, right?


RE: [RELEASE] Pneumatic - redsoxboi21 - 2012-10-25 14:39

(2012-10-25 10:37)Popeye Wrote:  
(2012-10-25 04:28)redsoxboi21 Wrote:  Thanks again! But there is a problem. Once it repairs, it goes to a folder that is watched by CouchPotato, which is what is supposed to happen, but CP always says that the movie is unknown? Any way to fix this? How do you have it set up?

I dont follow. Why should the repaired things end up in a watched folder? The watch folder is for nzb's, right?

It's not the folder watched by SAB. It's the folder that is watched by CouchPotato to post process the file.


RE: [RELEASE] Pneumatic - redsoxboi21 - 2012-10-26 00:01

Ok disregard what I said. Now I have changed my setup to make it a little easier. I have it set now to go to a folder that is a source in XBMC so that it will automatically go to XBMC, BUT the movies do not have metadata. I've got the source set up to get the info from iMDB, but it still does not work. Any thoughts?


RE: [RELEASE] Pneumatic - mattisi - 2012-10-26 07:23

@popeye

i had an idea for a nice feature..posibilitie to jump fwd. in a movie

you have the duration..calculate with the total of rars and duration to which rar we have to jump.
- respond with buffering %
- move the calculated rar to top in the queue / reorder the following rars
- satisfy the user with the new streaming feeling ;-)

maybe not possbile or tricky..so a good step would be, when jumping to a frame which not available:
add a third option to the list
-back to movie (go back to frame before timejump)
-just download
-delete


RE: [RELEASE] Pneumatic - Popeye - 2012-10-26 10:16

(2012-10-26 00:01)redsoxboi21 Wrote:  Ok disregard what I said. Now I have changed my setup to make it a little easier. I have it set now to go to a folder that is a source in XBMC so that it will automatically go to XBMC, BUT the movies do not have metadata. I've got the source set up to get the info from iMDB, but it still does not work. Any thoughts?

Sorry, still don't follow. You can set a nfo setting in pneumatic, else you will have to trigger xbmc to scan the folder for new content.
(2012-10-26 07:23)mattisi Wrote:  @popeye

i had an idea for a nice feature..posibilitie to jump fwd. in a movie

you have the duration..calculate with the total of rars and duration to which rar we have to jump.
- respond with buffering %
- move the calculated rar to top in the queue / reorder the following rars
- satisfy the user with the new streaming feeling ;-)

maybe not possbile or tricky..so a good step would be, when jumping to a frame which not available:
add a third option to the list
-back to movie (go back to frame before timejump)
-just download
-delete


Cool idea! You could do some testing of your own by manually push inidividual files to the top in SAB and then try to jump to the end in XBMC.


RE: [RELEASE] Pneumatic - ericab - 2012-10-29 08:15

(2012-10-12 01:21)mattisi Wrote:  Hi

I have updatet some minutes ago sabnzbd to 0.7.4 (win)..now pneumatic/newznab is not working anymore:-(

when i click some movie "requesting nzb" seconds count up and up
then i have a look and see that in sabnzb download is started..when i look at the details i see that the last part of rar is NOT moved to the top of queue, so i think thats the problem.

other point is maybe the problem in sabnzbd special settings allow_streaming is checked but behind it is stated as (off)
in the .ini file the value is definitly allow_streaming = 1

so is the problem more pneumatic or sabnzb related?

any fixes or i have to downgrade to lower sabnzbd version?

thanx
mattis


Popeye;
i hate to say it but ive got the exact same issue.
i have the "Replace" switches in sabnzbd disabled, the temp dir for the nzb files is R/W by xbmc.
im on sabnzbd 0.7.4

i notice that when the NZB is added to SAB, the first 2 files arent the first and last rar.

i noticed in the LOG this line: NOTICE: error: expect one parameter
other then that there is nothing of note.

any ideas ?