Kodi Community Forum
Problem with Apple TV 2 - 4.3.1 with Jailbreak - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Off-Topic (/forumdisplay.php?fid=34)
+--- Forum: Off-Topic Discussion (/forumdisplay.php?fid=113)
+--- Thread: Problem with Apple TV 2 - 4.3.1 with Jailbreak (/showthread.php?tid=98493)

Pages: 1 2 3 4 5 6 7 8 9 10 11 12 13 14


- jd2157 - 2011-04-07 14:26

yanksfan Wrote:sorry for the newbie question, where can I find info on how to do this? I need to add another drive to mine

The easiest way is by using ssh, i.e.
ssh root@192.168.1.666 (change the IP to your atv2's IP address, default password is alpine)
cd /private/var/mobile/Library/Preferences/XBMC
rm -rf userdata

If by "need to add another drive" you mean add a USB drive to your atv2 that's not possible. See the FAQ here:
http://wiki.xbmc.org/index.php?title=XBMC_for_iOS_specific_FAQ#Can_I_hook_up_my_external_harddrive_or​_other_USB_device_to_the_ATV2.3F


- Jurg - 2011-04-07 16:03

Olof.n Wrote:Also, I read in another forum "Videos –> Add Source –> Browse –> Windows network (SMB) –> WORKGROUP –> Your Mac –> Select your “shared folder” and confirm by pressing the left previous track button on the Apple Remote –> Name your folder whatever you want, then hit Done" I have a brief memory of that this option was visible to me before i added my "Movies" folder (which is unreachable). Now the only options left in the Video menu is "Files, Playslits and Video Add-ons" where have the "Add Source option gone? Any ideas?

The Add Source is under Files now, I believe.

EDIT: After you add the first source, the Files and Playlists folders are created it seems.


- GoodOmens - 2011-04-07 18:30

Dev team released a new version of their jailbreak - wonder if it fixes the issue?


- tatoosh - 2011-04-07 18:54

Is XBMC now working correct on ATV2 with redsn0w 0.9.6rc10 ?


- DN38416 - 2011-04-07 19:08

I didn't think that you could jailbreak the AppleTV2 with redsn0w?
Have they added support?

EDIT: No they haven't... *sigh* waste of time. Damn noob posts getting my hopes up!


- tatoosh - 2011-04-07 19:19

^^ you're maybe right - but this works: Sn0wbreeze 2.5.1:
http://ih8sn0w.com/index.php/welcome.snow


- DN38416 - 2011-04-07 19:31

cool..
Do you know if it fixes the AC3 and DTS audio issues?


- sandom - 2011-04-07 20:16

DN38416 Wrote:cool..
Do you know if it fixes the AC3 and DTS audio issues?

No it doesn't, smb doesn't work either so i reverted back with seas0nPass


- ldi9999 - 2011-04-07 22:33

I don't really see any advantage upgrading to 4.3.1. I'v been using 4.2.1 with official xbmc and it worked really well. I had buffering issue while playing 720p xvid movies. I thought it might be better if I had the new version.

I'm now on latest nightly on 4.3.1 seas0npass, but with more issues:
- The 700p Xvid is still unwatchable (stutters).
- AC3 passthrough not working
- Random crashes
- Fastforward a few times while playing regular movies and it then started stuttering. I had to stop and play it again.
NoNo


- izibizi - 2011-04-07 22:49

is there a way to see that i am on nightly?

where is the setting for hardware exceleration?


- jd2157 - 2011-04-07 23:53

ldi9999 Wrote:I don't really see any advantage upgrading to 4.3.1. I'v been using 4.2.1 with official xbmc and it worked really well. I had buffering issue while playing 720p xvid movies. I thought it might be better if I had the new version.

I'm now on latest nightly on 4.3.1 seas0npass, but with more issues:
- The 700p Xvid is still unwatchable (stutters).
- AC3 passthrough not working
- Random crashes
- Fastforward a few times while playing regular movies and it then started stuttering. I had to stop and play it again.
NoNo

- iOS 4.3 adds MLB, NBA, Netflix 5.1 sound and Airplay updates for those /w other 4.3 iOS devices to stream to the atv2. Some people want these things, some don't.

- 720p Xvid will always stutter, atv2 only has hardware acceleration for h264/x264 content... XBMC updates aren't going to change this.

- Latest nightlies have issues with AC3, might be what you're seeing. Should eventually be fixed. Hard to say if the fix will come in the new Audioengine (which has been in development since Aug 2010) or from regular updates.

- Haven't seen any random crashes or stuttering personally (using an ethernet connection, not wireless) YMMV.


- andy9000 - 2011-04-07 23:56

What can I do against the SMB problem? Sad


- jd2157 - 2011-04-08 00:05

andy9000 Wrote:What can I do against the SMB problem? Sad

The only SMB problem I know of at the moment is solved with the latest Seas0npass jb. Mine's on iOS 4.3 with the latest nightly build from April 1st and SMB shares are working fine.


- ldi9999 - 2011-04-08 00:11

jd2157 Wrote:- iOS 4.3 adds MLB, NBA, Netflix 5.1 sound and Airplay updates for those /w other 4.3 iOS devices to stream to the atv2. Some people want these things, some don't.

- 720p Xvid will always stutter, atv2 only has hardware acceleration for h264/x264 content... XBMC updates aren't going to change this.

- Latest nightlies have issues with AC3, might be what you're seeing. Should eventually be fixed. Hard to say if the fix will come in the new Audioengine (which has been in development since Aug 2010) or from regular updates.

- Haven't seen any random crashes or stuttering personally (using an ethernet connection, not wireless) YMMV.

Thanks for explaining this.
- I don't really need all those new features
- Guess I have to re-code those 720p Xvid to h264
- I hope AC3 issue would be fixed soon
- Random crashes and stuttering are real issues to me.
Xbmc crashed and went back to aptv main menu quite a few times while i was navigating through the movie collections
I played a movie and fast forwarded a few times. Then the movie started stuttering, like slow motion pictures. Nothing fixes it unless stop it and replay.


- jd2157 - 2011-04-08 00:11

izibizi Wrote:is there a way to see that i am on nightly?

where is the setting for hardware exceleration?

You'd probably know it if you were using the nightlies. You'd be reading this thread and had to have used wget to manually download the latest_atv2.deb file and "dpkg -i latest_atv2.deb" to install it.
http://forum.xbmc.org/showthread.php?tid=97246

Hardware acceleration is under System > Video > Playback > Allow hardware acceleration.