Kodi Community Forum
[WIP] Metropolis skin - Printable Version

+- Kodi Community Forum (http://forum.kodi.tv)
+-- Forum: Help and Support (/forumdisplay.php?fid=33)
+--- Forum: Skin Help and Support (/forumdisplay.php?fid=67)
+---- Forum: Metropolis (/forumdisplay.php?fid=162)
+---- Thread: [WIP] Metropolis skin (/showthread.php?tid=99317)



- stoli - 2012-01-07 22:51

@jabba_29 - thanks ill update that tonight.


- Martijn - 2012-01-07 23:06

I still see that you have logo-downloader as dependency:

Just for you to know
Logo Downloader (the end of it as we know it)


- 5meohd - 2012-01-08 05:51

I'm sorry guys... I just can't figure out how to simply install this skin. Sad

I guess I've never used any repository d/l's I'm going insane.


- stoli - 2012-01-08 15:08

Make sure you are using Eden Beta. Download this file http://passion-xbmc.org/addons/Download.php/repository.passion.xbmc.org/repository.passion.xbmc.org-1.0.4.zip and the in Settings > Addons select install from zip and select the file you just downloaded. After that installs you should have the Passion Repo installed and be able to select this skin.


- stoli - 2012-01-08 21:18

sialivi Wrote:Since there was some interest in my wip viewtype I'll try to finish it. Here's it's current state. The Aspect Ratio on the non focused items are incorrect at the moment and the animations suck (might have to leave that to someone else). Feel free to come with suggestions (but I'm a total newbie so it'll have to be simple suggestions)

[Image: drivez.jpg]

View Added. Smile Good work sialivi!


- noiz13 - 2012-01-09 01:06

just installed it one word AWSOME i have a HTPC built ready for this one the case that is. i am going to use a 60's era radio it will fit perfect


- 5meohd - 2012-01-09 01:15

stoli Wrote:Make sure you are using Eden Beta. Download this file http://passion-xbmc.org/addons/Download.php/repository.passion.xbmc.org/repository.passion.xbmc.org-1.0.4.zip and the in Settings > Addons select install from zip and select the file you just downloaded. After that installs you should have the Passion Repo installed and be able to select this skin.

Thanks for the reply.. however.. its exactly what I did and I still can't see Metropolis.. I see the passion repo.. click it.. and it basically just cycles around in a loop. ?


- FREAKJAM - 2012-01-09 02:24

5meohd Wrote:Thanks for the reply.. however.. its exactly what I did and I still can't see Metropolis.. I see the passion repo.. click it.. and it basically just cycles around in a loop. ?

Did u restart XBMC after installing the addon? If u dont you will only see "..." aka a empty repo. Atleast thats my experience with repo's (or I am just impatient). Try if any other repo works. (Hitcher's for example).


- sialivi - 2012-01-09 06:07

stoli Wrote:View Added. Smile Good work sialivi!

Thanks, but you forgot to include the file in the commit Wink


- stoli - 2012-01-09 16:00

sialivi Wrote:Thanks, but you forgot to include the file in the commit Wink

Details details... Smile It's there now.


- Hudson_Hawk04 - 2012-01-10 17:02

to get the repo populated you have to bring up the context menu and do a force refresh and or update, I think it is something along those lines not near one of my boxes at the moment.


- Aenima99x - 2012-01-11 18:12

For those who haven't seen yet, Martijn has released a new Movie Trailers addon based off Nuka's AMT II Lite addon (see here). I've added it and removed the AMT II addon and it's working great. However if you do this, you will lose the home menu item for "Trailers" in Metropolis. As a quick workaround you can make the following changes and I'm hoping Stoli will add them in (with probably a better way of doing it).

You'll need to make the same change in 2 files - Includes_Home1.xml and Includes_Home2.xml

Open Includes_Home1.xml and go to Line 299.
Open Includes_Home2.xml and go to Line 187.

You should be under the <item id="13"> section and be at the <visible> line. Replace that line with these 2 lines

Quote:<onclick>ActivateWindow(Videos,plugin://plugin.video.the.trailers,return)</onclick>
<visible>system.hasaddon(plugin.video.apple.movie.trailers.lite) + !Skin.HasSetting(NoTrailers) | system.hasaddon(plugin.video.the.trailers) + !Skin.HasSetting(NoTrailers)</visible>
This will keep the Trailers menu item visible and working whether you have AMT or the new The Trailers addon installed. I would recommend not having both installed though.


- noiz13 - 2012-01-12 01:20

i tried this skin it worked perfectly,
But after a update, i get a black screen, i have to shut the HTPC off to get out of this. i am running the latest Eden beta.


- homerjs - 2012-01-12 01:49

noiz13 Wrote:i tried this skin it worked perfectly,
nut after a update i get a black screen, i have to shut the HTPC off to get out of this. i running the latest Eden beta.

I too recently have been getting black screen and freezing after update, icons show but black background behind icins, nothing else showing
Running latest Eden on ATV2


- jabba_29 - 2012-01-12 11:36

I love this skin.

Ignore the stuff below, it seems to have fixed itself. Weird as I didn't do anything. I had deleted textures.db and everything in Thumbnails...

Weird...

---

When I view the tv show info, the poster image is always using banner.jpg and is all distorted - I have to change all show info to use poster.jpg but by default somehow it is looking for thumbs instead of the poster: am I doing this wrong?

http://www.flickr.com/photos/jabba_29/6683548087/in/photostream/
http://www.flickr.com/photos/jabba_29/6683547833/in/photostream/

Added images. I'm using fanart list for the view in TV shows.