Problems building for ios

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
henke66 Offline
Junior Member
Posts: 46
Joined: May 2012
Reputation: 0
Post: #1
Hi, I'm new on the forum. I'm actually also newbie on mac as a developer platform. So be kind Blush.
I'm trying to build xbmc for ios using the instruction in README.ios.
I have downloaded XCODE from the app store. However I didn't find the old version 3.2.5, so I installed 4.3.2 instead. Will this work or do I need to get the 3.2.5 version?

My actual problem is that I fail to execute the command ./bootstrap in the section "3.1 Install Cross libs and runtime environment".
I get the following message:

Code:
./bootstrap: line 1: autoconf: command not found

Is there additional tools, like autoconf and make, that I need to install or should they be available anyway, as part of xbmc or xcode?

Btw, I pulled down the latest code from git yesterday.
(This post was last modified: 2012-05-06 08:16 by henke66.)
find quote
deanmv Offline
Posting Freak
Posts: 876
Joined: Jun 2011
Reputation: 10
Location: UK
Post: #2
The nightlies start again in a few days so you might as well just wait if you are just building straight from mainline. Also as it is stated on GitHub in /docs/readmeIOS

"Install latest Xcode. You can download it from Apple's site after registration at
(http://developer.apple.com/tools/download).
The preferred version is Xcode 3.2.5 and iOS SDK 4.2."

Set Up
Raspberry Pi running Raspbmc - XBMC 12.2
40" Samsung ES6800 LED Smart 3D 1080P TV
Onkyo HTS3405 5.1 DD True HD and DTS-HD Surround Sound
ReadyNAS Duo with 4TB (2 x 2TB X-RAID) Western Digital Caviar Green using NFS
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #3
xcode4 is not supported with the current build system right now. use xcode3.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
smitopher Offline
Member
Posts: 95
Joined: Mar 2012
Reputation: 3
Post: #4
(2012-05-06 23:31)davilla Wrote:  xcode4 is not supported with the current build system right now. use xcode3.
According the the Apple developer web site
Quote:Xcode 3 is incompatible with Mac OS X 10.7 Lion
Since I am using Lion, I cannot perform any builds?
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #5
no, there IS an xcode3 version that will run and build under 10.7. Incompatible here means you can't build via 10.7sdk on xcode3.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
amet Offline
Retired Team-Kodi Member
Posts: 4,087
Joined: Jul 2009
Reputation: 41
Location: Novi Sad / Dubai
Post: #6
this should do it -> http://anatomicwax.tumblr.com/post/80649...lion-redux
find quote
Cranial Offline
Fan
Posts: 740
Joined: Aug 2008
Reputation: 3
Location: Sydney, Australia
Post: #7
Git commit 10.7

Noticed a few new commits, are you moving in the direction of Xcode 4 building?

Been playing with Xcode 4.3 installed, but now that everything is wrapped up inside Xcode.app I think it'll require a fair bit of work that's way over my head. Had to install autoconf from source too as it's dumped in 4.3.

If I have helped you in any way, please forgive me, it was entirely accidental.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #8
you might want to follow along here -> https://github.com/davilla/xbmc/tree/dar...s-refactor

not ready for primetime yet, still working out depends issues.

ps. wtf did apple drop autotools from command-line tools Smile


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
Cranial Offline
Fan
Posts: 740
Joined: Aug 2008
Reputation: 3
Location: Sydney, Australia
Post: #9
(2012-05-08 07:34)davilla Wrote:  you might want to follow along here -> https://github.com/davilla/xbmc/tree/dar...s-refactor

not ready for primetime yet, still working out depends issues.

ps. wtf did apple drop autotools from command-line tools Smile

Thanks, I'll check it out. Will the audio engine merge help with the depends issues?

As for the autotools being dropped, I'm guessing it's to do with gpl.v3 and the shipped version getting way out of date?

Either way, Apple.... easier to just drop functionality than to fix.

If I have helped you in any way, please forgive me, it was entirely accidental.
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #10
"Will the audio engine merge help with the depends issues", no.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote
henke66 Offline
Junior Member
Posts: 46
Joined: May 2012
Reputation: 0
Post: #11
So I finally got the build started!

I had some issues finding the xcode 3.2.5 and then installing it. I didn't find xcode 3.2.5 on apples developer site (where it's supposed to be) however there was a package on the p-bay. Then when I tried to install that it failed, with a non-informal message, due to some signing of the package that had expired.
The solution to this was found here http://managingosx.wordpress.com/2012/03...ignatures/.

I also had to do
./configure --with-darwin=ios --with-sdk=4.2
in stead of
./configure --with-darwin=ios
when installing cross libs and runtime environment.

I think the statement in the README.ios to install latest xcode is a bit misleading nowadays.

Would xcode 3.2.6 also work?
find quote
davilla Offline
Retired-Team-XBMC Developer
Posts: 11,508
Joined: Feb 2008
Reputation: 64
Post: #12
The README.ios is directed to build under 10.6.8. Building under 10.7 is twitchy so we never documented it.

darwin-depends-refactor can build depends and xbmc for osx. not tested ios build yet.


MediaInfo : http://mediainfo.sourceforge.net/
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
find quote