!IsEmpty(ListItem.Thumb) returns true for videolibrary icons

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
pecinko Offline
Donor
Posts: 3,846
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #1
Don't know if it should be this way? Does not seam logical to me.

One exception though, it returns false only for video add-ons in videolibrary root.

My skins:

Amber
Quartz

(This post was last modified: 2011-05-23 23:04 by pecinko.)
find quote
Hitcher Offline
Skilled Skinner
Posts: 11,172
Joined: Aug 2007
Reputation: 105
Location: Eastleigh, UK
Post: #2
It's true because they're not empty surely?
find quote
pecinko Offline
Donor
Posts: 3,846
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #3
Hitcher Wrote:It's true because they're not empty surely?

I probably didn't explain it well? It returns true for DefaultFOO icons in library root, except for Video Add-ons.

In other words, if I use ListItem.Thumb it will show all icons in VideoLibrary Root, except for Video Add-ons.

Is this supposed to be this way?

This is on Mac & Xbmc 10.1.

My skins:

Amber
Quartz

find quote
pecinko Offline
Donor
Posts: 3,846
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #4
To ticket or not to ticket it... ?

My skins:

Amber
Quartz

find quote
Hitcher Offline
Skilled Skinner
Posts: 11,172
Joined: Aug 2007
Reputation: 105
Location: Eastleigh, UK
Post: #5
It shows DefaultAddonVideo.png for me on PC.
find quote
pecinko Offline
Donor
Posts: 3,846
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #6
Hitcher Wrote:It shows DefaultAddonVideo.png for me on PC.

Just to make sure - ListItem.Thumb shows DefaultAddonVideo.png at your side?

If so, shouldn't it return empty texture as it is an icon, not thumb?

My skins:

Amber
Quartz

(This post was last modified: 2011-05-25 19:24 by pecinko.)
find quote
ronie Online
Team-Kodi Member
Posts: 9,486
Joined: Jan 2009
Reputation: 167
Post: #7
pecinko Wrote:Just to make sure - ListItem.Thumb shows DefaultAddonVideo.png at your side?

If so, shouldn't it return empty texture as it is an icon, not thumb?

i think you are right.

i remember seeing a similar issue before:
http://trac.xbmc.org/ticket/7351

so i guess this is just another one of them.

Always read the Kodi online-manual, FAQ and search the forum before posting.
Do not PM or e-mail Team-Kodi members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
pecinko Offline
Donor
Posts: 3,846
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #8
ronie Wrote:i think you are right.

i remember seeing a similar issue before:
http://trac.xbmc.org/ticket/7351

so i guess this is just another one of them.

Yup, seams it's the same problem as in that ticket.

Even weirder thing is I have opposite results on Mac - if I use ListItem.Thumb it will show all DefaultFOO icons in VideoLibrary Root, except for Video Add-ons

My skins:

Amber
Quartz

find quote