playing 60 fps mkv on ATV2?

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Closed
mojo6911 Offline
Junior Member
Posts: 49
Joined: Oct 2009
Reputation: 2
Post: #31
Getting the same problem.
find
pants Offline
Junior Member
Posts: 2
Joined: Dec 2009
Reputation: 0
Post: #32
I'm noticing an increase in popularity with the 60FPS encoding as well. Let's hope a fix comes soon!
find
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #33
KidMirage Wrote:I'm having similar problems with videos recorded at 60fps. The audio is way out of sync with the video. Video looks Ok but the onscreen display shows its only playing at 22 fps. Audio starts out Ok but gets garbled as the clip plays. CPU sits at about 68%.

The files are recorded with a Hauppauge HD-PVR, and play fine on my Acer Revo 1600 box running XBMC Dharma.

Here are the specifics...


General Information:
~~~~~~~~~~~~~~~~~~~~
Platform: ATV2
Version of iOS: 4.2.1.
Build version: Git:62171b3(Compiled Jun 23 2011)
Install method: nitoTV
Connection: HDMI to my 720P TV

Media Information:
~~~~~~~~~~~~~~~~~~
General
ID/String : 0 (0x0)
CompleteName : Z:\Being Erica-(Two Wrongs)-2011-07-04-0.tp
Format : MPEG-TS
FileSize/String : 27.4 MiB
Duration/String : 41s 475ms
OverallBitRate/String : 5529 Kbps
OverallBitRate_Maximum/String : 18.0 Mbps

Video
ID/String : 4113 (0x1011)
MenuID/String : 1 (0x1)
Format : AVC
Format/Info : Advanced Video Codec
Format_Profile : Main@L4.0
Format_Settings_CABAC/String : Yes
Format_Settings_RefFrames/String : 4 frame2
Format_Settings_GOP : M=4, N=32
CodecID : 27
Duration/String : 41s 592ms
BitRate_Mode/String : VBR
BitRate/String : 4868 Kbps
BitRate_Maximum/String : 20.0 Mbps
Width/String : 1280 pixel3
Height/String : 720 pixel3
DisplayAspectRatio/String : 16:9
FrameRate/String : 59.940 fps3
ColorSpace : YUV
ChromaSubsampling : 4:2:0
BitDepth/String : 8 bit3
ScanType/String : Progressive
Bits-(Pixel*Frame) : 0.088
StreamSize/String : 24.1 MiB (88%)
colour_primaries : BT.709-5, BT.1361, IEC 61966-2-4, SMPTE RP177
transfer_characteristics : BT.709-5, BT.1361
matrix_coefficients : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio
ID/String : 4352 (0x1100)
MenuID/String : 1 (0x1)
Format : AC-3
Format/Info : Audio Coding 3
Format_Settings_ModeExtension : CM (complete main)
CodecID : 129
Duration/String : 41s 568ms
BitRate_Mode/String : CBR
BitRate/String : 384 Kbps
Channel(s)/String : 2 channel2
ChannelPositions : Front: L R
SamplingRate/String : 48.0 KHz
BitDepth/String : 16 bit3
Compression_Mode/String : Lossy
Video_Delay/String : -50ms
StreamSize/String : 1.90 MiB (7%)

Debug Information:
~~~~~~~~~~~~~~~~~~
xbmc.log: http://pastebin.com/FW2peEXE
syslog: http://pastebin.com/mjd4qKyA
Sample file: http://www.mediafire.com/file/couhui45vt...07-04-0.tp

the sample link is down ... could we have a reupload please?

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find
KidMirage Offline
Junior Member
Posts: 11
Joined: Jun 2011
Reputation: 0
Location: Waterloo, Ontario
Post: #34
Here is a new sample that shows the problem with 60 FPS recordings on the ATV2. As before this sample plays fine on an Acer Revo 1600 - Dharma Live.

http://www.mediafire.com/file/pysari0cjb...0Sample.ts
find
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #35
thx ... added link to the trac ticket

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find
redgrandam Offline
Junior Member
Posts: 12
Joined: Jun 2011
Reputation: 0
Post: #36
Soo.. it's been 7 months since the ticket listed in this thread was started, seems no progress. I'm not complaining, just wondering how it works, as it's listed as future/pending, does that mean someday sometime it will be looked at? Will it get closed at some point? or just stay open?

I've seen there are some other threads about the same or similar problems, it's still an issue for me (watching the latest Colbert Report HD version still can't play it, forced to use SD video for this and other shows all the time time..)

Any new information to give us hope in a near future fix?

BTW, to the developers, AMAZING job with XBMC in general, can't thank you enough.. This bug in this thread is really the only issue I'm having with it. Everything else works great, and it's made my ATV the most used device and XBMC the most used application by far in my household Smile
find
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #37
apple doesn't use 60fps material in there itunes stores - so one could think there hardware doesn't need to support it. Thats my personal opinion why it doesn't work.

Imho not much hope until we get an special agent into apple wo brings us the complete api documentation of the videotoolbox hardware decoder framework Wink

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find
redgrandam Offline
Junior Member
Posts: 12
Joined: Jun 2011
Reputation: 0
Post: #38
Memphiz Wrote:apple doesn't use 60fps material in there itunes stores - so one could think there hardware doesn't need to support it. Thats my personal opinion why it doesn't work.

Imho not much hope until we get an special agent into apple wo brings us the complete api documentation of the videotoolbox hardware decoder framework Wink

That was my fear. Smile. Thanks!
find
soundmanbrad Offline
Junior Member
Posts: 4
Joined: Sep 2005
Reputation: 0
Post: #39
Like another member, I am having this problem on the Apple TV 2. The files I am using are 720p mkvs and they played perfectly fine on the old nightly releases of XBMC. So I don't think it is an issue with the hardware.
find
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #40
soundmanbrad Wrote:Like another member, I am having this problem on the Apple TV 2. The files I am using are 720p mkvs and they played perfectly fine on the old nightly releases of XBMC. So I don't think it is an issue with the hardware.

and now? I doubt that 60fps material played on any version of xbmc for atv2/ios. So maybe you have another problem? Post the mediainfo of that file...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find
jd2157 Offline
Fan
Posts: 642
Joined: Jan 2011
Reputation: 0
Location: Nova Scotia
Post: #41
So just to be clear, we shouldn't expect any 720p video at 60 fps to play without syncing issues on the atv2 because of inadequate hardware (and/or lack of hardware documentation)? Just trying to figure out if the issue is open, closed or undetermined. The ticket still looks open but no activity in 3 months.


For example, on my atv2 running Eden rc1 and Apple TV 4.4.4, this file won't play without sync issues (even when copied local to the atv2).
EDIT: I did create a new guisettings.xml and update the latency delay in advancedsettings.xml to 0 but the audio and video still aren't synced.

Code:
General
Unique ID                                : 3659106022034442551454203031187631330 (0x2C0B7DB057EEC2D9099E34794542CE2)
Complete name                            : the.colbert.report.720p.x264.mkv
Format                                   : Matroska
Format version                           : Version 2
File size                                : 573 MiB
Duration                                 : 21mn 28s
Overall bit rate                         : 3 733 Kbps
Encoded date                             : UTC 2012-02-23 08:41:38
Writing application                      : mkvmerge v2.7.0 ('Do It Again') built on Jul  2 2010 15:54:17
Writing library                          : libebml v0.7.7 + libmatroska v0.8.1

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.1
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 5 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 21mn 28s
Bit rate                                 : 3 275 Kbps
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate                               : 59.940 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Bits/(Pixel*Frame)                       : 0.059
Stream size                              : 503 MiB (88%)
Writing library                          : x264 core 120 r2164 da19765
Encoding settings                        : cabac=1 / ref=5 / deblock=1:0:0 / analyse=0x3:0x113 / me=umh / subme=8 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=16 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=300 / keyint_min=30 / scenecut=40 / intra_refresh=0 / rc_lookahead=50 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / ip_ratio=1.40 / aq=1:1.00
Language                                 : English
Default                                  : Yes
Forced                                   : No
Matrix coefficients                      : BT.709-5, BT.1361, IEC 61966-2-4 709, SMPTE RP177

Audio
ID                                       : 2
Format                                   : AC-3
Format/Info                              : Audio Coding 3
Mode extension                           : CM (complete main)
Codec ID                                 : A_AC3
Duration                                 : 21mn 28s
Bit rate mode                            : Constant
Bit rate                                 : 384 Kbps
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Bit depth                                : 16 bits
Compression mode                         : Lossy
Stream size                              : 59.0 MiB (10%)
Default                                  : Yes
Forced                                   : No
(This post was last modified: 2012-02-29 02:38 by jd2157.)
find
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #42
no 60fps on atv2!

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find
jd2157 Offline
Fan
Posts: 642
Joined: Jan 2011
Reputation: 0
Location: Nova Scotia
Post: #43
Memphiz Wrote:no 60fps on atv2!

Thanks, very clear now Smile

Hopefully March 7 will bring a solution that's easily jailbroken... let's all pray together.
find
mcpish Offline
Junior Member
Posts: 40
Joined: Jan 2011
Reputation: 0
Post: #44
jd2157 Wrote:Thanks, very clear now Smile

Hopefully March 7 will bring a solution that's easily jailbroken... let's all pray together.

This is what I'm really hoping for in the AppleTV3 box:
  • $99 Price
  • 1080p capable at 23.976, 24, 25, 29.97, and 59.94 fps
  • fast enough for realtime advanced deinterlacing (2x) 60Hz - making it usable as a HD MythTV frontend using the MythBox plugin
find
jd2157 Offline
Fan
Posts: 642
Joined: Jan 2011
Reputation: 0
Location: Nova Scotia
Post: #45
Closing thread before it turns into an atv hardware discussion. Memphiz makes it clear, atv2 won't do 720p at 60 fps... case closed.
find
Thread Closed