[Release] MLBMC - a Major League Baseball (video) add-on

  Thread Rating:
  • 3 Votes - 4.67 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #31
OK, we got a new error -
Code:
ERROR: Win32DllLoader::Load: Unable to load special://xbmcbin/system/players/dvdplayer/librtmp.dll (127)

I'm not sure why you would get this error. I would try download rtmpdump - http://rtmpdump.mplayerhq.hu/download/rt...-win32.zip and extract the librtmp.dill to /xbmc/system/players/dvdplayer/
find quote
Hack_kid Offline
Fan
Posts: 646
Joined: Jan 2007
Reputation: 4
Post: #32
I do compile my own builds am I missing something
find quote
Hack_kid Offline
Fan
Posts: 646
Joined: Jan 2007
Reputation: 4
Post: #33
Changing ells fixed it but why? Mine was way smaller then the one you linked to very interesting I'm gonna try a nightly from the site and see but I think I tryed before
find quote
WildBill Offline
Senior Member
Posts: 229
Joined: Aug 2011
Reputation: 3
Post: #34
Just an FYI

Seeon.tv has been having 3 streams of MLB games for a few days now.Dont't know how long they are going to last.

http://www.seeon.tv/view/18656/MLB
http://www.seeon.tv/view/18657/MLB
http://www.seeon.tv/view/18658/MLB
find quote
sdsnyr94 Offline
Fan
Posts: 512
Joined: Aug 2009
Reputation: 2
Location: Greensboro, NC
Post: #35
Divingmule - Last night I tried to watch the Mets game, and could only get as far as selecting the home/away feed... it would tell me that there was an error in playback. The log file shows a lot of:

WARNING: FillBuffer: curl failed with code 22
ERROR: CFileCurl::CReadState::Open, didn't get any data from stream.

I tried again today with same issue:

http://pastebin.com/zPQa0QEW

The only PC the games worked on was the one that I could use the Nexdef settings on.

Archive games did work... it was just live games.

***EDIT**** If I switch from Nexdef to the Flash1800 feed, I get the same results.... so the only thing working for me is the Nexdef feed.
(This post was last modified: 2011-08-28 01:40 by sdsnyr94.)
find quote
sdsnyr94 Offline
Fan
Posts: 512
Joined: Aug 2009
Reputation: 2
Location: Greensboro, NC
Post: #36
Well, after a 2 day issue, the problem appears to have cleared itself. Anyone else see a problem late last week?
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #37
Back when we first started developing this there was a day, maybe two, that the urls changed. They were really short, looking at your log it looks like that is what happend.

Anyway, glad it's working again.
find quote
lephio Offline
Junior Member
Posts: 9
Joined: Aug 2011
Reputation: 0
Post: #38
outstanding job. thanks to you and daftcat of mlbviewer.

better than any other mlb app. everything works out-of-the-box

you're the men!

thanx from italy
find quote
lephio Offline
Junior Member
Posts: 9
Joined: Aug 2011
Reputation: 0
Post: #39
any chance to have this stream on MLBMC menu?

http://mlb.mlb.com/search/media.jsp?mlbt...eebok_flex
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #40
lephio Wrote:any chance to have this stream on MLBMC menu?

http://mlb.mlb.com/search/media.jsp?mlbt...eebok_flex

Good chance Wink I'm looking into it.
find quote
lephio Offline
Junior Member
Posts: 9
Joined: Aug 2011
Reputation: 0
Post: #41
great!
find quote
dan1son Offline
Fan
Posts: 608
Joined: Dec 2008
Reputation: 0
Post: #42
Having an issue with the NexDef feeds myself. I compile my own xbmc (git pull was yesterday). I added librtmp, and compiled mlbhls per instructions. The regular flash feeds work fine, but the HD ones don't tend to do much of anything.

Reading the logs I see it's creating pipeline files in /tmp but xbmc isn't playing them. I also don't see mlbhls running at all.

When I run mlbhls from the command line with the base64 url the plugin spits out, it seems to work fine. A file is created wherever I want and continues to grow.

Thoughts?
find quote
divingmule Offline
Skilled Python Coder
Posts: 1,297
Joined: Oct 2008
Reputation: 61
Post: #43
Yeah, the NexDef mod is only working with dharma (stable 10.1). With eden-pre I get the same as you. The only thing in the log is
Code:
ERROR: Control 1 in window 10099 has been asked to focus, but it can't

I tried it once, left xbmc open and opened the temp file with mplayer and mlbhls fired up and xbmc tried to start playing but crashed.

I'm not really sure where to go with this. It would probably be hard to get a xbmc dev. to look in to this with all the hoops to jump through to reproduce the error.
find quote
dan1son Offline
Fan
Posts: 608
Joined: Dec 2008
Reputation: 0
Post: #44
divingmule Wrote:Yeah, the NexDef mod is only working with dharma (stable 10.1). With eden-pre I get the same as you. The only thing in the log is
Code:
ERROR: Control 1 in window 10099 has been asked to focus, but it can't

I tried it once, left xbmc open and opened the temp file with mplayer and mlbhls fired up and xbmc tried to start playing but crashed.

I'm not really sure where to go with this. It would probably be hard to get a xbmc dev. to look in to this with all the hoops to jump through to reproduce the error.

Well darn. Out of curiosity where's the code for this mlbmc plugin? I found your google code repository, but it looks significantly outdated.
find quote
dan1son Offline
Fan
Posts: 608
Joined: Dec 2008
Reputation: 0
Post: #45
I'm not seeing that ERROR when I attempt to run it, I'm not sure it's related. If you google that error there's a lot of people seeing it in XBMC builds of late, with no clear indication of it causing the actual problem.

Looking through the code from the repo
Code:
print filename
                try:
                    os.mkfifo(filename)
                except OSError, e:
                    print "Failed to create FIFO: %s" % e
                else:
                    fifo = open(filename, 'w')
                if __settings__.getSetting('scenario') == 'NexDef - Auto Select':
                    bitrate = ' -L'
                if __settings__.getSetting('scenario') == 'NexDef - 4.5 Mb':
                    bitrate = ''
                if __settings__.getSetting('scenario') == 'NexDef - 3.0 Mb':
                    bitrate = ' -b 3000000'
                if __settings__.getSetting('scenario') == 'NexDef - 1.8 Mb':
                    bitrate = ' -b 1800000'

                target = 'mlbhls -B '+game_url+' -o '+filename+bitrate
                print '----Target: '+target

Something between the print filename (which I do get) and the print ----Target: fails with no output. I do get the files in /tmp, but mlbhls never starts up.

Maybe if I get bored tonight I'll see if I can get it working.
find quote
Post Reply