How to get a seamless remote experience

  Thread Rating:
  • 9 Vote(s) - 4.22 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Savage702 Offline
Junior Member
Posts: 34
Joined: Mar 2009
Reputation: 0
Post: #181
I have the HP MCE Remote, and all in all it works great with Kodibuntu. I've seen a lot of people commenting about having problems coming out of Standby mode. My only issue is coming out of the screen dimming mode. I don't have it going into standby or anything like that, but if it spends a good amount of time in the screen dim mode, the remote doesn't do anything. I have to grab my keyboard, and tap any key, then the remote will continue working again. I do notice whenever this happens, the red light on the reciever is solid, as if it's getting a signal from the remote none stop... but it's not. Again, tapping a key on the keyboard stops all that, and the remote resumes normal operation.
find quote
forster164 Offline
Junior Member
Posts: 9
Joined: Nov 2015
Reputation: 0
Post: #182
Hi guys,

Sorry for all the help I've been requiring but here is one more for you.

Lubuntu 15.04 (kernel: Linux 3.19.0-15-generic)
Kodi 15.2 Git:02e7013
Intel NUC

I'm trying to run ir-keytable -c -w /etc/rc_keymaps/rc6_mce

sudo ir-keytable -c -w /etc/rc_keymaps/rc6_mce
Invalid parameter(s)
ir-keytable: -w: (PROGRAM ERROR) Option should have been recognized!?
Try `ir-keytable --help' or `ir-keytable --usage' for more information.

I'm sure it is a small error but cant seem to figure it out for the life of me!

Thanks once again!
find quote
tocinillo Offline
Posts: 414
Joined: Dec 2010
Reputation: 13
Post: #183

I have exactly the same problem that this guy:

My OS is Ubuntu 14.04 (kernel 4.3) with OrigenAE M10 (15c2:0036 device) and a MCE Remote (Philips RC197). I installed ir-keytable and lirc without any problem. Then I did sudo dpkg-reconfigure lirc and select Linux input layer and my device without problems. Finally I executed: /usr/bin/ir-keytable -w /lib/udev/rc_keymaps/imon_mce -p RC6 (I didn't remember exactly the command, but was worked).

Finally I tested with: ir-keytable -t and every button worked lovely. But....the pause, stop, guide, and 3-4 more buttons has the same problem with the "Double Presses'. It's very easy to identify with the "ir-ketable -t" and pressing any of this buttons...

Any ideas?
(This post was last modified: 2015-12-11 18:32 by tocinillo.)
find quote
ffws Offline
Junior Member
Posts: 12
Joined: Oct 2009
Reputation: 0
Post: #184
(2015-09-25 03:05)LupinSansei Wrote:  Man I am struggling like hell getting this to work. I have simple commands working like volume up and down, enter, arrow up and down etc but nothing else no matter what rc6_map I use :/

Here is my rc6_mce file.

and my keyboard.xml for Kodi.

I just want the normal basic commands nothing special like hitting ok to open, guide button for contex guide butong going back home etc please help. Bout to pull my hair out lol.

I moved to a new linux mint 17.3 cinammon, and i was having issues with some buttons working and others did not.

Somehow when you load a custom keytable is not getting loaded or something.

I had to copy my "custom table" and overwrite this file:


and then reboot...and it was heaven again!
find quote
grzechu84 Offline
Junior Member
Posts: 1
Joined: Jan 2016
Reputation: 0
Post: #185

I have a problem with the RC of DVB S2 TBS6982SE. I have installed Ubuntu Server 15.10, where it is installed KODI.

In the RC does not work all the keys.
Do not operate below these keys:
POWER, Back, OK, CHL + CHL-, *, #, TV, Zoom, FAV Mode, the EPG, SUB, REPLAY, SKIP.

After applying the ir-keytable command in the console shows that the pilot sends commands with these keys.

sudo ir-keytable  -t

Testing events. Please, press CTRL-C to abort.
1454241106.710528: event type EV_MSC(0x04): scancode = 0x84
1454241106.710528: event type EV_KEY(0x01) key_down: KEY_POWER2(0x0001)
1454241106.710528: event type EV_SYN(0x00).
1454241106.710593: event type EV_MSC(0x04): scancode = 0x84
1454241106.710593: event type EV_SYN(0x00).
1454241106.962500: event type EV_KEY(0x01) key_up: KEY_POWER2(0x0001)
1454241106.962500: event type EV_SYN(0x00).
1454241120.510525: event type EV_MSC(0x04): scancode = 0x99
1454241120.510525: event type EV_KEY(0x01) key_down: KEY_OK(0x0001)
1454241120.510525: event type EV_SYN(0x00).
1454241120.510562: event type EV_MSC(0x04): scancode = 0x99
1454241120.510562: event type EV_SYN(0x00).
1454241120.762517: event type EV_KEY(0x01) key_up: KEY_OK(0x0001)
1454241120.762517: event type EV_SYN(0x00).

In KODI also I installed application to map the keys, but it is not possible to map onto these keys. In KODI they do not work.

More info:

sudo ir-keytable
Found /sys/class/rc/rc0/ (/dev/input/event7) with:
        Driver saa716x, table rc-tbs-nec
        Supported protocols: NEC RC-5 RC-6 JVC SONY LIRC other
        Enabled protocols: NEC LIRC
        Name: saa716x IR (TurboSight TBS 6982S
        bus: 1, vendor/product: 6982:0002, version: 0x0001
        Repeat delay = 500 ms, repeat period = 125 ms

How to solve the presented problem?

(This post was last modified: 2016-01-31 13:56 by grzechu84.)
find quote
5ggggg Offline
Junior Member
Posts: 30
Joined: Jan 2016
Reputation: 0
Post: #186
Harmony 650: Profiles "MCE Remote SE" plus "MCE Keyboard" Ubuntu 14lts

Hi IR profs ;-)
With ir-keytable protocols RC-6 and mce_kbd enabled, "MCE remote" works but MCE keyboard gives trouble ...

"MCE Keyboard":
1 Quite often repeated keys
2 Mouse buttons: no button Up is dedected (or it comes too late). It comes when I press another button like "mouse move" in the example below
Event: time 1459697933.706289, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 1 = Button Down
Event: time 1459697934.507118, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 2 = Repeat
Event: time 1459697934.707126, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 2
Event: time 1459697935.107119, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 2
Event: time 1459697935.210348, type 2 (EV_REL), code 0 (REL_X), value -5 = I pressed Mouse Move button
Event: time 1459697935.210348, type 1 (EV_KEY), code 273 (BTN_RIGHT), value 0 = then Button Up comes

So right now I gave up on using the kernel modules and try to use LIRC instead.
+ I got the "MCE Remote" working, when checking with irw.
+ I also see the signals from "MCE Keyboard" when using "mode2 -d /dev/lirc0", but nothing with irw.
- I did not find any lirc.conf for the "MCE Keyboard"

MODULES="lirc_dev mceusb ir_lirc_codec"

After researching for weeks I am still not sure which mode I should use to get "MCE Keyboard (not Remote)" working: "lirc only" or "kernel+lirc" and how to do that.

a) Is there a lirc.conf for "MCE keyboard" ?
b) how to configure hardware.conf ?
find quote
LupinSansei Offline
Senior Member
Posts: 287
Joined: Sep 2010
Reputation: 1
Post: #187
Does anyone have or know where I can get an rc6_mce file? I was dumb and accidentally overwrote mine without backing it up :/

Asrock Extreme 4 Z97
Intel i7 4790k @4.7ghz
EVGA Hybrid FTW GTX 1070
G.Skill Ripjaws 32GB ram
Samsung 500GB SSD
750gb HDD
Windows 10 Pro x64
find quote
cityboy19 Offline
Junior Member
Posts: 5
Joined: Dec 2015
Reputation: 0
Post: #188
how to edit hardware.conf ?
find quote
GodzillaXP Offline
Junior Member
Posts: 34
Joined: Oct 2011
Reputation: 0
Post: #189
I am having a strage problem.

ir-keytable shows my keymap is working correctly.

But some key presses are not detected by kodi (17).

KEY_UP, KEY_SELECT, KEY_I are working for example.
But KEY_H, KEY_PAGEUP, ... are not shown in the kodi's debug log.

Does anybody have an idea why this happens?

My system:
Lubuntu 16.04
Kodi 17 Beta 3


I found the solution!

You need to restart the X server (restart kodi service or reboot), because it only triggers on KEYs that are mapped during the start of X.

You also need to load your keymap with ir-keytable befor you restart X.
(This post was last modified: 2016-10-24 00:41 by GodzillaXP.)
find quote
bnebenda Offline
Junior Member
Posts: 2
Joined: Nov 2016
Reputation: 0
Post: #190

I'm having trouble with my IR remote. I'm running ubuntu 16.04 and kodi 16.1 and everything is fine after a reboot (i.e. the remote control can be used to operate kodi). However when I suspend the PC I'm able to wake up using the IR remote but it's no longer usable in kodi.

Below is the output of dmesg:
[ 31.767341] lirc_dev: IR Remote Control driver registered, major 244
[ 31.793877] usbcore: registered new interface driver mceusb

lsusb shows this:
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 005 Device 002: ID 1d57:ac01 Xenta Wireless Receiver (Keyboard and Mouse)
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

From what I have seen in various postings there should be an entry for the IR control. Is there anything that I could do to get this resolved. (I tried to use lirc but so far to no result).

Thanks alot for any helpful hints.

PS I forgot to mention that even after waking up from suspend ubuntu is accepting the shutoff IR command (i.e. it opens the selection whether one would like to sleep, shutdown, restart etc.)
(This post was last modified: 2016-11-13 16:40 by bnebenda.)
find quote
electricc0wb0y Offline
Junior Member
Posts: 2
Joined: Dec 2013
Reputation: 0
Post: #191
The path to the lirc device changed on zesty. To use lirc with kodi on zesty, you need to point kodi to the new device:
kodi -l /var/run/lirc/lircd
find quote
Post Reply