XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)

  Thread Rating:
  • 5 Vote(s) - 4.2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
clipper99 Offline
Senior Member
Posts: 271
Joined: Dec 2008
Reputation: 3
Location: Vancouver Island
Post: #2416
(2015-11-27 10:02)speedyrules Wrote:  nobody reading here? Sad maybe i need to opne up a new post

I'm assuming that official support for the app is dead. The Trakt TV function no longer works for me and I've all but given up on it being updated. I really miss the feature. Good luck on your question!

[Image: movie-thin-banner.jpg]
iMac 12,2 HTPC (Gotham 13.2/Aeon Warlion 4.1.9/MacOSX 10.10.1)/Sony STR-DG800/LG 50" Plasma
find quote
coyote82 Offline
Junior Member
Posts: 19
Joined: Feb 2013
Reputation: 0
Post: #2417
Will you update the Cinema Experience Option to the new Cinema Vision function which is the new Version of CE?
find quote
stryjek4 Offline
Junior Member
Posts: 4
Joined: Dec 2015
Reputation: 1
Post: #2418
Hi there guys,

As one of XBMC Constellation creators I'd like to say hello to all of you and let you guys know that XBMC Constellation isn't dead. In fact, recently it received a bugfix update and will be maintained. Trakt integration is already fixed but we don't expect Apple to release a new version before Christmas as they shut down reviews from tomorrow.
find quote
Brice Offline
Junior Member
Posts: 28
Joined: Jun 2009
Reputation: 0
Question  RE: XBMC Constellation For iPad/iPhone by FSS.cc (unofficial remote)
Post: #2419
EDIT : Looking at the difference between loppback address and every adress. I found the setting that allowed control from another device like Constellation on the iPad. See http://kodi.wiki/view/JSON-RPC_API#Enabling_JSON-RPC, but with Jarvis the settings are now in Network > Remote Control

And after a restart netstat indeed show
Code:
TCP    0.0.0.0:9090           0.0.0.0:0              LISTENING       2608

ORIGINAL
Does anyone can make the JSON RPC work with the new Jarvis betas ?

Constellation cannot connect to the JSON RPC port.

I looked at it, forced the port in the advancedsettings.xml file following the wiki pages (advancedsettings.xml, json rpc)

Code:
<advancedsettings>
    <jsonrpc>
        <compactoutput>true</compactoutput>
        <tcpport>9090</tcpport>
    </jsonrpc>
    
    <videoscanner>
        <ignoreerrors>true</ignoreerrors>
    </videoscanner>
</advancedsettings>

However the resource monitor on windows 10 seems to indicate that this port is listening on the loopback ipv6 interface only while the regular http server on the port 59000 listen on both ipv4 and ipv6 addresses.

Code:
Image    PID    Address    Port    Protocol    Firewall Status
Kodi.exe    7340    IPv4 unspecified    1638    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    1718    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    1900    UDP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    1921    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    2127    UDP    Allowed, not restricted
Kodi.exe    7340    IPv6 loopback    9090    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    9777    UDP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    14275    UDP    Allowed, not restricted
Kodi.exe    7340    IPv6 unspecified    36666    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    36666    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 loopback    52307    TCP    Allowed, not restricted
Kodi.exe    7340    IPv6 unspecified    59000    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    59000    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 loopback    59994    TCP    Allowed, not restricted


netstat -aon | more

Code:
...
  TCP    0.0.0.0:59000          0.0.0.0:0              LISTENING       7340
...
  TCP    [::]:59000             [::]:0                 LISTENING       7340
  TCP    [::1]:9090             [::]:0                 LISTENING       7340
...

Is there something I have missed in the advanced settings ?
(This post was last modified: 2015-12-21 18:15 by Brice.)
find quote
brick0044 Offline
Junior Member
Posts: 11
Joined: Jan 2014
Reputation: 0
Post: #2420
(2015-12-21 18:05)Brice Wrote:  EDIT : Looking at the difference between loppback address and every adress. I found the setting that allowed control from another device like Constellation on the iPad. See http://kodi.wiki/view/JSON-RPC_API#Enabling_JSON-RPC, but with Jarvis the settings are now in Network > Remote Control

And after a restart netstat indeed show
Code:
TCP    0.0.0.0:9090           0.0.0.0:0              LISTENING       2608

ORIGINAL
Does anyone can make the JSON RPC work with the new Jarvis betas ?

Constellation cannot connect to the JSON RPC port.

I looked at it, forced the port in the advancedsettings.xml file following the wiki pages (advancedsettings.xml, json rpc)

Code:
<advancedsettings>
    <jsonrpc>
        <compactoutput>true</compactoutput>
        <tcpport>9090</tcpport>
    </jsonrpc>
    
    <videoscanner>
        <ignoreerrors>true</ignoreerrors>
    </videoscanner>
</advancedsettings>

However the resource monitor on windows 10 seems to indicate that this port is listening on the loopback ipv6 interface only while the regular http server on the port 59000 listen on both ipv4 and ipv6 addresses.

Code:
Image    PID    Address    Port    Protocol    Firewall Status
Kodi.exe    7340    IPv4 unspecified    1638    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    1718    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    1900    UDP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    1921    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    2127    UDP    Allowed, not restricted
Kodi.exe    7340    IPv6 loopback    9090    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    9777    UDP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    14275    UDP    Allowed, not restricted
Kodi.exe    7340    IPv6 unspecified    36666    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    36666    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 loopback    52307    TCP    Allowed, not restricted
Kodi.exe    7340    IPv6 unspecified    59000    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 unspecified    59000    TCP    Allowed, not restricted
Kodi.exe    7340    IPv4 loopback    59994    TCP    Allowed, not restricted


netstat -aon | more

Code:
...
  TCP    0.0.0.0:59000          0.0.0.0:0              LISTENING       7340
...
  TCP    [::]:59000             [::]:0                 LISTENING       7340
  TCP    [::1]:9090             [::]:0                 LISTENING       7340
...

Is there something I have missed in the advanced settings ?

I'm having the same issue.Hopefully there is support for this running Jarvis
find quote
Anesthaesia Offline
Junior Member
Posts: 1
Joined: Feb 2016
Reputation: 0
Post: #2421
Hi all,

I'm hoping someone here can help with an issue I am having.

I am running OpenElec on a Pi and Constellation on an iPad. Everything has worked for years, however whenever I open the iPad lid or resume playback after pausing, Constellation seems to do an update which is indicated by a progress bar near the top of the screen. The update takes about 60-90 sec, however during this time any video playback pauses briefly a few times (maybe 5 pauses for 10-20 sec each)

I have tried everything to disable this updating - does anyone have an idea of what it is doing during this time and whether this can be disabled?
find quote
fischgourmet Offline
Junior Member
Posts: 33
Joined: Jan 2014
Reputation: 1
Location: Berlin
Post: #2422
Any news about JSON RPC work with Jarvis?
find quote
fischgourmet Offline
Junior Member
Posts: 33
Joined: Jan 2014
Reputation: 1
Location: Berlin
Post: #2423
push
(This post was last modified: 2016-05-02 17:10 by fischgourmet.)
find quote
fischgourmet Offline
Junior Member
Posts: 33
Joined: Jan 2014
Reputation: 1
Location: Berlin
Post: #2424
Works fine now. Thanks.
find quote
Post Reply