Aeon Nox animations cause unending memory consumption+crash when XBMC is hidden.

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
escobar Offline
Junior Member
Posts: 29
Joined: Dec 2009
Reputation: 0
Post: #1
EDIT: PLEASE SEE THIS POST. THIS IS AN XBMC PROBLEM, NOT LIMITED TO AEON NOX.

OS: Windows XP 32
XBMC: Latest Nightly
Aeon Nox Skin: Lastest Passion Repo
External Media Player: MPC HC


When XBMC is hidden for any reason (alt-tab or external media player usage), the Aeon Nox animations cause XBMC to consume memory endlessly - until it finally crashes.

The rate of memory consumptions varies, depending on whether "Alt-tab" is used or an external media player is called. When "Alt-tab" is used, the memory increases by about 30 K / per second in the 'Task Manager'. When an external media player is called, memory increases by a whopping 300000 K / per second. In both cases, consumption increases until XBMC finally crashes (around 2GB of memory in my task manager).

I am sure it is the animations causing this. Simply put, I disabled the animations in Aeon Nox options & the problem went away. The memory either stabalizes or decreases - there is no unending increase or crash.

I am also sure it is specifically Aeon Nox animations causing this (and not animations in general). For example, I use the 'Neon' skin which has the "Ken Burns" moving background animation. The memory consumption stabilizes in both "Alt-Tab" & external media player usage. No crash ever occurs.

Here is further proof this is unique to Aeon animations: This problem also exists in the "Simplicity" skin which uses Aeon's "Smoke Effect" animation. It can be turned off/on, and we get the exact same results. When it is turned on - using either "Alt-Tab" or external media player - the same unending memory consumption problem occurs (with the result of XBMC crashing).

Is there any way the Aeon Nox animations can be fixed?
(This post was last modified: 2011-07-25 09:32 by escobar.)
find quote
stoli Offline
Skilled Skinner
Posts: 2,409
Joined: Nov 2008
Reputation: 31
Location: Florida
Post: #2
It would be helpfull if you could post a debug log when this happens. Enable debugging in Settings, reproduce the issue and then post the log to pastebin.com and link to it here.
find quote
BigNoid Offline
Team-Kodi Member
Posts: 3,164
Joined: Jul 2010
Reputation: 103
Location: Below sea level
Post: #3
CPU usage increases when using Aeon Nox
This can be caused by enabling the smoke like background effect.
Disable the background effect in the Home window - and View type options to fix this problem.

It even says in the option itself it can increase CPU usage

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
escobar Offline
Junior Member
Posts: 29
Joined: Dec 2009
Reputation: 0
Post: #4
Big_Noid Wrote:CPU usage increases when using Aeon Nox

It even says in the option itself it can increase CPU usage

I already knew that.

Please read my initial post carefully. I was talking about memory consumption (RAM & Paging File). The CPU consumption is not a problem. That remains stable throughout.

Also, I should mention that I have no trouble while actually navigating within XBMC. The problem only occurs when I "alt-tab" or use an external media player.

My next post will contain log & screenshots.
find quote
escobar Offline
Junior Member
Posts: 29
Joined: Dec 2009
Reputation: 0
Post: #5
Here is the pastebin copy of my log:
http://pastebin.com/a7ZzP26s

Here is a screenshot of task manager while my XBMC is idle in the animated movie library:
[Image: normi.png]
(Image name, User name, CPU, Mem usage)

Here is a screenshot of task manager while movie is playing - perhaps a minute in:
[Image: beforecrash.png]
(Image name, User name, CPU, Mem usage)

Here is a screenshot of task manager after XBMC memory consumption peaks & crashes:
[Image: crashoo.png]
(Image name, User name, CPU, Mem usage)
(This post was last modified: 2011-07-24 17:33 by escobar.)
find quote
BigNoid Offline
Team-Kodi Member
Posts: 3,164
Joined: Jul 2010
Reputation: 103
Location: Below sea level
Post: #6
Just disable the background effect options, the ones that say can increase cpu usage. The ken burns effect are just regular slide and zoom animations.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
escobar Offline
Junior Member
Posts: 29
Joined: Dec 2009
Reputation: 0
Post: #7
Big_Noid Wrote:Just disable the background effect options, the ones that say can increase cpu usage. The ken burns effect are just regular
slide and zoom animations.

Of course I can disable the animations. My issue is that I shouldn't have to...because this has nothing to do with my hardware specs (which are decent).

The Aeon animations are only gobbling up memory to infinity - when - XBMC is hidden (via alt-tab or external media player). Otherwise, it works beautifully.

For example, let's take the simple "regular slide and zoom" ken burns effect.

I told you that Neon had it...and it worked fine during alt-tab & external MPC. Meanwhile, Aeon Nox also has Ken Burns animation (with smoke disabled)...and it doesn't work during alt-tab & external MPC. Clear sign that this isn't hardware problem.

So we just have to figure out why Aeon Nox's animations go crazy when XBMC is hidden.
(This post was last modified: 2011-07-24 18:58 by escobar.)
find quote
BigNoid Offline
Team-Kodi Member
Posts: 3,164
Joined: Jul 2010
Reputation: 103
Location: Below sea level
Post: #8
Okay, just to be clear: you experience this issue with both settings disabled:
Home window options-->Enable background effect (Can increase CPU usage)
Viewtype options--> Enable background effect on panels (Can increase cpu usage)
Cause with one of these enabled I can explain the excess usage of ram. It's an multi image control that loads lots of pictures at high speed.

The option that causes the ken burns effect is in General settings--> Enable animated backgrounds.
This option is basically the same that all other skins are also using for animated backgrounds, just a different tweener and easing. To test if this causes your issue change this in the includes_animations.xml:
Code:
<include name="Animation_Background">
    <animation effect="zoom" start="110" end="130" center="auto" time="16000" tween="cubic" easing="inout" pulse="true" condition="Skin.HasSetting(animatedbg)+[Window.IsActive(home)|!Skin.HasSetting(animatedbghome)]">Conditional</animation>
    <animation effect="slide" start="-10,-10" end="20,20" time="8000" tween="cubic" easing="inout" pulse="true" condition="Skin.HasSetting(animatedbg)+[Window.IsActive(home)|!Skin.HasSetting(animatedbghome)]">Conditional</animation>
  </include>
Then it's exactly the same as in Neon.

Always read the XBMC online-manual, FAQ and search the forum before posting.
Do not e-mail XBMC-Team members directly asking for support. Read/follow the forum rules.
For troubleshooting and bug reporting please make sure you read this first.
find quote
Hunter-Killer Offline
Junior Member
Posts: 42
Joined: Aug 2010
Reputation: 0
Location: UK
Post: #9
Quote:Of course I can disable the animations. My issue is that I shouldn't have to...because this has nothing to do with my hardware specs (which are decent).

Why do you minimise a media centre application like XBMC which plays a hell of a lot of file formats to run a separate media player?

How decent is decent hardware specs?
find quote
escobar Offline
Junior Member
Posts: 29
Joined: Dec 2009
Reputation: 0
Post: #10
Big_Noid Wrote:Okay, just to be clear: you experience this issue with both settings disabled:
Home window options-->Enable background effect (Can increase CPU usage)
Viewtype options--> Enable background effect on panels (Can increase cpu usage)

The option that causes the ken burns effect is in General settings--> Enable animated backgrounds.

Yes. Those are the settings I've used to enable only ken burns effect (with smoke disabled) in Aeon Nox.

The end result is that, while XBMC is hidden, it eats memory at a rate of about 200 K / second. This is slower consumption than smoke effect...but the end result is the same: Once it gets to about 2GB of memory consumption, it crashes.

Again, things are fine while we're actually within XBMC.

Big_Noid Wrote:To test if this causes your issue change this in the includes_animations.xml:
Code:
<include name="Animation_Background">

I have just noticed that Neon has the same problem!
When I tested Neon last night, it had such a slow rate of memory increase, I must have mistook it for stable.

Tonight, I ran a longer test using its various views (with animation). In every case, it displayed the same never-ending memory consumption as Aeon Nox.

So the Ken Burns effect in Neon & Aeon Nox (with or without the suggested code edit) has a slower memory consumption than "smoke effect"...but it still has the same result: peak of 2gb, followed by crash.

This would mean it's an XBMC problem - Not an Aeon problem. My apologies to you Aeon skinners. I'll edit my previous posts to reflect this.

I'll also start another topic in the relevant XBMC forum about this issue.

Thanks, and apologies again.
find quote
escobar Offline
Junior Member
Posts: 29
Joined: Dec 2009
Reputation: 0
Post: #11
Just a little update...even more confirmation this is not an Aeon Nox problem, but an XBMC nightly problem.

When I reverted back to the Dharma XBMC, the memory leak went away. I tried both editions of Aeon Nox (dharma & pre-eden) in the stable XBMC release...no memory leak whatever the animation.

The problem only occurs when using nightly builds of XBMC.

Hope this information helps anyone who has a similar problem.

In case anyone is interested in the memory leak itself, I have submitted a bug report to XBMC developers here: http://trac.xbmc.org/ticket/11779
find quote