Tearing on NVIDIA - no need to disable Composite!

  Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
chessplayer Offline
Junior Member
Posts: 19
Joined: Jul 2011
Reputation: 0
Location: Germany
Lightbulb  Tearing on NVIDIA - no need to disable Composite!
Post: #1
Some people might want to enjoy Compiz but also, when watching TV or videos using XBMC, they (obviously) do not want tearing. An easy solution for this is described in the following thread on ubuntuforums.org. This is actually quite easy.

In short, what must be done is

  1. Install CCSM (Compiz Config Settings Manager)
    Code:
    sudo apt-get install compizconfig-settings-manager
  2. Check the option "Unredirect Fullscreen Window"
    • For Ubuntu, this option is found in the "General" section of CCSM until 10.10 (Maverick). In Natty (due to Unity), it has been moved to the "Composite" section.

      Hope this helps to get the best of both worlds!

-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*
Clients: Atom D525 + ION2 with yaVDR (both 0.3 and 0.4 alpha) and with standard Natty + XBMC + tvheadend :;):
Server: Seagate Dockstar with VDR; Seagate Dockstar with tvheadend :cool:
Test: AMD Zacate with vaapi driver working with XBMC :nerd:
All with Sundtek DVB-C Sticks :nod:
find quote
kosinus Offline
Junior Member
Posts: 4
Joined: Oct 2009
Reputation: 0
Post: #2
That worked for me, simple enough...

Cheers,
e.
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,752
Joined: Dec 2008
Reputation: 23
Post: #3
Nice, I'll update the sticky.
find quote