"Adjust display refresh rate" extremely choppy

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
wildonrio Offline
Senior Member
Posts: 222
Joined: Mar 2008
Reputation: 0
Post: #1
Hi everyone,

Been using XBMC for many years. Took a break for about 6 months and now trying to get back into it. I remember falling in love with the newer option "Adjust display refresh rate to match video" option since it got rid of ALL choppiness once and for all. Not a single judder ever.

I recently tried this in both Dharma and the latest SVN (see sig) and the option now causes extreme choppiness - looks like 5 or so frames per second. Hitting "O" during playback reveals that it's going at 23.976, though that's definitely not what I'm seeing. CPU isn't struggling at all either.

What could be causing this? My TV, video card, and CPU are all the same as before when the option worked flawlessly. I reinstalled Windows and XBMC is all. Thanks in advance.

Version: 20110904-bb1417b
OS: Windows 7 Professional 64 Bit
Display: Samsung LN52B750 52" 240Hz LCD HDTV
CPU: AMD Phenom II X4 965 Black AM3 3.4Ghz 512KB 45NM 125W 4000MHZ
Graphics: PNY XLR8 Nvidia GeForce 9800 GT
Memory: CORSAIR XMS2 4GB (4 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)
Motherboard: ASUS M3A78-EM
find quote
wildonrio Offline
Senior Member
Posts: 222
Joined: Mar 2008
Reputation: 0
Post: #2
After hours of fiddling, I fixed this problem! Under Settings>System>Video output I UNchecked "Use a fullscreen window rather than true fullscreen". I assume that this is checked by default now when it wasn't before. I hope someone else is helped by this information someday.

Version: 20110904-bb1417b
OS: Windows 7 Professional 64 Bit
Display: Samsung LN52B750 52" 240Hz LCD HDTV
CPU: AMD Phenom II X4 965 Black AM3 3.4Ghz 512KB 45NM 125W 4000MHZ
Graphics: PNY XLR8 Nvidia GeForce 9800 GT
Memory: CORSAIR XMS2 4GB (4 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)
Motherboard: ASUS M3A78-EM
find quote
Huguito Offline
Junior Member
Posts: 5
Joined: Sep 2011
Reputation: 0
Post: #3
Thank you sooooo much, I had the same problem and fixed it with your help
I owe you a beer :-D
Cheers
find quote
wildonrio Offline
Senior Member
Posts: 222
Joined: Mar 2008
Reputation: 0
Post: #4
I'm glad I'm not alone in the universe with this problem Smile

Version: 20110904-bb1417b
OS: Windows 7 Professional 64 Bit
Display: Samsung LN52B750 52" 240Hz LCD HDTV
CPU: AMD Phenom II X4 965 Black AM3 3.4Ghz 512KB 45NM 125W 4000MHZ
Graphics: PNY XLR8 Nvidia GeForce 9800 GT
Memory: CORSAIR XMS2 4GB (4 x 1GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400)
Motherboard: ASUS M3A78-EM
find quote
nhenson22 Offline
Junior Member
Posts: 12
Joined: Feb 2012
Reputation: 0
Post: #5
I experienced this problem also with the 'fullscreen window' option checked.

My only problem is that I, and others, use my primary monitor to do things at the same time as XBMC running full screen on my TV. With the 'fullscreen window' option disabled this setup is not possible as Windows automatically minimises XBMC the minute any area on the primary monitor is selected.
Has anyone ever come across a way to get around this?
find quote
ktownhero Offline
Junior Member
Posts: 17
Joined: Feb 2011
Reputation: 0
Post: #6
(2012-03-16 14:35)nhenson22 Wrote:  I experienced this problem also with the 'fullscreen window' option checked.

My only problem is that I, and others, use my primary monitor to do things at the same time as XBMC running full screen on my TV. With the 'fullscreen window' option disabled this setup is not possible as Windows automatically minimises XBMC the minute any area on the primary monitor is selected.
Has anyone ever come across a way to get around this?

I am running Windows 7 and run XBMC on my TV as a second monitor. It works perfectly fine for me, as soon as I start XBMC it opens full screen on the second monitor without affecting my primary desktop. You might want to check into your configuration.

Also, if you think about it, it makes sense that you get choppiness if you use the "full screen window" option. With a "window", XBMC does not have control of the display, your OS does... So, the OS is running your monitor at 30 or 60hz, but XBMC is playing back at 24hz... it doesn't add up. I wonder if the issue resolves itself if you are using a 120hz monitor since 120 % 24 = 0.
find quote
Vimes Offline
Member
Posts: 81
Joined: Feb 2009
Reputation: 2
Post: #7
(2011-12-15 09:21)wildonrio Wrote:  I'm glad I'm not alone in the universe with this problem Smile
You are not indeed as it seems to work for me Smile
find quote