Mac OS X - ViMediaManager - Media Manager for Mac OS X!

  Thread Rating:
  • 18 Votes - 4.72 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
cbr600ds2 Offline
Member
Posts: 68
Joined: Aug 2011
Reputation: 0
Post: #31
I'm not on Lion and I haven't had many crashes. A few pinwheels especially with getting trailers but so far so good. I'm waiting before using it for TV Shows because I don't like how it handles episodes so far.

Oh and I'm on an unRaid server.
find quote
pecinko Online
Donor
Posts: 3,838
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #32
Thanks for implementing folder name search!

There seams to be a problem with non-english titles

"Harry Potter A Fénixův Řád (2007)"

when you copy-paste this into http://www.themoviedb.org/ search field it finds the movie immediately. ViMM seams to have a problem.

I have selected "čeština" (Czech) in general preferences. I suppose it means that search will be attempted in local language with fallback to english?

If I change the movie title to english it finds the movie and fetches localized info if available (Czech plots), which is perfect.

Is there a way to scan all titles? Right now, I'm offered with a list of Movies found and it seams that I must manually fetch metadata for each one.

Once again this is a great app. Many thanks!



EDIT: Just for info, my media is on NAS and I'm using AFP. Running OS X 10.6.8, ViMM 0.5b2

EDIT2: There seams to be a problem with saving of folder.jpg and fanart.jpg (they get saved but size is 0), all is well with Banner, landscape and logo.jpg

My skins:

Amber
Quartz

(This post was last modified: 2011-09-13 11:33 by pecinko.)
find quote
SpoBo Offline
Member
Posts: 54
Joined: May 2006
Reputation: 0
Post: #33
Thx for the quick update! Loving the fact that you're actively working on it Smile

Some issues are cropping up now though:

I notice now though that fetching poster & fanart takes ages and afterwards it creates 0-kb jpg files. I assume this is related to the provider (timeouts) and not a bug in your app since it used to work perfectly yesterday. But is it be possible to not write empty jpg files? That way when I do a rescan hopefully it can skip the ones that have already properly downloaded.

Also, my movie folders are formatted like this: "X-Men First Class (2011) (1080P)". And none of them get recognized automatically. Always have to do a manual lookup. Bummer Sad So perhaps it's necessary to do a bit of sanitizing on the directory names as well and not only the filenames. Sorry Big Grin

I assume a lot of people are going to have the same issue since this formatting is done automatically by tools such as CouchPotato.

Keep up the good work. Looking forward to the next beta!

By the way are you using the Sparkle framework for the updates?
(This post was last modified: 2011-09-13 12:27 by SpoBo.)
find quote
MariusTh86 Offline
Posting Freak
Posts: 803
Joined: Oct 2010
Reputation: 14
Location: The Netherlands
Post: #34
To do a batch search for either Movies or TV shows, select the desired section from the toolbar, then click on the "File" menu and select "Fetch Metadata For All Media"

I'll have a look into the czechian names, I think i can find a solution there.
And I can filter out (1080p) and (720p) in the next update, but i'm not sure which other flags couchpotato uses.

Thanks for letting me know about the image files, specifically that it's probably a timeout.
I'll look into stopping it from making empty images if there's a timeout.

I'm not using sparkle, using my own engine instead which is not as great as sparkle unfortunately.
I'm still looking into how I can get it to work with the programming language i'm using.

Edit:
Actually, the images thing is a bug of mine, i did too much encoding and translated the slash "/" to a different character for titles with "/" in it.

ViMediaManager - The Best Media Manager for Mac OS X
(This post was last modified: 2011-09-13 13:24 by MariusTh86.)
find quote
MariusTh86 Offline
Posting Freak
Posts: 803
Joined: Oct 2010
Reputation: 14
Location: The Netherlands
Post: #35
It seems the API of themoviedb.org doesn't find anything when i'm using the czechian name...

ViMediaManager - The Best Media Manager for Mac OS X
find quote
Broiler Offline
Member
Posts: 51
Joined: Jul 2010
Reputation: 1
Post: #36
I love you!

Was struggling with wine and mono and shit because nothing like this existed on MAC, I was even prepared to start learning how to code my own program! This is the best news I've had in a looong time Smile Laugh
find quote
pecinko Online
Donor
Posts: 3,838
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #37
MariusTh86 Wrote:It seems the API of themoviedb.org doesn't find anything when i'm using the czechian name...

Well, I'm sorry to hear that.

If it helps somehow XBMC scraper have no problems with it and it works on http://www.themoviedb.org/ if you copy-paste string I posted above.

My skins:

Amber
Quartz

find quote
MariusTh86 Offline
Posting Freak
Posts: 803
Joined: Oct 2010
Reputation: 14
Location: The Netherlands
Post: #38
pecinko Wrote:Well, I'm sorry to hear that.

If it helps somehow XBMC scraper have no problems with it and it works on http://www.themoviedb.org/ if you copy-paste string I posted above.

I'll keep looking into it, see what is going wrong and why.
In the mean time, the images should work again in 0.5b3.

ViMediaManager - The Best Media Manager for Mac OS X
find quote
pecinko Online
Donor
Posts: 3,838
Joined: Dec 2008
Reputation: 52
Location: Prague / Belgrade
Post: #39
MariusTh86 Wrote:I'll keep looking into it, see what is going wrong and why.
In the mean time, the images should work again in 0.5b3.

Thanks a bunch I'll give it a go.

Should I post a few suggestions or is it bugfix time for now?

My skins:

Amber
Quartz

find quote
MariusTh86 Offline
Posting Freak
Posts: 803
Joined: Oct 2010
Reputation: 14
Location: The Netherlands
Post: #40
Feel free to post suggestions, but I might not get around to it until after I fix most of the more annoying bugs.

ViMediaManager - The Best Media Manager for Mac OS X
(This post was last modified: 2011-09-13 16:02 by MariusTh86.)
find quote
Broiler Offline
Member
Posts: 51
Joined: Jul 2010
Reputation: 1
Post: #41
I have my TV folder mounted as NFS share from my Linux server. When I tried loading them the program crashed and produced the content of the pastebin link:
http://pastebin.com/Lt3kuzyx

I cant start the program again since it crashes instantly because I was in TV mode last time I had the program open.

Hope this helps debugging!

Thanks alot once again!
find quote
MariusTh86 Offline
Posting Freak
Posts: 803
Joined: Oct 2010
Reputation: 14
Location: The Netherlands
Post: #42
You can try again by removing the preferences file inside the ~/Library/Preferences/ folder called com.vidalvanbergen.vimediamanager.xml
But it seems like ViMM has a bit of a problem with networked drives, I'm guessing that it's adding folders faster than the network can give them.

ViMediaManager - The Best Media Manager for Mac OS X
find quote
Broiler Offline
Member
Posts: 51
Joined: Jul 2010
Reputation: 1
Post: #43
Yeah I got it working by editing that file to use my Movies folder instead. The drive containing my tv-shows is pretty slow, so probably thats the cause.
find quote
Hjord Offline
Senior Member
Posts: 212
Joined: Nov 2009
Reputation: 0
Post: #44
This looks very very good!
My iMac is unfortunately under repair at the moment so i can't try it Sad

Does it support Movie sets?

[Image: widget]
find quote
MariusTh86 Offline
Posting Freak
Posts: 803
Joined: Oct 2010
Reputation: 14
Location: The Netherlands
Post: #45
It doesn't support movie sets yet, but it's on my ToDo list Wink

ViMediaManager - The Best Media Manager for Mac OS X
find quote
Post Reply