Backrow on Crystalbuntu freezing when returning home

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #1
Hello,

First off, great skin. Really like it, by far the best I have tried so far. I am having a small issues though. It doesn't happen all the time but when returning home from various places (programs, tv shows, sometimes videos) the system will lock up for anywhere between 5 seconds to 2 minutes. Problem is when I enable debugging it will not lock up. Disable it and it will go back to locking up again. This is on crystalbuntu on an apple tv with a crystalhd card.

Any help here would be greatly appreciated. I should also note that this doesn't happen on any other skin I have tried.
find quote
Sharpe Offline
Skilled Skinner
Posts: 1,033
Joined: Jul 2006
Reputation: 13
Location: North West England
Post: #2
Hi there - might be an issue with some scripts on the home screen - what version of the skin are you running and are you on Dharma or a nightly build of xbmc?
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #3
I am currently on a nightly. I do not know what scripts run on the home screen. How can I figure this out? Unfortunately I am fairly new to the advanced workings of xbmc. Also version of the skin is 3.4.5
find quote
Sharpe Offline
Skilled Skinner
Posts: 1,033
Joined: Jul 2006
Reputation: 13
Location: North West England
Post: #4
I've updated the skin recently with some changes that might help this issue. The current version from the manual download link is 3.4.6. Hopefully I'll get this version pushed through to the main XBMC repository in a few days or so.
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #5
Sharpe Wrote:I've updated the skin recently with some changes that might help this issue. The current version from the manual download link is 3.4.6. Hopefully I'll get this version pushed through to the main XBMC repository in a few days or so.

I will grab the skin and try it then report back. Hopefully it fixes the issue.
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #6
Installed the newest version. First try and it locked up. Any ideas? Was leaving tvshows
find quote
Sharpe Offline
Skilled Skinner
Posts: 1,033
Joined: Jul 2006
Reputation: 13
Location: North West England
Post: #7
Ok try downloading this and extracting the files inside the rar to the skin's 720P folder. Then try it.

If you still get the same problem then it's something else going on and I'll need a debug log.

Cheers
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #8
unfortunately still freezing. What log do you need and does debugging need turned on?
find quote
Sharpe Offline
Skilled Skinner
Posts: 1,033
Joined: Jul 2006
Reputation: 13
Location: North West England
Post: #9
It's the xbmc.log and yes turn debugging on please.

Cheers
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #10
I will get you the log at some point after I get home. Problem is though if debugging is on I cannot get it to lock up...
find quote
Sharpe Offline
Skilled Skinner
Posts: 1,033
Joined: Jul 2006
Reputation: 13
Location: North West England
Post: #11
Yeah I see your point it's just hard to think what else it could be without a debug log.

Could you try going into skin options and disabling "TV Airing Today" and also "Recent & Random Content" - they are the only things I can think that might cause a hang on the home screen. The only other thing could be if you have picked some custom wallpaper that's stored over a network or is an unusual file.
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #12
I have not forgotten about this. The internet at home has been out. A tech is coming today between 5 and 7 (which really means next week some time) to look at it. I think the line to the house is bad.
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #13
I just got a good freeze. Cleared the log first so it should be shorter. Here it is
http://pastebin.com/N8qyCHJh

Also note that when I started the system I had the network cable unplugged because I didnt want it to grab a new nightly build. Any errors about connecting to mysql databases should be from that.
find quote
Sharpe Offline
Skilled Skinner
Posts: 1,033
Joined: Jul 2006
Reputation: 13
Location: North West England
Post: #14
Oh thanks for that - I'm sorry but I'm struggling to see what's causing the hanging issue though (unless it's an obvious error I tend to draw a blank). I can see it returning to the home screen and running recently added updates then some Unload actions then it runs out - I can't tell from that what's the problem. Perhaps the recently added home widget? Have you tried seeing if you still get the same issue with the recently added stuff disabled?
find quote
Syco54645 Offline
Junior Member
Posts: 10
Joined: Oct 2011
Reputation: 0
Post: #15
Just disabled recently added and it is still hanging. This is frustrating to say the least...
find quote