(Home)Menu link to video or picture folder doesn't show content

  Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
theGuillaume Offline
Junior Member
Posts: 23
Joined: Dec 2010
Reputation: 3
Location: Montréal
Post: #1
Hello
I've just updated from Dharma and I'm having trouble accessing a videos folder and a pictures folder. It worked perfectly on Dharma.

For the pictures folder, even if I set my folder as default folder for my pictures, I always get to the view where there is a list with my pictures folder, "add source", "picture add-ons", etc.. No way it will go to my pictures folder directly.
I tried adding the folder to my favourites, then adding it to the home menu, but accessing it I get this:

[Image: xbmchmm.jpg]

Same with the videos folder, but with a different view.
Can't make a fav link in the home menu to access the folder directly with a list view.
Also, I try to add the fav to that folder in a home submenu and I cannot change the name of it. I press DOWN, the box appears, I rename it, ENTER, and it remains unchanged. If I try to rename it again, it displays the name I tried to gave it before.
(This post was last modified: 2011-11-28 18:49 by theGuillaume.)
find quote
LakersFan Offline
Senior Member
Posts: 261
Joined: Jan 2008
Reputation: 0
Post: #2
Had the same issue (with the videos) and Big Noid said it was a bug. To fix, be sure to add the videos as a favorite. Then open up the favourites.xml and remove quotes around the affected folder. Then go back to customize the home menu and add the favorite.

Removed quotes:

Old
Code:
<favourite name="Videos">ActivateWindow(10025,&quot;H:\\Videos\\&quot;)</favourite>

NEW
Code:
<favourite name="Videos">ActivateWindow(10025,H:\\Videos\\)</favourite>


http://forum.xbmc.org/showpost.php?p=942...count=4047
find quote
BigNoid Offline
Team-Kodi Member
Posts: 3,189
Joined: Jul 2010
Reputation: 105
Location: Below sea level
Post: #3
Just to be clear, this is not a skin bug, but an bug in the way non library folders are are added to favorites in XBMC.
find quote
LakersFan Offline
Senior Member
Posts: 261
Joined: Jan 2008
Reputation: 0
Post: #4
Yes, sorry I didn't mention it that way. Smile
find quote
theGuillaume Offline
Junior Member
Posts: 23
Joined: Dec 2010
Reputation: 3
Location: Montréal
Post: #5
It worked for both the videos and pictures. Thanks alot. I would never have found the problem myself.
find quote
LakersFan Offline
Senior Member
Posts: 261
Joined: Jan 2008
Reputation: 0
Post: #6
Awesome, glad it worked for you!
find quote
kavond Offline
Junior Member
Posts: 40
Joined: Sep 2011
Reputation: 0
Post: #7
Is this going to be fixed before the eden final is released? This bug is still in beta 2.
find quote
live4ever Offline
Fan
Posts: 674
Joined: Sep 2006
Reputation: 6
Post: #8
kavond Wrote:Is this going to be fixed before the eden final is released? This bug is still in beta 2.

Maybe ask ronie (in the Transparency thread), he fixed this bug in the favourites script for me:
http://forum.xbmc.org/showpost.php?p=919...tcount=537
find quote
parslej Offline
Member
Posts: 93
Joined: Aug 2011
Reputation: 4
Post: #9
Thanks this helped me too.

Had this issue with RC-2 shoudnt this be fixed in final version?
find quote
jaylucan Offline
Junior Member
Posts: 1
Joined: May 2012
Reputation: 0
Post: #10
This one post solved something thats been taking me a day to figure out...
Thank you very much! Smile
find quote
Brad P Offline
Donor
Posts: 194
Joined: May 2009
Reputation: 0
Post: #11
Sorry to bump a sort-of old thread but I had the same problem. One favourite is now fixed but another uses an apostrophe. The favourite comes up as D:\\Brad&apos;s Files\\My Documents but the custom menu setting shows it as D:\\Brad\'

Replacing with an apostrophe does not work.

Plan B is to move the source folder.

Desktop / HTPC: Win7 x86, Cooler Master Storm Sniper Black Edition case, Asus P5Q Pro, Intel C2Q q8300, Asus 4550HD, Asus 3450HD, CM M 1000w, 4GB GSkill, 2x Seagate 7200.11 1TB Raid 1, Samsung SSD 240GB, SPM393 Raid Controller w/ 1 Samsung 2TB, 4 1.5TB for a 7.2TB media volume

XBMC as of May 2014 - 12.2 Frodo
find quote
jinux Offline
Junior Member
Posts: 18
Joined: May 2012
Reputation: 0
Post: #12
I have a folder called : Onze Videos. I made this a add to favorites.
then i set in custom 1 as favorite this favorite Onze Videos
when i select Onze Videos in the home screen, i get a screen with all sorts of windows but not my Onze videos.

In Aeon nox 2.0 everything worked fine, very irritating aeon nox update itself to 3.0.
cannot rollback,

the fix with in favorites,xml to get the quotes removed also does not work.

is there away to get aeon nox 2.0 back ? or fix the folder to favorites error ?

all the time i read it is not a skin problem, but with every other skin it works ok, only since aeon nox updatet itself it stopped working please help me ?

http://imageshack.us/photo/my-images/576...nnox3.jpg/
(This post was last modified: 2012-05-28 10:51 by jinux.)
find quote
jinux Offline
Junior Member
Posts: 18
Joined: May 2012
Reputation: 0
Post: #13
Got it, thanks to Phil :

http://forum.xbmc.org/showthread.php?tid...pid1113777

To be old and wise, one must first be young and stupid !
find quote