[RELEASE] Official XBMC boblight Addon

  Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
atoulmin Offline
Member
Posts: 51
Joined: Sep 2015
Reputation: 0
Post: #1516
Hi I'm looking at setting this up with. Looking at the options can I have a static backlight color when I'm the Kodi menu, that turns off with screensaver and turn off when playing movie tv shows etc? Like theatre mode with the hue lights.
(This post was last modified: 2017-01-30 06:13 by atoulmin.)
find quote
Memphiz Offline
Kodi MVP
Posts: 15,935
Joined: Feb 2011
Reputation: 221
Location: germany
Post: #1517
Yes this is possible

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote
atoulmin Offline
Member
Posts: 51
Joined: Sep 2015
Reputation: 0
Post: #1518
(2017-01-31 08:18)Memphiz Wrote:  Yes this is possible

Thanks I'll see how it goes
find quote
Saiz08 Offline
Junior Member
Posts: 1
Joined: Feb 2017
Reputation: 0
Post: #1519
Hey guys I have a really strange issue. I have a clean install of windows 10 and a clean install of Kodi 17. When I go to install this add-on it prompts that it needs the library. I know it won't download it right so I manually download the file and extract it to the folder. Every time Kodi boots it prompts to install the library. I can not get boblight to work on this pc. I already re-installed windows and Kodi today and the issue persisted. My other two computers I was able to setup boblight/kodi fine and it works properly. On this PC I have eveything setup and working except the boblight addon for kodi. Any ideas on how I can force it to find the library?


Edit: Went back to Kodi 16.1 and it works properly. Weird.
(This post was last modified: 2017-02-03 23:51 by Saiz08.)
find quote
Memphiz Offline
Kodi MVP
Posts: 15,935
Joined: Feb 2011
Reputation: 221
Location: germany
Post: #1520
Is this from the appstore?

AppleTV4/iPhone/iPod/iPad: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for Kodi: NFS (wiki)
HowTo configure avahi (zeroconf): Avahi_Zeroconf (wiki)
READ THE IOS FAQ!: iOS FAQ (wiki)
find quote
johnjohn22 Offline
Junior Member
Posts: 22
Joined: Jan 2017
Reputation: 0
Post: #1521
Hey there!

Planning on building an ambilight setup for my livingroom. I have been looking for tutorials etc., but I cannot really find anything that is up to date and elaborate enough to get me started.

I have a 4K UHD TV(Sony), with an AVR receiver connected and an NVIDIA Shield hooked up to it. I am running SPMC on the Shield for all my media. Also I do have a Raspberry Pi 3 lying around.

Can anyone guide me about which LED's and what other stuff I need to buy to get going? And also, if anyone can link me to a guide to getting it set up, that would be awesome.

Thank you in advance, and my apologies if the information is widely available, and that I am just being blinded by the massive amount of info.
find quote
TDXX81 Offline
Junior Member
Posts: 1
Joined: Feb 2017
Reputation: 0
Post: #1522
Hey all,

I'm running Ubuntu 16.04.2 with Kodi v17 and 2.0.16 version of the Kodi Boblight plugin. Kodi connects to boblightd and I it cycles through colors. It will even do the static solid color background if I configure it. When I play a video, the lights change to match something close to the first frame and then they never update again. If turn on debugging in the boblight.conf, I can see what looks like it's writing the same data to the lights and the lights themselves never change. This all worked before when I was on Ubuntu 14.04 and Kodi v16.2, but I did a clean install of the OS went straight Kodi 17, so I'm not sure if it misconfiguration or one or both of the new versions.

I've tried recompiling boblight multiple different ways and from different sources, but haven't made any progress. Is this just a Kodi 17 thing? Has anyone experienced anything similar or have any suggestions? Thanks.

EDIT: it appears to be a krypton thing. If I roll back to v16, everything works normally.
(This post was last modified: 2017-03-09 04:28 by TDXX81.)
find quote
dan9550 Offline
Junior Member
Posts: 6
Joined: Aug 2013
Reputation: 0
Post: #1523
Has anyone else had an issues with a massively delayed response (seconds) from the LEDs? I'm wondering if the baud rate (115200) on my Arduino setup is to slow, as i'm using 240 LEDs total. When i run boblightd with debugging enabled it almost looks as if Kodi Boblight isn't sending out the updates quick enough. Any insights or advice would be appreciated!
find quote
dan9550 Offline
Junior Member
Posts: 6
Joined: Aug 2013
Reputation: 0
Post: #1524
(2017-03-11 13:41)dan9550 Wrote:  Has anyone else had an issues with a massively delayed response (seconds) from the LEDs? I'm wondering if the baud rate (115200) on my Arduino setup is to slow, as i'm using 240 LEDs total. When i run boblightd with debugging enabled it almost looks as if Kodi Boblight isn't sending out the updates quick enough. Any insights or advice would be appreciated!

Actually after i updated Kodi (I was on some RC build of 17.0) and my kernel plus some other bits and rebooted. Not sure what did it but after one of these i'm not having any issues with the refresh rate of the LEDs, However i think they may need to be mirrored horizontally (i'm yet to mount it on the back of the TV but i'm 90% sure this is the case. Has anyone had to do this before?
find quote
Miguel torres Offline
Junior Member
Posts: 1
Joined: Mar 2017
Reputation: 0
Post: #1525
(2012-11-25 04:19)Specterx Wrote:  Here is the hardware I used to make my boblight setup for XBMC:

all ordered from DX.com for $58.

12MM RGB Bare Point Source Red/Green/Blue 50-LED String light

Arduino Compatible UNO Rev3 Development Board

5V 3A Wall Power Adapter for Scanner / Router + More (US Plug / 5.5 x 2.1mm)

Male + Female DC Power Converter Connector Adapters w/ Terminal Blocks For CCTV Camera (Pair)

The LEDs are LPD6803. cheap and works great.

Hello Friend. You could provide the steps that make to use the leds 6803. eh tried to make it work but without success. I would very much appreciate the information


Please
find quote
djcorvus Offline
Member
Posts: 87
Joined: Jul 2009
Reputation: 0
Post: #1526
Hi guys,
I'm new to Boblight.
Currently running an Adalight build with Arduino Uno (as per Adafruit's instructible).
I've been using Ambibox with the Kodi plugin so far, but apparently the latest version of Kodi (Krypton) is no longer compatible with the method that the Ambibox plugin extracts color info for its zones, making it unusable.
I would normally just use the Windows desktop capture mode to get around this, but I really need the function of the Kodi addon so that it can automatically detect aspect ratio of the content and adjust accordingly.

Can anyone confirm if Boblight is unaffected by these changes in the latest Kodi version?

Also, what is needed besides the Boblight addon? I'm assuming that I'll no longer be needing Ambibox. Do I also need Boblightd? I've tried looking everywhere but can't find an .exe or .zip file to install it (running Windows 10 64bit).

Any help is greatly appreciated.
(This post was last modified: 2017-04-09 04:25 by djcorvus.)
find quote
wolfgr Offline
Junior Member
Posts: 47
Joined: Mar 2012
Reputation: 0
Post: #1527
hello,i am using boblight at my windows htpc + kodi and its working great.My setup is 105 leds driven from a arduino mega.The thing is that i want to upgrade to a nice powerfull and smaller android tv box but i dont want to lose boblight.Can i use a raspberry pi to drive my leds and host boblightd and run boblight at the android box kodi?Is there a tutorial for that?
find quote
ijourneaux Offline
Fan
Posts: 656
Joined: Mar 2009
Reputation: 4
Location: Wisconsin, USA
Post: #1528
(2017-02-13 00:10)johnjohn22 Wrote:  Hey there!

Planning on building an ambilight setup for my livingroom. I have been looking for tutorials etc., but I cannot really find anything that is up to date and elaborate enough to get me started.

I have a 4K UHD TV(Sony), with an AVR receiver connected and an NVIDIA Shield hooked up to it. I am running SPMC on the Shield for all my media. Also I do have a Raspberry Pi 3 lying around.

Can anyone guide me about which LED's and what other stuff I need to buy to get going? And also, if anyone can link me to a guide to getting it set up, that would be awesome.

Thank you in advance, and my apologies if the information is widely available, and that I am just being blinded by the massive amount of info.

Were you ever able to get you amilight setup to work with an NVIDIA Shield. I am trying to move my main HTPC from WIndows (where Boblight works lie a champ) to the NVidia Shield (sImplier setup).
Was hoping to get the ambient lighting to work with the Shield.
find quote
johnjohn22 Offline
Junior Member
Posts: 22
Joined: Jan 2017
Reputation: 0
Post: #1529
(2017-05-10 05:56)ijourneaux Wrote:  
(2017-02-13 00:10)johnjohn22 Wrote:  Hey there!

Planning on building an ambilight setup for my livingroom. I have been looking for tutorials etc., but I cannot really find anything that is up to date and elaborate enough to get me started.

I have a 4K UHD TV(Sony), with an AVR receiver connected and an NVIDIA Shield hooked up to it. I am running SPMC on the Shield for all my media. Also I do have a Raspberry Pi 3 lying around.

Can anyone guide me about which LED's and what other stuff I need to buy to get going? And also, if anyone can link me to a guide to getting it set up, that would be awesome.

Thank you in advance, and my apologies if the information is widely available, and that I am just being blinded by the massive amount of info.

Were you ever able to get you amilight setup to work with an NVIDIA Shield. I am trying to move my main HTPC from WIndows (where Boblight works lie a champ) to the NVidia Shield (sImplier setup).
Was hoping to get the ambient lighting to work with the Shield.
I tried some different stuff. But eventually I ended up buying a Lightberry HD kit and use that with a Raspberry Pi 3 with the OS and everything they provide. Actually now I want to get rid of the Raspberry and use the Lightberry straight with my HTPC. At the same time I am replacing my NVIDIA Shield with an Intel NUC with Windows 10, so I have to figure out how to get that to work.
With the Raspberry in the system, the raspberry is running Hyperion and I was then running Hyperion plugin inside KODI on my Shield to use the Lightberry remotely over LAN. It worked fine. But now that I am replacing the shield and removing the Pi, then I need to find another software than Hyperion, as that is Linux only for the backend.

Maybe you can tell me if I can run bob light on the NUC and make that light up my Lightberry? The leds are just USB through a apa102
find quote
pauldgroot Offline
Junior Member
Posts: 2
Joined: May 2017
Reputation: 0
Post: #1530
I'm running Kodi on a Intel NUC with Windows 10 Professional freshly installed and I'm having the same problem more people over here were having. Every time I start Kodi it asks me to download the binary which I accept and then nothing happens.

I've checked my lib folder in appdata and the dll is present, manually downloading and pasting it in there doesn't fix the issue. I've also tried installing Visual C++ 2010 and 2015 since someone suggested that. The deamon is succesfully connecting to my Arduino so that's not the issue.

Here is a log: http://www.pastebin.com/q10LgdqM
find quote
Post Reply