[RELEASE] Official XBMC boblight Addon

  Thread Rating:
  • 2 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Post Reply
trouty00 Offline
Junior Member
Posts: 12
Joined: Mar 2010
Reputation: 0
Post: #91
Seems like I have fixed that issue now too. I have upgrade to Eden and got the option,

I downloaded the arduino s/w on linux and updated the pde file from the source and also moved the mega conf file but I am only getting a green output, its working from XBMC but only green.

I also can only get green from the terminal even but only when I issue the boblight-constant FF0000 which should actually be only giving me RED.

I know the wiring is fine as it worked fine with the amblone pde and windows s/w.

any thoughts?
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #92
Probably need to change
Code:
#ifdef __AVR_ATmega1280__
into
Code:
#if 1

For some reason that #ifdef doesn't work anymore.
find quote
trouty00 Offline
Junior Member
Posts: 12
Joined: Mar 2010
Reputation: 0
Post: #93
bobo1on1 Wrote:Probably need to change
Code:
#ifdef __AVR_ATmega1280__
into
Code:
#if 1

For some reason that #ifdef doesn't work anymore.



great that worked, thanks, seems like there are a few bits which are not clear/updated, I know its hard but may save you guys some bother in the long run!

I was also having a flickering problem as i was running boblightd& but when i lost the & it worked fine.

thanks for the help!
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #94
You can also use boblightd -f to start it in the background.
find quote
regnets Offline
Senior Member
Posts: 197
Joined: Feb 2011
Reputation: 1
Location: Ratingen, Germany
Post: #95
Hi,

at first, thank you for the great addon. That makes XBMC really special.

I have a bug:
In XBMC Menus the LED aren't lighting up. I activated the static light in the settings.

Here is my xbmc.log, you need anything else?
http://pastebin.com/5NyCMrRH

And i like to add a feature request:
I'll like to have boblighting in the menues. Not only static colors.

greetz

regnets
find quote
kimp93 Offline
Aeon Group
Posts: 157
Joined: Mar 2004
Post: #96
bobo1on1 Wrote:Yeah probably not, I don't have time to support windows anymore.
Compiling boblight on cygwin should work though.

I'm compiling boblightd on cygwin. Would you advise me on following error?
It seems cygwin have not implement 'pthread_mutex_timedlock’

Quote:util/mutex.cpp: In member function ‘bool CMutex::Lock(int64_t)’:
util/mutex.cpp:89:52: error: ‘pthread_mutex_timedlock’ was not declared in this scope
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #97
regnets Wrote:I have a bug:
In XBMC Menus the LED aren't lighting up. I activated the static light in the settings.

1. Impressive your setup with 25 lights - how cool Smile
2. This is not a general bug - this works for me. Verify that you've setup the RGB sliders and wait a bit - colors fade in very smooth and slow to the configured RGB color.

If it still doesn't work post a bit more about your setup. Does it work during video Playback?

regnets Wrote:And i like to add a feature request:
I'll like to have boblighting in the menues. Not only static colors.

Yeah that would be a dream. But we can dream on. If this was possible with a snip - i wouldn't have implemented the static color. We can't capture the image when not rendering. Rendering only happens when a video is played. So no - its not possible during menu and its not possible during music or music visualisation. At least for now or until someone comes up with an idea how to change it.

PS: next time please post a uncut full log...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
(This post was last modified: 2012-01-11 14:58 by Memphiz.)
find quote
bobo1on1 Offline
cheapass Team-XBMC Developer
Posts: 2,758
Joined: Dec 2008
Reputation: 22
Post: #98
kimp93 Wrote:I'm compiling boblightd on cygwin. Would you advise me on following error?
It seems cygwin have not implement 'pthread_mutex_timedlock’

Fixed in http://code.google.com/p/boblight/source/detail?r=409
find quote
kimp93 Offline
Aeon Group
Posts: 157
Joined: Mar 2004
Post: #99
bobo1on1 Wrote:Fixed in http://code.google.com/p/boblight/source/detail?r=409

Thanks for quick fix. boblightd compiled and seems working.
I tested with Eden beta, boblight addon, and arduino PWM sketch.
Very rough boblightd for windows : http://www.multiupload.com/HH7JTNKC4G
mirror : http://www.mediafire.com/?c6c19gagq2bm08a
https://www.box.com/s/3mpckxp7d0yyzsl71rq8

edit: forgot to include cygwin dlls. the file link is updated
edit2: more mirrors.
(This post was last modified: 2012-01-24 21:28 by kimp93.)
find quote
regnets Offline
Senior Member
Posts: 197
Joined: Feb 2011
Reputation: 1
Location: Ratingen, Germany
Post: #100
Memphiz Wrote:1. Impressive your setup with 25 lights - how cool Smile
2. This is not a general bug - this works for me. Verify that you've setup the RGB sliders and wait a bit - colors fade in very smooth and slow to the configured RGB color.

It is not that impressive, it is a led strand with controllable LEDs. Just search for adalight - very simple and easy to use ambilight solution. In the next few days i ger my second strand with 25 more leds.

Memphiz Wrote:If it still doesn't work post a bit more about your setup. Does it work during video Playback?

Now it is working i have to reset the arduino between movie playback and the menues. I think it is a problem with the arduino code.


Memphiz Wrote:Yeah that would be a dream. But we can dream on. If this was possible with a snip - i wouldn't have implemented the static color. We can't capture the image when not rendering. Rendering only happens when a video is played. So no - its not possible during menu and its not possible during music or music visualisation. At least for now or until someone comes up with an idea how to change it.

Yeah bobo1on1 told me that in irc, just wanted to mentioned, that this would be a great feature.

Memphiz Wrote:PS: next time please post a uncut full log...
It was a full log?!?!

greetz

regnets
find quote
Memphiz Offline
Team-Kodi Developer
Posts: 11,277
Joined: Feb 2011
Reputation: 115
Location: germany
Post: #101
regnets Wrote:It was a full log?!?!

Really? Then it either crashed or you grabbed the log while xbmc was still running. Sorry then ...

AppleTV2/iPhone/iPod: HowTo find debug logs and everything else which the devs like so much: click here
HowTo setup NFS for XBMC: Wiki NFS
HowTo configure avahi (zeroconf): Wiki Avahi
READ THE IOS FAQ!: iOS FAQ
find quote
regnets Offline
Senior Member
Posts: 197
Joined: Feb 2011
Reputation: 1
Location: Ratingen, Germany
Post: #102
Oh yeah... so it wasn't a full log, you are absolutely right. XBMC was running, my girlfriend was watching tv. Rolleyes
find quote
regnets Offline
Senior Member
Posts: 197
Joined: Feb 2011
Reputation: 1
Location: Ratingen, Germany
Post: #103
Hi,

i am using boblight for about a week, it is really great!

I just discovered that dark scenes in movies are not dark enough Big Grin. As example: If i see a really dark scene my led are still lighting a bit up. I tried to change the settings in the boblight addon. So far every change seems to make the light brighter as the default settings. Am i doing anything wrong? Did i misinterpret the settings?

Thank you!

regnets
find quote
m_K_o Offline
Local lemming
Posts: 10
Joined: Dec 2010
Reputation: 0
Location: Finland
Post: #104
I'm having troubles installing boblight on latest XBMCbuntu (from http://www.xbmcfreak.nl/en/).
./configure stops with:
Code:
configure: error: Missing a required library, please install it or disable X11 support by passing --without-x11 to configure
As far as i know, x11 is installed.

edit. chmod did the trick

edit2. also had to install build-essential and g++
(This post was last modified: 2012-01-21 21:40 by m_K_o.)
find quote
Lunatixz Offline
Posting Freak
Posts: 2,980
Joined: May 2011
Reputation: 51
Location: New York
Post: #105
anyone developing a bobolightd for windows? their is a compiled version posted by kimp but it doesn't seem to work...
find quote
Post Reply